System Requirements and Compatibility

Hardware Requirements

CIMPLICITY v11.0 requires, at a minimum, the following hardware specifications. GE Digital recommends testing your particular system to determine if your performance needs require hardware beyond the base system recommendations.

Hardware Requirements
Microprocessor Intel Core 2 Duo 3.0 GHz
RAM 4 GB
Hard disk 40 GB
Ports
  • USB port, if using a USB M4 or M5 license or a green key.

  • Serial port for some touch screens, pointing devices, and I/O drivers

  • Additional ports for I/O hardware

Monitor
  • Color graphics monitor, SVGA or better

  • 24-bit graphics card capable of 800 x 600 resolution

Supported Operating Systems and Versions

CIMPLICITY v11.0 runs on any of the following operating systems, provided that specified revisions and service packs are included.

  • Microsoft® Windows® 10 (32-bit or 64-bit), Professional, Enterprise & Ultimate Editions

  • Microsoft® Windows® 8.1 (32-bit or 64-bit), Professional, Enterprise & Ultimate Editions

  • Microsoft® Windows® Server 2019

  • Microsoft® Windows® Server 2019 Cluster

  • Microsoft® Windows® Server 2016

  • Microsoft® Windows® Server 2016 Cluster

  • Microsoft® Windows® Server 2012 R2

  • Microsoft® Windows® 10 IoT Enterprise (LTSB) (Only full blown IoT version is supported. Not the core & mobile versions)

.NET Installation

NET 3.5 SP1 is required for the CIMPLICITY installer.

Supported External Software Versions

CIMPLICITY v11.0 is compatible with the following external software.

External Software Supported Version
Microsoft Office 2016
Microsoft SQL Server

2014, 2016, and 2017

Important: SQL Server 2008 can be installed but is no longer supported.
Note: CIMPLICITY has been validated to work with Database configurations using SQL 2016 AlwaysOn with the exception of the Tracker Attribute Database (TADB) functionality.
SQL Express 2014, 2016, and 2017
Oracle

12c

Note:

  1. Oracle 12c is the only version supported by CIMPLICITY 11.0.
  2. Both the client and server should be running Oracle 12c.
Microsoft Visual Studio 2017
Flexera Software - Install Shield 2018
Sequent - Alarm Cast 10.01.01

Supported GE Software Versions

CIMPLICITY v11.0 is compatible with the following GE software.

GE Software Supported Version Install Before or After CIMPLICITY
Alarm Cast Administrator 10.01.01 After
Change Management 9.5 Before
Common Licensing Latest version With CIMPLICITY
Driver Server Latest version Either
Global Discovery Server 2.2 After
Historian (full version)

8.0, 7.2 (Latest SIM), 7.1 (Latest SIM), and 7.0 (Latest SP/SIM)

Note: Logging array points to Historian is supported from version 7.0 onwards.

Either
IGS OPC Server Latest version Either
Machine Edition 9.5 and 9.0 Either
Plant Apps 7.0 latest Service Pack Either
Portal 3.5 SP5 Either
Proficy Driver Server (PDS) Latest version With CIMPLICITY
Web HMI/OPSHUB 2.2/1.1 Either
Webspace 6.0 & 5.0 After

Compatibility Requirements

Note the following as they apply to your installation:

Element Requirement
Network Communication I/O

Allen-Bradley Ethernet Driver

Note the following:

  • RSLINX OEM 3.80.00 is required.

  • Rockwell requires a Factory Talk activation for RSLINX OEM. If RSLINX OEM is not activated, the Allen-Bradley Ethernet device communication interface will not run. Allen-Bradley Internet is supported on the following operating systems:

Windows 2019

Windows 8.1

Windows 10

Server2012R2

Server 2016

Windows 10 IoT, LTSB

Note: Depending on the OS, some RSLINX OEM features may not be supported. Refer to the RSLINX documentation for further information.
Genius PCI

If you are using Genius PCI communications you need:

  • One full height PCI slot for each port (up to four)

  • One Genius PCI card (IC660ELB931)

Note: Genius PCI is only supported on 32-bit Windows 7 and Windows 10 systems.
Reflective Memory

If you are using reflective memory, the card requirements are:

  • PCPCIE-5565PIORC requires a low profile PCI Express Slot for each card

  • PCI-5565PIORC requires a 64-bit PCI slot for each card

  • PCIE-5565RC requires a PCI Express Slot.

Note: You can install up to two reflective memory cards, but not all computers support two cards due to hardware or BIOS-specific limitations. The Reflective Memory driver is only supported on Windows 7 and is no longer packaged with CIMPLICITY. However, the package is available from Abaco, who is also the vendor for the reflective memory cards.

You must install the following package:

RFM2G Windows 7/XP/Vista/Server 2008/Server 2003/32/64-bit PCIE/PCI/PMC Driver for X86 R08.01.

DDE Communications

The DDE communications interface runs in the service session only. The DDE server must be able to run from the service session.

Browsers

The following browsers are supported for WebSpace with CIMPLICITY.

  • Google Chrome 66 or Greater
  • Microsoft Edge 41 or Greater
  • Firefox
  • Safari

The following browsers are supported with the SCADA Web Configuration:

  • Google chrome 76 and above
  • Safari 10 and above, MacBook only (not iPad or iPhone)
  • Microsoft Edge on Windows 10 - 44.x
  • Firefox 67