Software Requirements

Server Operating Systems

Important: Since operating systems have continuous updates, be sure to run the Windows update feature to get the latest software.
  • Microsoft® Windows® Server 2019 Standard
  • Microsoft® Windows® Server 2016 Standard
  • Microsoft® Windows® Server 2012 R2 Standard
  • Microsoft® Windows® 10 (64-bit only)
  • Microsoft® Windows® 8.1 (64-bit only)
  • Microsoft® Windows® 7, SP1 (64-bit only)

Be aware that:

  • Windows Server operating systems are recommended for multi-user environments.
  • The Webspace Server is not supported on 32-bit operating systems.
  • Make sure you have the latest Windows updates and certificates installed (and that your certificate paths are correct). Webspace has been validated using the latest updates as of August 2019.

Browsers

  • Microsoft® Windows® Internet Explorer 11 (32-bit)
  • Mozilla® Firefox® 52 and later (standard and ESR, 32-bit and 64-bit)
  • Apple Safari 9 or later on Mac OS X
  • Google Chrome with Windows 7, Windows 8.1, Windows 10, and Chromebook
  • Microsoft Edge

Client Operating Systems

  • Microsoft® Windows® 10 Pro and Enterprise (32-bit/64-bit)
  • Microsoft® Windows® 8.1 Pro and Enterprise (32-bit/64-bit)
  • Microsoft® Windows® 7 with Service Pack 1 (32-bit/64-bit)
  • Mac OS X 10.10 and later
  • Red Hat Enterprise Linux and 6 and 7 (64-bit)
  • CentOS 6 and 7 (64-bit)
  • SUSE Linux Enterprise Desktop 12 (64-bit)
  • Ubuntu 16.04 LTS and 18.04 LTS (64-bit)
    Note: The following operating systems are not supported for Webspace client sessions: Windows Pocket PC and Windows CE.

Web Server Software

  • Microsoft® .NET Framework 4.5 installed on your Web Server.
  • Microsoft Internet Information Server (IIS) 7.x, or 8.x.
  • Apache HTTP Server 2.x.
Important: Apache and IIS Web servers and their sub-components (such as, OpenSSL) must be maintained and patched as per the latest security guidelines provided by their respective software vendors. The security of Webspace sessions depends on the security that the web servers provide.

Mobile Operating Systems

  • Apple iOS 9.0 or later, including the iPad, iPhone, and iPod Touch.
  • Android version 7.xx or later, and 4GB of memory or greater. (Webspace Android Client only supports ARM processors.)

For iPad tablets, you must install the CA certificates on the iPad clients to establish a trusted connection and to receive live data.

Support for Applications Using DirectX

Applications that use DirectX,such as Microsoft Office 2013 or Office 2016, will not run in Webspace sessions on Windows Server 2008 R2 or Windows 7 when Windows Update KB 2670838 is installed. To work around this issue, uninstall KB 2670838.

Background: Windows Update KB 2670838 replaces the user-mode DirectX runtime with a version that requires display drivers to support DirectX. The Webspace display driver does not support DirectX in versions 4.71 and earlier. Beginning in version 4.8, the Webspace display driver supports DirectX, but only on Windows 8, Windows 8.1, Windows Server 2012 and Windows Server 2012 R2. The Webspace driver only supports DirectX on these versions of Windows because it relies on a Windows component that is not available in earlier versions of Windows.

Other GE Software Requirements

  • Network interface software for network communication and certain I/O drivers for your GE applications. TCP/IP must be enabled as a network protocol on your computers in your setup. Configure any external firewall and any software firewall on the server to allow TCP port 491. (By default, Webspace listens on registered port 491 for TCP packets.)
  • Administrators must have administrative rights on the server to perform the installation.
  • The ASP .NET feature must be enabled on your Web Server.
  • Proper GE licensing software must exist on all computers in your setup.
  • If you are using third-party software along with Webspace, make sure that the third-party software is also supported for the operating system you are running Webspace on. For instance, if you are running Webspace on Microsoft Windows 8.1, your third-party software must also be supported on Microsoft Windows 8.1.
  • An I/O driver for SCADA servers. GE supplies I/O drivers for many programmable controllers, or you may purchase a driver separately.

Compatibility with Other GE Products

GE Digital Product Required Version
CIMPLICITY 9.5 or greater.
iFIX 5.9 or greater.