Compatibility with Other GE Products

Several GE products work with Historian. The following is a general set of required versions to work with Historian.

Important: If you want to enable the Strict Authentication feature in Historian 7.2, be aware that you will need to apply the latest SIMs that support this feature for all Proficy clients that connect to the Archiver, including the ones listed in this table. In addition, there may be SIMS to allow pre-5.0 collectors and client applications such as Excel Add-In to connect. Refer to the SIM download page for update for Historian and other Proficy products.
ProductSupported Version
CIMPLICITY 9.0, 10.0
iFIX5.9, 6.0, 6.1
Plant Apps PA 7.2 SP5 SIM4, PA 8.0
Workflow2.5 SP4, 2.6
Operations Hub1.5

* For customers using iFIX, there was a change in the HKEY_CURRENT_USER registry values for WebSpace and it will no longer work with the existing SIM. Ensure that you get the latest iFIX SIMs. The following article provides additional instructions: https://ge-ip.force.com/communities/en_US/Article/iFIX-Webspace-Strict-Historian-Authentication

** For Plant Apps customers using the ‘Historian Type = ‘GE Proficy – Historian 3.0’ to connect to Historian 7.2, both the Enabled and Disabled options for Enforce Strict Client Authentication selection are supported.

** For Plant Apps customers using the ‘Historian Type = ‘GE Proficy – Historian’ to connect to Proficy Historian 7.2, only the Disabled option for Enforce Strict Client Authentication selection is supported.

In Historian 5.0, the Historian HKEY_CURRENT_USER registry key values were changed. The programs accessing the server collection through the SDK are unaffected. Any program or script that directly accesses the registry keys or any Terminal Server login scripts that try to configure a list of servers by importing registry keys directly will no longer work. Such programs need to access the server collection via SDK calls, not directly.