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Chapter 1. CIMPLICITY Runtime Login
About CIMPLICITY Runtime Login
CIMPLICITY provides a runtime login requirement as one of its runtime security features.
When the project is running and the first time a user attempts to access any of the CIMPLICITY
runtime applications, a CIMPLICITY® Login dialog box displays asking for the User ID and
password.
After the user successfully enters a User ID and password and gains access to the runtime, feature,
the level of available runtime privileges is determined by the user's role.
• Login requirements and privileges configuration.
• Runtime login procedure.
• Use the CIMPLICITY® Login dialog box.
Note: The runtime login is a counterpart to configuration security, which requires a user to login
to do configuration.

Login Requirements and Privileges Configuration
By assigning privileges to roles and roles to users , you, the system administrator, can allocate
privileges for CIMPLICITY runtime applications.
You can enter the required User ID and password when you configure users. During runtime a user
will have to enter the correct User ID and password in the CIMPLICITY® Login dialog box in order
during the first time attempt to enable a runtime application.
Review additional login configuration information for:
• CimView.
• Alarm Viewer (stand alone).
• Alarm Viewer (OCX Control).
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• Clients.

Runtime Login Procedure
A user will be asked to login to any of the following applications when it is the first time that an
application is opened during a runtime session. Once the user is logged into that session access is
available to all of the runtime features for which the user role has privileges.
Runtime Application

CIMPLICITY® Login Dialog Box Displays when a user:

CimView

Tries to open a CimView screen that contains points.

Alarm Viewer (stand alone)

Clicks Login! on the Alarm Viewer menu bar.

Alarm Viewer (OCX Control)

Tries to open an Alarm Viewer CimView screen.

Alarm Sound Manager

Tries to add a project.

Point Control Panel

Tries to add points.

Show users

Tries to open a project.

Process Control

Tries to connect to a project.

PRT_UI

Tries to open the window.

RCOUI

Tries to open the window.

Note: Login for CIMPLICITY remote access, such as Terminal Services, depends on the system
administrator's configuration.

CIMPLICITY® Login Dialog Box
1. Enter your User ID.
2. Enter your user Password.
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You can now access the CIMPLICITY runtime features for as long as you are working in (and
logged into) the current runtime session.
When you walk away from your computer you can easily log out of CIMPLICITY if you need to
protect your runtime usage privileges.
CAUTION: If you check Save User ID + Password you do not have to log into any
CIMPLICITY runtime features as long as your user ID is logged into Windows. However, use this
option very carefully, particularly if you have more privileges than other users who may have access
to your computer while you are logged into the Windows environment.

Chapter 2. Login Panel
About the Log in Panel
The Log in Panel is an interactive process that lets you monitor the state of remote or local projects
you are logged into or attempting to log into on your computer. The Login Panel shows the status of
projects for which there is an active connection. An active connection is made by an application on
your computer that is collecting point or alarm data.
You can use this process to:
• Log out of a CIMPLICITY project.
• Override the current log in.
• Change your CIMPLICITY user password.
• Manage your saved log ins.
These actions do not require that you exit from any applications that are currently running. For
example, if you are a supervisor, you can override the log in and privileges of an operator, log out,
and return the system back to the operator's logged in state.
When you log out of a project, data collection and background processing continues. However, any
open CIMPLICITY screens will no longer show point status.
Tip: CimLogin and CimLogout Basic Control Engine API's are available for use in CimView,
e.g. to have a logout button on the screen.

Steps for Using the Login Panel
Login Panel Usage Steps
Following are steps to monitor log ins.
Step 1
(page
11)

Start the Login Panel.

Step 2
(page
13)

Administer the Login Panel.
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Step 3
(page
16)

Log out of a project through the Login panel.

Step 4
(page
17)

Log back into a project through the Login panel.

Important: CIMPLICITY does not support Windows XP Fast user Switching.

Step 1. Open the Login Panel
1. Make sure at least one CIMPLICITY project is running.
2. Use one of the following.
• Workbench
• Start menu
Workbench
3. Select Runtime>Login Panel in the Workbench left pane.
4. Do one of the following.

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
Either

Or

Double click Login Panel.

D

In the Workbench right pane:

a. Right-click Login Panel.
b. Select Properties on the Popup menu.
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Either
Double click Login Panel.

E

Or
a. Right-click Login Panel.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

Start menu
5. Right-click Login Panel.
6. Select Properties on the Popup menu.
7. Right-click Login Panel.
8. Select Properties on the Popup menu.
9. Click Start on the Windows task bar.
10. Select (All) Programs>Proficy HMI SCADA - CIMPLICITY version> Login Panel.
Results
• If no CIMPLICITY project is running
11. The Login Panel opens.
12. A message reports that
CIMPLICITY is not running. Program will exit.

13. The Login Panel closes.
• If at least one project is running.
14. The Login Panel window opens.
15. For each project that users on this computer are logged into the Login Panel displays the:
• Node ID for the project
• Project ID
• User name
• Log in status
• Type
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Note: If no users are logged in, the Login Panel window will be blank.

Step 2. Administer the Login Panel
Step 2. Administer the Login Panel
You can use the Login Panel to:
Step 2.1
(page
13)

Change a user password for a project.

Step 2.2
(page
14)

Add/remove a saved CIMPLICITY log in.

Step 2.1. Change a User Password for a Project
Note: In a Server Redundancy configuration, changing the password is only supported when the
primary and secondary computer are on line.
1. Select a user in the Login Panel that has a logged in status.
2. Select Project>Change Password on the Login Panel menu bar.

The Change Password dialog box opens displaying the selected project and user ID.
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3. Enter the following to change the password.

Field

Description

Old password

Password the user is currently using to log into the project.

New password

Password the user will use for the next and future logins.

Confirm

New password repeated.

4. Click either:
OK

Accepts the new password

Cancel

Keeps the old password.

Either the password is changed to the new password you have entered or the change is cancelled.

Step 2.2. Add/Remove a Saved Log in
• CIMPLICITY® Login dialog box.
• Saved Logins dialog box.
CIMPLICITY® Login dialog box
Check Save User ID + Password in any CIMPLICITY® Login dialog box.

Result: The user name and password information are saved in the Registry.
Whenever you open any CIMPLICITY screen that requires that user name and password, you are
automatically logged in to CIMPLICITY software.
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Use the Saved Logins dialog box (page 16) to remove the user from the saved log ins list.
Saved Logins dialog box
1. Select Edit>Saved Logins on the Login Panel menu bar.

The Saved Logins dialog box opens displaying a list of users with saved log ins.
2. Click either of the following.

rect 248, 67, 355, 91 (page 15)
rect 248, 89, 355, 118 (page 16)
A

Add

An Add Saved Login dialog box opens.
a. Enter the following.
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Field

Description

Project

Project that has the user ID to be saved. Tip: Use the drop-down list button to display the list of
available projects in your enterprise.

User ID

User ID to be saved.

Password

User's log in password.

Confirm
Password

User's log in password.

a. Click either:
OK

Accepts the new password

Cancel

Keeps the old password.

The new entry appears in the Saved Logins list. After you activate the new saved login, whenever
you open a screen in this project; you are automatically logged in to the project.
B

Remove

1. Select a user in the saved Log ins list.
2. Click Remove.
The user is removed from the saved log ins list. The next time the user attempts to access or open a
feature that requires a log in, the CIMPLICITY® Login dialog box will open for a user name and
password.

Step 3. Log out of a Project through the Login Panel
1. Select a user in the Login Panel that has a Logged in status.
2. Do one of the following.

A

Click the Log out button on the Login Panel toolbar.

B

Select Project>Logout on the Login Panel menu bar.
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CIMPLICITY software logs out the user.
• If you have runtime applications open, the:
• User line remains in the Login Panel and
• Status changes to Logged Out.
All runtime applications that you are logged into will be no longer update data. For example, all
CimView screens that have animation objects that use points from this project will disable the
objects.
• If you are not logged into any runtime application, the:
Login Panel removes the User from the list.

Step 4. Log Back into a Project through the Login Panel
1. Select a user in the Login Panel that has a Logged in status.
2. Do one of the following.

A

Click the Log in button on the Login Panel toolbar.

B

Select Project>Login on the Login Panel menu bar.

A CIMPLICITY Login dialog box opens.
3. Enter your user ID and password for logging into the project.
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CIMPLICITY software logs you back into the project. The status changes to Logged in.
All runtime applications to which you have been logged in that are still open will resume updating
data. All CimView screens connected to this project will now have their animation objects enabled.
Note:
• The screen itself may change if visibility animation has been enabled for objects and keyed to
User ID and Role ID information.
• If the user ID is a saved login, the Save user ID + Password box will be checked when the
CIMPLICITY® Login dialog box opens.

Login Panel Menu and Tools
Login Panel Menu and Tools
Providing you with the capability to easily use the Login Panel are its:
• Menu
• Toolbar

Login Panel Menu Options
You can use the menu options to open a project, toggle the Toolbar and Status bar displays; change
display attributes, and access Help.
The menu options are:
• File
• Edit
• Project
• View
• Help

File menu

The File menu functions are:
Exit

Exits the Login Panel.
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Edit menu

The Edit menu functions are:
Saved Logins

Opens the Saved Logins dialog box.

Project menu

The Project menu functions are:
Login

Opens the Login dialog box for the selected project.

Logout

Logs you out of the selected project.

Change Password

Enables you to change your password for the selected project.

View menu

The View menu functions are:
Toolbar

Enables/disables the display of the Toolbar.

Status Bar

Enables/disables the display of the Status bar.

Help menu

The Help menu functions are:
Help Topics

Opens the Help window for the Login Panel.

About Login Panel

Displays the current version number for the Login Panel utility.

Login Panel Toolbar Buttons
The Toolbar buttons available to you are:
Login

Opens the Login dialog box for the selected project.
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Logout

Logs you out of the selected project.

About

Displays the title, version number and copyright information for the Login Panel

Chapter 3. Show Users
About Show Users
Show Users is an interactive process that lets you show the users on the various CIMPLICITY
projects running on your network.

Show Users Steps
Show Users Steps
Following are steps to get CIMPLICITY user information:
Step 1
(page
21)

Start Show Users.

Step 2
(page
23)

Change Show Users view options.

Step 3
(page
24)

Open a Project in Show Users.

Step 4
(page
27)

Search for user information.

Step 5
(page
28)

Close a project view in Show Users.

Step 1. Open the Show Users Window
1. Select Runtime>Show Users in the Workbench left pane.
2. Select Show Users in the Workbench right pane.
3. Do one of the following.
• Workbench
• Start menu
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Workbench

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
Either

Or

Double click Show Users.

D

In the Workbench right pane:
Either
Double click Show Users.

E

a. Right-click Show Users.
b. Select Properties on the Popup menu.

Or
a. Right-click Show Users.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

Start Menu
a. Click Start on the Windows task bar.
b. Select (All) Programs>Proficy HMI SCADA - CIMPLICITY version>Show Users .
Result:
• If no project or more than one project is running.
The appropriate Select CIMPLICITY® Project dialog box opens.
Select the CIMPLICITY project for the Show Users window.
• When a project is running:
The Show Users window opens.
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Using the Show Users window, you can:
• Select all projects or a particular project to display.
• Search for users.
• Access Help.
4. Right-click Show Users.
5. Select Properties on the Popup menu.
6. Right-click Show Users.
7. Select Properties on the Popup menu.

Step 2. Change the Show Users View Options
1. Click View on the Show Users window menu bar.
2. Select Options.
The Options dialog box opens.

3. Select the options as follows:
• If you check the On user login check box, a sound plays whenever a user logs in to any
CIMPLICITY project that you are viewing.
If you uncheck the check box, no sound plays when users log in to CIMPLICITY projects that
you are viewing.
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• If you check the On user logout check box, a sound plays whenever a user logs out of any
CIMPLICITY project that you are viewing.
If you uncheck the check box, no sound plays when users log out of CIMPLICITY projects that
you are viewing.
4. Either:
• Click OK to close the dialog box and save your changes, or
• Click Cancel to close the dialog box without implementing any changes.

Step 3. Open A Project in Show Users
Step 3. Open A Project in Show Users
A project that you open in the Show Users window displays in a Show Users sub-window. You can
open more than one project in the Show Users window. Each project has its own sub-window.
For every CIMPLICITY user who is logged in to a project, the project's sub-window displays the:
• User ID,
• Role,
• Node and
• Process ID.
The information in the sub-window updates as users log in and out of the project.
The method for opening a Show Users project varies depending on whether or not a project was
recently opened.
Option
3.1 (page
24)

Open a project that was recently opened.

Option
3.2 (page
25)

Open a project that was not recently opened.

Option 3.1. Open a Project in the Show Users Window that was Recently Opened
1. Click Project on the Show Users window menu bar.
2. Click the project you want from the recently opened list.
A login dialog box displays.
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3. Log into the project.
A project sub-window displays in the Show Users window.

Option 3.2. Open a Project in the Show Users Window that was not Recently Opened
1. Do one of the following:
Method 1
a. Click Project on the Show Users window menu bar.
b. Select Open.
Method 2
Press Ctrl+O on the keyboard.
Method 3
Click the Open button on the Show Users window toolbar.
The Open dialog box opens displaying a list of currently running projects that are broadcasting.
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2. Do one of the following.
Method 1
a. Select the project you want to open.
b. Click Open.
Method 2
Double-click the project you want to open.
Method 3
a. Enter a project name in the Project field.
b. Enter a node name in the Node field.
c. Click Open.
A Login dialog box opens.
3. Log into the project.
A project sub-window displays in the Show Users window. The title bar for the sub-window displays
the project name and node name of the computer on which the project is running.
Note: If a project is already open the newly opened project displays in a second sub-window.
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Step 4. Search for User Information
1. Do one of the following:
• Select Search... on the Search menu,
• Click the Search button on the Show Users window toolbar.
• Press Ctrl+S on the keyboard.
The Search dialog box opens displaying the last search criteria that were entered.

2. Fill in any single or combination of fields to search the list of users in a project.
• User ID,
• Role,
• Node, and/or
• Process.
Note: You can use the drop-down list buttons to the right of each field to display and select
previous search filters.
3. Click Find.
The first user that matches the criteria in the active sub-window's list is highlighted.
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4. Use the Search dialog box navigation buttons or quick keys to search for items that match the
criteria as follows.
Button (key)

Moves the selection in the active sub-window to the:

Next (Ctrl+N)

Next item that matches the search criteria.

Previous (Ctrl+P)

Previous item that matches the search criteria.

Step 5. Close A Project View in Show Users
1. Select the project's sub-window.
2. Do one of the following:
• Select Close on the Project menu.
• Double-click on the Control button for the project.
• Click the Close button on the Show Users window toolbar.

Show Users Window Menu and Tools
Show Users Window Menu and Tools
Providing you with the capability to easily use Show Users are the Show Users window:
• Menu
• Toolbar
• Shortcut keys

Show Users Menu Options
You can use the menu options to open a project, toggle the Toolbar and Status bar displays; change
display attributes, and access Help.
The menu options are:
• Project menu
• View menu
• Help menu
• Search menu
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• Window menu

Project Menu

Feature

Description

Open

Opens a new project on the network.

Recent Project

Displays the list of recently opened projects and lets you select one.

Exit

Exits Show Users.

View Menu

Feature

Description

Toolbar

Enables/disables the display of the Toolbar.

Status Bar

Enables/disables the display of the Status bar.

Options...

Selects options from the Options dialog box.

Help Menu

Feature

Description

Contents

Opens the Contents tab in the Show Users help dialog box.

Search for Help On

Opens the Index tab in the Show Users help dialog box.

How to Use Help

Opens the Index tab in the Show Users help dialog box.

About ShowUser...

Displays the current version number for the Show Users utility.

Search Menu
Note: When you have one or more projects open in this window, the Search menu is available.
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Feature

Description

Search

Displays the Search dialog box.

Next

Displays the next line of user information that meets the search criteria.

Previous

Displays the pr evious line of user information that meets the search criteria.

Window Menu
When you have one or more projects open in this window, the Window menu is available. When you
select the Window menu, the following drop-down list displays:

Feature

Description

Cascade

Cascades the currently open project windows.

Tile
Horizontally

Tiles the currently open project windows horizontally.

Tile Vertically

Tiles the currently open project windows vertically.

Arrange Icons

Arranges the icons for all minimized project windows.

Close All

Closes all project windows.

Open Projects

Displays the list of all opened projects in Show Users. To activate the display of a project in this list,
just click on it.

Show Users Toolbar Buttons
Show Users toolbar buttons are as follows.

1

Open

Open a project

2

Close

Closes the active sessions.

3

Search

Searches for a user.
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4

Search Next

Searches for the next user.

5

Search Previous

Searches for the previous sure.

6

Tile Windows

Tiles windows horizontally.

7

Tile Windows

Tiles windows vertically.

8

Cascade Windows

Cascades windows.

Show Users Shortcut Keys
You can use the following shortcut keys to initiate commonly used functions:
Shortcut Key

Function

Ctrl+O

Opens a project.

Ctrl+S

Opens the Search dialog box.

Ctrl+N

Finds the next entry that matches the criteria in the Search dialog box.

Ctrl+P

Finds the previous entry that matches the criteria in the Search dialog box.

Alt+Print Screen

Captures the contents of the current window to the clipboard.

F1

Opens the Help window.

Shift+F1

Invokes the Help cursor.

Alt+F4

Closes the current window. You will be prompted to save any changes.

Ctrl+Esc

Opens the Start Menu on the task bar.

Chapter 4. Alarm Viewers
About Alarm Viewers
1. System events, such as device failures, program terminations, system startups and system
shutdowns.
You create and modify system event alarms in the Alarm Definition dialog box .
Note: CIMPLICITY comes with several configured Event alarms.
2. Points that are in an alarm state, created in the Point Properties dialog box. You can modify
them in the Point Properties dialog box or the Alarm Definition dialog box.
CIMPLICITY includes the following Alarm Viewers:
a. Alarm Viewer OCX Control (AMV Control).
• AMV Control overview.
• AMV Control configuration.
a. Stand-alone Alarm Viewer (stand-alone AMV).
• Stand-alone AMV overview.
• Stand-alone AMV configuration
Both alarm viewers provide the capabilities to:
• Configure alarm views.
• Display current alarms.
• Modify the state of existing alarms.
• Enter comments about an existing alarm.
• Receive instructions to resolve alarm conditions.
• Filter the alarm list to display only those alarms that have certain characteristics.
• Display alarms in a static view.
In Static view, a user opens a CIMPLICITY Alarm Viewer a current list of alarms displays.
This list remains in the window until a user:
• Acknowledges or resets alarms that are configured to be deleted on acknowledge or reset.
• Clicks Refresh to display an updated list of alarms when the alarm count changes to the
Unseen Alarm Count color.
• Display alarms in a dynamic view.
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In Dynamic view, the alarm display is updated automatically whenever a new alarm that passes
a filter (or unfiltered) list is generated or when the status of an existing alarm changes.

CIMPLICITY AMV Control Overview
A CIMPLICITY AMV Control is an Active X object that you embed in a CimEdit screen.
The AMV Control provides a powerful tool for you to:
• Fully integrate the Alarm Viewer capability with your other CimEdit screens.
For example, you can configure the CimEdit screens so operators can easily move back and forth
between other CimView screens and the Alarm Viewer.
• Exercise more control (than for the stand-alone AMV) over user configuration capability during
runtime. For example, you can specify whether or not a user, during runtime, can:
• Configure the control.
• Sort fields.
• Choose from all buttons to display for dynamic view. (The stand-alone AMV provides only the
Setup (page 105) and Toggle (page 124) buttons for dynamic view.)
• Take advantage of CimView features, e.g. the zoom screen capability.

CIMPLICITY Stand-alone AMV Overview
1. Open the stand-alone AMV or a stand-alone AMV file,
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2. Start CIMPLICITY if it is not already started, and
3. Login.
Alarms that pass a default alarm filter setup display in the stand-alone AMV window.
A user can immediately respond to alarms and/or change the configuration as required.

AMV Control Configuration
AMV Control Configuration
Steps to configure the AMV Control include:
Step 1
(page
35)

Place an AMV Control on a CimEdit screen.

Step 2
(page
36)

Resize a new Alarm Viewer OCX Control.

Step 3
(page
38)

Open the CIMPLICITY AMV Control dialog box.

Step 4
(page
39)

Configure the AMV Control alarm count layout.

Step 5
(page
41)

Configure the AMV Control fonts and colors.
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Step 6
(page
46)

Specify the AMV Control sort properties.

Step 7
(page
46)

Specify AMV Control display properties.

Step 8
(page
48)

Specify the AMV Control user configuration privileges.

Step 9
(page
52)

Specify the projects the AMV Control will monitor.

More
(page
86)

Steps to configure Alarm Viewer fields and buttons.

Step 1. Place an AMV Control on a CimEdit Screen
Do any of the following to place an AMV control on a CimEdit screen.
• Click the Alarm Viewer OCX button.
• Click the OLE button.
Click the Alarm Viewer OCX button.
Click Alarm Viewer on the in the Drawing>Objects group on the CimEdit Ribbon bar.

Result: An AMV OCX Control is placed on the CimEdit screen. The top left corner is located at the
top left corner of the screen.

Click the OLE button
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1. Click OLE in the Drawing>Objects group on the CimEdit Ribbon bar.

An ActiveX Placement cursor displays on the CimEdit screen.
2. Place the ActiveX Placement cursor where you want the top left corner of the control to be
located.
The Insert Object dialog box opens
3. Select CIMPLICITY AMV Control.

4. Click OK.
A new Alarm Viewer control is placed on your CimEdit screen in the location you selected.

Step 2. Resize a new Alarm Viewer OCX Control
Do one of the following.
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• Quickly resize the AMV Control.
• Enter precise dimensions for the AMV Control.
Quickly resize the AMV Control
1. Click Resize in the Drawing>Edit group on the CimEdit Ribbon bar.

2. Click one of the object's handles and move it to enlarge or reduce the AMV Control size.

3. Hold the mouse button down while you move the handle.
Note: The screen displays the following.

A

The handle that is being dragged changes to a crosshair.

B

The original size displays within the original handles during the re-sizing process.

C

The Alarm Viewer's new size display follows the cursor.

4. Release the mouse button.
Result: The Alarm Viewer control displays in the new size.
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Precise dimensions for the AMV Control
5. Select the Alarm Viewer control.
6. Do one of the following.
• Click Properties in the Home>Properties group on the CimEdit Ribbon bar.

• Click the right-mouse button on the Alarm Viewer control; select Properties on the Popup
menu.
The CimEdit Properties - Object dialog box opens when you use either method.
7. Select Geometry.
8. Enter the following.

Field

Description

Top

Number of points starting from the bottom of the screen where the AMV Control top is located.

Width

Width of the object in points.

Left

Number of points starting from the left of the screen where the left side of the AMV Control is located.

Height

Height of the object in points.

The AMV Control enlarges/ reduces and moves to the size you specify.

Step 3. Open the CIMPLICITY AMV Control Dialog Box
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1. Right-click the Alarm Viewr chart
2. Select CIMPLICITY AMV Control Object>Properties on the Popup and extended Popup
menus.

The CIMPLICITY AMV Control Properties dialog box opens when you use any method.

Step 4. Configure the AMV Control Alarm Count Layout
Select the Count Layout tab in the CIMPLICITY AMV Control Properties dialog box.
Count fields selections are as follows.
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rect 5, 50, 99, 116 (page 40)
rect 4, 122, 109, 197 (page 41)
rect 100, 52, 316, 169 (page 41)
1
(page
40)

Position

2
(page
41)

Orientation

3
(page
41)

Fields

1

Position

Check the Position check boxes to specify the fields' position in the AMV Control as follows.
Position of fields in the AMV Control

Top of screen

Center count

Bottom left-hand corner of the AMV Control.

Clear

Clear

Upper left-hand corner of the AMV Control.

Check

Clear
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Centered at the top of the AMV Control.

Check

Check

Note: Center count is enabled when you check Top of screen.
2

Orientation

Choose one of the following.
Horizontal

Side by side in the order you specify.

Vertical

One on top of the other in the order you specify.

3

Fields

The following fields, when checked, display the following in the Alarm Control.

A

Count

Alarm count

B

Date

Date the alarm was generated.

C

Time

Time the alarm was generated.

The following buttons move the fields to the left or right in the AMV Control.
Move Up

Moves the field to the left.

Move Down

Moves the field to the right.

Result: The alarm count information displays according to your specifications.

Step 5. Configure the AMV Control Fonts and Colors
• AMV Control fonts.
• AMV Control colors.
AMV Control Fonts
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1. Select the Fonts tab in the CIMPLICITY AMV Control Properties dialog box.
Fonts can be configured for the following AMV Control features.
• Alarm
• Button
• Count
• Date
• Status
2. Select a feature.
3. Click Font...

The font dialog box opens.
4. Make the customary font selections.

If an alarm message that needs to use non-Western characters (e.g. Cyrillic, Chinese)
displays ???? instead of the message, changing the Script selection in the Font dialog box may
correct the issue.
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The Script drop-down list will display the character types available for the selected font.
Note: The stand-alone Alarm Viewer displays only the language selected for the operating
system.
5. Click OK.
The new specifications display for that selected feature.
6. Repeat the procedure if you want to configure the font for other features.
7. Click Apply.

The selected fonts and sizes display in the AMV Control.

AMV Control Colors
You can select colors for each of the AMV Control properties.
Selections are as follows.
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1
(page
44)

Property name

2
(page
44)

Color for selected property

1

Property name

Select a property in the Property Name drop-down list.
Selections are as follows.
Listed Property

Property

AlarmBGColor

Alarm list background

ButtonBGColor

Button background

CountAlarmColor

Alarm count text

CountBGColor

Count background

CountNormalColor

Normal count text

StatusBGColor

Status background

StatusTextColor

Status text.

2

Color for selected property

Do either of the following to select a color for the selected property.
Select a system color
1. Select a color in the System Color drop down list.
Available selections are as follows.

Runtime | 4 - Alarm Viewers | 45

• Active Border

• Highlighted Text

• Active Title Bar

• Inactive Border

• Active Title Bar Text

• Inactive Title Bar

• Application Workspace

• Inactive Title Bar Text

• Button Face

• Menu Bar

• Button Highlight

• Menu Text

• Button Shadow

• Scroll Bars

• Button Text

• Window Background

• Desktop

• Window Frame

• Disabled Text

• Window Text

• Highlight

1. Click Apply.
Select a color in the palette
1. Click a color in the palette.
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1. Click Apply.
The selected properties will display during runtime in the selected colors.
Note: The Alarm font colors are selected in the Alarm class configuration.

Step 6. Specify AMV Control Sort Properties
1. All unacknowledged alarms in ALARM state are first.
2. All unacknowledged alarms in NORMAL state are next.
3. All acknowledged alarms in ALARM state are last.
4. All unacknowledged alarms in ALARM state are last.
5. All unacknowledged alarms in NORMAL state are next.
6. All acknowledged alarms in ALARM state are first.

Step 7. Specify AMV Control Display Properties
Check any of the check boxes in the Display box to display the feature in the AMV Control during
runtime.
• Check boxes.
• Runtime display example.
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Check boxes

rect 24, 78, 120, 99 (page 47)
rect 25, 99, 121, 120 (page 47)
rect 24, 119, 132, 148 (page 47)
rect 147, 75, 323, 102 Step 8. Specify AMV Control User Configuration Privileges (page 48)
rect 131, 101, 344, 127 (page 47)
1

Field titles

Display column titles. The column titles must display in order to allow users to sort by title during
runtime, if enabled.

2

Status box

Display a status box that provides information about the:
•
•
•
•
•

Project(s)
(Connected) State
(Alarm) Count per project,
Date/Time and
Setup (Filter being used).

3

Begin in
Static

4

Show alarm clear time in view stack

Static mode (at startup).

Select when to provide a timestamp as follows.
Check

Provides time for when a value:
• Goes into Alarm state.
• Goes into Normal state (is cleared).

Clear

Provides the time for when a value goes into Alarm state.

Runtime display example
Following are examples of how the AMV Control displays based on your selections.
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• AMV Control with all display features selected

rect 1, 51, 248, 68 (page 47)
rect 4, 175, 279, 225 (page 47)
rect 88, 226, 149, 243 (page 47)
• AMV Control with no display features selected

Step 8. Specify AMV Control User Configuration Privileges
• Configuration for runtime configuration access.
• Runtime configuration features.
Configuration for runtime configuration access
1. Select the Display tab in the CIMPLICITY AMV Control Properties dialog box.
2. Do one of the following in the Allow runtime popup menu checkbox.
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Check

Users will be able to display a Configuration Popup menu during runtime.

Clear

Users will not be able to display a Configuration Popup menu during runtime.

Result: Users will have access to Alarm Viewer Control configuration.
Runtime configuration features
Note: Viewing the Popup menu, Point Control Panel and/or Quick Trends through the
Alarm Viewer OCX is available if the role assigned to your user ID has authorization.
Runtime configuration features are as follows.

rect 213, 67, 372, 86 Option 9.1. Add Projects and Default Filters to the AMV Control (page
52)
rect 213, 84, 372, 103 Option 9.2. Delete Projects from the AMV Control List (page 56)
rect 213, 101, 372, 120 (page 50)
rect 213, 129, 372, 148 (page 50)
rect 213, 146, 372, 165 (page 51)
1
(page
50)

Add Project.
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2
(page
50)

Remove Project.

3
(page
50)

Copy Alarms

4
(page
50)

Use Ambient Properties

5
(page
51)

Properties...

1

Add Project

Projects can be added to the Alarm Viewer Control before and during runtime (page 55).
2

Remove Project

Projects can be removed from the Alarm Viewer Control before and during runtime (page
56).
3

Copy Alarms

3. Select one or more alarms in the AMV Control.
4. Display the Popup menu.
5. Select Copy Alarms.
The selected alarms and details are copied.
6. Paste the alarms and details in any text file.

4

Use Ambient Properties

Select Ambient Properties on the Popup menu.
The AMV Control display uses the CimEdit Ambient properties.
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The Ambient Properties will be in the CIMPLICITY AMV Control Properties dialog box during
this runtime session.

However, this setting is temporary. The next time the AMV Control is opened, the properties
configured for the AMV control will display again.
5

Properties...

7. Display the Popup menu.
8. Select Properties...
The CIMPLICITY AMV Control Properties dialog box opens.
The user has full access to the Alarm Viewer control configuration.
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Step 9. Specify the Projects the AMV Control will Monitor
Step 9. Specify the Projects the AMV Control will Monitor
During configuration, you can select and delete projects to be included in the AMV Control display.
Note: Runtime users can also perform these functions if the runtime AMV Control Popup menu is
enabled (page 48).
Option
9.1 (page
52)

Add projects and default filters to the AMV Control.

Option
9.2 (page
56)

Delete projects from the AMV Control list.

Option 9.1. Add Projects and Default Filters to the AMV Control
• Add projects during configuration.
• Add projects during runtime.
1. Select the Projects tab in the CIMPLICITY AMV Control Properties dialog box.
2. Options to add projects are as follows.
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rect -5, 169, 151, 197 (page 53)
rect 19, 65, 103, 156 (page 53)
rect 228, 64, 312, 89 (page 53)
rect 105, 65, 189, 156 (page 54)
rect 231, 110, 315, 135 (page 54)
1
(page
53)

Connect to local project

2
(page
53)

Add project

3
(page
54)

(Optional) Select setup

1

Connect to local project

Check to do the following.
When a user opens the CimView screen containing this Alarm Viewer control, the control
automatically connects to the currently running local project and opens the CIMPLICITY Login
dialog box for user login.
2

Add Project

Opens the Select Project dialog box.

3. Do one of the following.
a. Select a project from the available projects in the drop-down menu.

Runtime | 4 - Alarm Viewers | 54

Note: If the server is connected to a network, the Project drop down menu displays all of the
running projects that are being broadcast on the network.
a. Enter any of the following.
• Project name
• Node name
• IP address
• Cluster name
• Cluster IP address
Important: If cabling redundancy is configured on a server and you attempt to connect by
cluster name or IP address, the connection will fail.
4. Click OK to add the project to the list in the Projects tab.
5. Repeat the procedure until all of the required projects have been selected.
Result: The projects display in the Projects list.
3

(Optional) Select Setup

Opens the Project Settings dialog box in which you can enter the default alarm setup.

6. Enter the default alarm filter
Note: You configure alarm filters when you configure the AMV Control buttons (page 110).
The default is <<UNFILTERED>>.
7. Click OK.
The entered setup displays in the Setup column in the selected project's row.
Result: When a user opens the CimView AMV Control screen:
• If the selected setup (filter) exists the alarms display adheres to the setup's specifications.
• If the alarm setup does not exist, an error message displays when the CimView AMV
Control screen is opened.
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When OK is clicked, an unfiltered alarm list appears.
If the setup is created during the session, it will be the default the next time the CimView Alarm
Viewer screen is opened.
Add projects during runtime
During runtime a user can quickly add projects by right-clicking the Alarm Viewer control
8. Right-click (page 49) the Alarm Viewer OCX.
A Popup menu opens.
9. Select Add Project.

The Select Project dialog box opens.

10. Do one of the following.
Select one of the running projects from the Project field.
Enter one of the following.
• Project name
• Node name
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• IP address
11. Click OK.

Option 9.2. Delete Projects from the AMV Control List
• Delete projects during configuration.
• Remove projects during runtime.
• Delete projects during configuration
1. Select the Projects tab in the CIMPLICITY AMV Control Properties dialog box.
2. Select the project to delete.
3. Click Delete Project.

The project is deleted from the list.
4. Repeat until all of the projects are selected.
Remove projects during runtime
During runtime a user can quickly remove projects by right-clicking the Alarm Viewer control
5. Right-click (page 49) the Alarm Viewer OCX
A popup menu appears.
6. Select Remove Project.
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The Disconnect Project dialog box opens displaying a list of projects attached to the Alarm
Viewer control.

7. Select the project to disconnect.
8. Click OK.

Stand-alone AMV Configuration
Stand-alone AMV Configuration
Steps to configure the stand-alone AMV are:
Step 1
(page
58)

Start the stand-alone AMV.

Step 2
(page
63)

Select an AMV file.

Step 3
(page
66)

Configure the alarm count layout.

Step 4
(page
72)

Select the alarm list font and background color.
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Step 5
(page
76)

Work with the Stand-alone AMV.

Step 6
(page
81)

Specify how a Stand-alone AMV file will connect to a project.

Step 7
(page
85)

Configure AMV fields and buttons.

Step 8
(page
85)

Exit the Stand-alone AMV.

More
(page
86)

Steps to configure Alarm Viewer fields and buttons.

Step 1. Start the Stand-alone AMV
Step 1. Start the Stand-alone AMV
Steps to start the stand-alone AMV are:
Step 1.1
(page
58)

Open the stand-alone AMV.

Step 1.2
(page
61)

Login to the stand-alone AMV.

Step 1.1. Open the Stand-alone AMV
Step 1.1. Open the Stand-alone AMV
Because Stand-alone AMV is a runtime application, you can open it on either a:
Option
1.1.1 (page
58)

Configuration server/viewer, or

Option
1.1.2 (page
60)

Runtime server/viewer.

Option 1.1.1. Open the stand-alone AMV on a Configuration Server or Viewer
Open the Alarm Viewer through the:
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• Workbench.
• Start Menu.
Workbench
1. Make sure the CIMPLICITY project is running.
2. Select Runtime>Alarm Viewer in the Workbench left pane.
3. Do one of the following.

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm Viewer.
b. Select Properties on the Popup menu.

D

In the Workbench right pane:
Either
Double click Alarm Viewer.

E

Or
a. Right-click Alarm Viewer.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

a. Result: An untitled, empty Stand-alone AMV window displays when you use any method.
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Start Menu
4. Right-click Alarm Viewer.
5. Select Properties on the Popup menu.
6. Right-click Alarm Viewer.
7. Select Properties on the Popup menu.
8. Click Start on the Windows task bar.
9. Select All Programs>HMI SCADA - CIMPLICITY <version>Alarm Viewer
.
An untitled, empty Stand-alone AMV window displays.

Tip: Once you have configured an Alarm Viewer file you can create a shortcut for the Windows
desktop or Start menu. A user can then double-click the shortcut and display both the stand-alone
AMV and alarms in the connected project in one or two easy steps. The exact steps depend on you
specifications for connecting the file to a project.
Option 1.1.2. Open the Alarm Viewer on a Runtime Server or Viewer
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A system administrator can control how Alarm Viewer opens and what alarms it displays on a
runtime server or viewer.
Very commonly, the Alarm Viewer that is embedded in a CimView screen starts when the runtime
server or viewer is booted.
Also commonly, an operator can click an icon on the Windows desktop to open a pre-configured
Alarm Viewer.
In other instances, the Alarm Viewer can be started through the Windows Start menu.
Note: If the user has not logged in a CIMPLICITY® Login dialog box displays and the user
must log in before the CimView screen can be enabled.

Step 1.2. Login to the Alarm Viewer
1
(page
61)

Start the Log in.

2
(page
61)

(If the router is not running) start the router.

3
(page
62)

Log into the Alarm Viewer.

1. Start the Log in.
Click Login! on the Alarm Viewer menu bar.

1. Start the router.
If the router is not running a Select a CIMPLICITY Project dialog box opens when you click Login!.
The dialog box displays available projects.
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1. Select any project to which you have access.
Note: The project does not have to be the one that displays in the active Workbench.
2. Click Start (or Start as Viewer).
a. Log into the Alarm Viewer.
(If logging in is required) a CIMPLICITYâ Login dialog box opens.

3. Enter your User ID and Password.
4. Click OK.
(When opened through the Start menu) a Project dialog box opens.
a. Enter any of the following.
• Project name
• Server name
• IP address
• Cluster name
• Cluster IP address
Important: If cabling redundancy is configured on a server and you attempt to connect by
cluster name or IP address, the connection will fail.

a. Click OK.
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The project starts after you have entered your User ID and password, if they are required. When the
project has started its active Alarm IDs display in the Alarm Viewer.

Note: If the CIMPLICITY project that displays in the Workbench is running, the Alarm Viewer
displays the alarms in that project when Login! is clicked on the Alarm Viewer menu bar–even if
more than one project is running.

Step 2. Select an Alarm Viewer File
Step 2. Select an Alarm Viewer File
You can select an Alarm Viewer file that contains the setup you want to use to review alarms.
Options include:
Option
2.1 (page
63)

Display a new Alarm Viewer file.

Optiion
2.2 (page
64)

Open an existing Alarm Viewer file.

Note: You can also simply view the configuration that displays when you open the stand-alone
AMV.

Option 2.1. Display a new Alarm Viewer File
Do one of the following.
Method 1
1. Click File on the Alarm Viewer menu bar.
2. Select New.
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Method 2
Double-click the New button

on the Alarm Viewer toolbar.

Method 3
Press Ctrl+N on the keyboard.
The File name that appears on the existing stand-alone AMV title bar displays as Untitled. The next
time you save the file, you will be prompted to name it.

Option 2.2 Open an existing Alarm Viewer File
Option 2.2. Open an existing Alarm Viewer File
If a saved Alarm Viewer file (AMV) contains the configuration you need for dealing with alarms
you can open it and connect to the appropriate project according to the specifications made when the
project was saved.
The Alarm Viewer enables you to easily:
Option
2.2.1 (page
65)

Open a recently used Alarm Viewer file.

Option
2.2.2 (page
65)

Open any existing Alarm Viewer file.

Tip: You can also create a shortcut to open an Alarm Viewer file. This is an efficient way of
making the correct Alarm Viewer configuration available to users.
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Option 2.2.1. Open a Recently Used Alarm Viewer File
1. Click File on the Alarm Viewer menu bar.
2. Select any of the files listed on the File menu.
The file displays in the stand-alone AMV with the configuration you saved.

Option 2.2.2. Open any Existing Alarm Viewer File
1. Open the Open dialog box.
Method 1
a. Click File on the stand-alone AMV menu bar.
b. Select Open.
Method 2
Double-click the Open button

on the stand-alone AMV toolbar.

Method 3
Press Ctrl+O on the keyboard.
The Open dialog box opens when you use any method.
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2. Find and select the .PPL file you want.
The file displays in the stand-alone AMV with the configuration you saved.

Step 3. Configure the Alarm Count Layout
Step 3. Configure the Alarm Count Layout
The Alarm Count display tells you how many alarms have been generated and the time and date
of the most recently generated alarms. You have complete flexibility with how to display this
information on the Alarm Viewer screen.
Configuration includes:
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Step 3.1
(page
67)

Open the Alarm Count Configuration dialog box.

Step 3.2
(page
67)

Specify the layout of the count information.

Step3.3
(page
69)

Select the alarm count colors.

Step 3.4
(page
70)

Select the alarm count fonts.

Step 3.1. Open the Alarm Count Configuration Dialog Box
1. Click Configure on the Alarm Viewer menu bar.
2. Select Count Layout.
The Alarm Count Configuration dialog box opens.

Step 3.2. Configure the Alarm Count Layout
1. Click Configure on the Alarm Viewer menu bar.
2. Select Count Layout…
The Alarm Count Configuration dialog box appears.
3. Select the Layout tab.
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The Layout tab displays the current selections.

4. Do one of the following in the Position box:
Action

For Position

Clear both check boxes

Bottom left-hand corner of the Alarm Viewer.

Check Alarm at Top of Screen

Upper left-hand corner of the Alarm Viewer.

Check both check boxes

Centered at the top of the Alarm Viewer.

5. Check one in Orientation box:
Check

Display Fields

Horizontal

Side by side in the order you specify.

Vertical

One on top of the other in the order you specify.

6. Check which fields to display in the Fields box. Options include alarm:
• Count.
• Date.
• Time.
7. Specify the order in which the information should display as follows.
a. Select an information field.
b. Click either:
• Move Up to move the field to the left or
• Move Down to move the field to the right.
The alarm count information displays during runtime according to your specifications.
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Step 3.3. Configure Alarm Count Colors
1. Click Configure on the Alarm Viewer menu bar.
2. Select Count Layout…
The Alarm Count Configuration dialog box appears.
3. Select the Colors tab.
The Colors tab displays the currently selected colors.

4. Click Color to the right of any option whose color you want to change.
Option

Changes the Color of the:

Unseen Alarm Count

Alarm count when new alarms are generated and you have not yet viewed them.

Seen Alarm Count

Alarm count after you have viewed the current set of alarms.

Background

Background color for the alarm count display.

A Color palette opens when you click any of the Color buttons.
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5. Select the color you want.
6. Click OK.
The color you selected will replace the existing color for the selected option.
Note: Click Define Custom Colors to expand the palette and create additional colors.

Step 3.4. Select the Alarm Count Fonts
1. Click Configure on the Alarm Viewer menu bar.
2. Select Count Layout…
The Alarm Count Configuration dialog box appears.
3. Select the Fonts tab.
The Fonts tab displays the currently selected fonts and size.
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4. Click Font in the Count Font box to change the font specifications for the alarm count display.
A Font dialog box opens in which you can make your changes.

a. Select the Font, Font style and size.
b. Click OK.
The Fonts tab re-displays.
5. Click Font in the Date/time Font box to change the font specifications for the date and time.
A Font dialog box opens in which you can make your changes.
a. Select the Font, Font style and size.
b. Click OK.
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The Fonts tab re-displays.

Step 4. Select the Stand-alone AMV Alarm List Font and Background
Colors
Step 4. Select the Stand-alone AMV Alarm List Font and Background Colors
You can specify the
• Font type, style, and size used for the Alarm List and
• Alarm Viewer background color. This color displays where there are no alarms. The
background color for the alarms is selected in the Alarm Class Configuration dialog box.
Steps include:
Step 4.1
(page
72)

Select the font type for the alarm list..

Step 4.2
(page
74)

Select the stand-alone AMVa background color.

Step 4.3
(page
75)

Select the button area background color.

Step 4.1. Select the Font Type for the Alarm List
1. Click Configure on the Alarm Viewer menu bar.
2. Select List Layout…
The Alarm List Configuration dialog box appears.
3. Select the Color and Font tab.
The Color and Font tab displays the currently selected font and size.
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4. Click Font in the Count Font box to change the font specifications for the alarm count display.
A Font dialog box opens in which you can make your changes.

5. Select the Font, Font style and size.
6. Click OK.
The Color and Fonts tab reappears.
7. Click OK.
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When alarms display in the Alarm Viewer the text for the alarm list and field headings will display in
the font you specify.

Step 4.2. Select the Stand-alone Alarm Viewer Background Color
1. Click Configure on the Alarm Viewer menu bar.
2. Select List Layout.
The Alarm List Configuration dialog box appears.

3. Select the Color and Font tab.
The Color and Font tab displays the currently selected background color.
4. Click Color.
A Color palette opens.
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5. Select the color you want.
6. Click OK.
The color you selected will replace the existing background color.

Step 4.3. Select the Button Area Background Color
1. Select the Button Layout tab in the Alarm List Configuration dialog box.
The color that displays in the Background Color box is the color that currently displays in
stand-alone AMV button area.
2. Click Color.
A Color Palette displays.
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3. Select the color you want to use.
4. Click OK or Apply.
The button area background changes to the color that you selected.

Step 5. Work with the Stand-alone AMV
Step 5. Work with the Stand-alone AMV
The CIMPLICITY Alarm Viewer has several features that enable a stand-alone Alarm Viewer user
to report, review and/or save alarms and/or an Alarm Viewer configuration.
Options include:
Option
5.1 (page
76)

Copy an alarm to another document.

Option
5.2 (page
77)

Print an Alarm Viewer document.

Option
5.3 (page
79)

Save an Alarm Viewer file.

Option 5.1. Copy an Alarm to another Document
1. Select the alarm or alarms in the Alarm Viewer that you want to copy.
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Note: Hold down the Shift key to select more than one alarm.
2. Do one of the following:
Method 1
Click Edit on the Alarm Viewer menu bar.
Select Copy.
Method 2
Press Ctrl+C on the keyboard.
3. Open the document in which you want to paste the data.
4. Press Ctrl+V (in almost all applications) on the keyboard.
The data is copied to the new document as text.
Example
Data for Two Alarms Selected in the Alarm Viewer

The Alarms Pasted in Word
TANK_2.LEVEL $SYSTEM LOW Feb 12 11:29 ALARM N
TANK_2 Level is Lo-2 at 0
S90_575 90-30 LOW Feb 12 11:29 ALARM N
S90_575 is out of range.

Option 5.2. Print a Stand-alone AMV Document
Option 5.2. Print a Stand-alone AMV Document
You can easily preview and print an Alarm Viewer file.
The Alarm Viewer enables you to:
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Option
5.2.1 (page
78)

Preview a document before it is printed.

Option
5.2.2 (page
78)

Specify the printer and setup.

Option
5.2.3 (page
79)

Print the document.

Option 5.2.1. Preview Stand-alone AMV Printed Document
1. Open the stand-alone AMV Print Preview window as follows.
Method 1
a. Click File on the stand-alone AMV menu bar.
b. Select Print Preview.
Method 2
Press Alt+F+V on the keyboard.
The stand-alone AMV Print Preview window opens when you use either method.
2. Review the print preview using the stand-alone AMV tools:
To
Zoom in

Action
Right-click the mouse, or
Click Zoom in on the toolbar.

Zoom out

Press Alt and Right-click the mouse, or
Click Zoom out on the toolbar.

Go to the previous page

Click Prev Page on the toolbar

Go to the next page

Click Next Page on the toolbar

Display one page

Click One Page. This button is active when two pages are displaying.

Display two pages

Click Two Pages. This button is active when one page is displaying.

Print

Click Print.

Option 5.2.2. Specify the Print Setup for the Stand-alone AMV
Do one of the following.
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Method 1
1. Click File on the Alarm Viewer menu bar.
2. Select Print Setup.
Method 2
Press Alt+F+R on the keyboard.
The Print Setup dialog box opens when you use either method.
Note: You can also change the printer specifications before you print the document.

Option 5.2.3. Print a Stand-alone AMV Document
Method 1
1. Click File on the stand-alone AMV menu bar.
2. Select Print.
Method 2
Click Print in the stand-alone AMV Print Preview window.
Method 3
Press Crtl+P on the keyboard.
The Print dialog box opens when you use any method. You can continue with printing in the same
manner as you do with any Windows document.

Option 5.3. Save a Stand-alone AMV File
Option 5.3. Save a Stand-alone AMV File
When you display a configuration that you think you will use again, you can
Option
5.3.1 (page
80)

Save the original stand-alone AMV file.

Option
5.3.2 (page
80)

Save a copy of an stand-alone AMV file.
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Option 5.3.1. Save the Original Stand-alone AMV File
1. Do one of the following:
Method 1
a. Click File on the stand-alone AMV menu bar.
b. Select Save.
Method 2
Double-click the Save button

on the stand-alone AMV toolbar.

Method 3
Press Ctrl+S on the keyboard.
If the file has been saved previously the saved version is updated.
If the file is being saved for the first time, the Save As dialog box opens.
2. Enter a name for the file in the folder where you keep stand-alone AMV files for the project.
3. Click Save.
A new stand-alone AMV file is saved for future use.
Note: By default, stand-alone AMV documents are placed in the Screens directory for the
CIMPLICITY project that is being used. However, you can select another directory.
Option 5.3.2. Save a Copy of Stand-alone AMV File
1. Click File on the Alarm Viewer menu bar.
2. Select Save As…
The Save As dialog box opens.
3. Enter a name for the file in the folder where you keep stand-alone AMV files for the project.
4. Click Save.
A copy of the existing stand-alone AMV file is saved for future use.
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Step 6. Specify how a Stand-alone AMV File will Connect to a Project
Step 6. Specify how a Stand-alone AMV File will Connect to a Project
When you create a stand-alone AMV file you need to specify how the stand-alone AMV will
determine what project to connect to when the stand-alone AMV file is opened. You make the
specification on the General tab in the Alarm List Configuration dialog box.
Step 6.1
(page
81)

Select the project that will be connected.

Step 6.2
(page
83)

Specify the placement of the stand-alone AMV window.

Step 6.3
(page
84)

(Optional) Install a shortcut of the stand-alone AMV file.

Step 6.1. Select the Project that will be Connected
1. Click Configure on the stand-alone AMV menu bar.
2. Select List Layout…
The Alarm List Configuration dialog box opens.
3. Select the General tab.
The General tab displays the current selection.
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4. Select one of the following connection types to determine how the stand-alone AMV will
connect to a project.
• Connection 1.
• Connection 2.
• Connection 3.
Connection 1
Check Connect to Local Project if you want the stand-alone AMV file to automatically
display alarms for the project, in which the stand-alone AMV file is located, when the project is
running.
If the local project is running, the alarms display immediately when the file is opened.
Connection 2
Check Browse for system when connecting if you want the user to select the connected project.
When a user opens the AMV file a dialog box appears with a drop down list of projects in the
system. If the selected project is running and the user has access, its alarms appear in the Alarm
Viewer.
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Connection 3
Check Select Project Now if you want the stand-alone AMV to connect to a specific project that is
not the project in which the AMV file is located.

When a user opens the AMV file, alarms for the selected project appear, if the project is running.
Note: In all instances, when no project is running, a Select CIMPLICITYâ Project dialog box
appears. The user selects which project to start and the alarms for that project will display.

Step 6.2. Specify the Placement of an Alarm Viewer Window
1. Click Configure on the stand-alone AMV menu bar.
2. Select List Layout…
The Alarm List Configuration window opens.
3. Select the General tab.
The General tab displays the current selection.
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4. Check either:
Check Box

The stand-alone AMV will:

Always on Top

Always be on top, no matter what other windows are open.

Pop to Top on new Alarms

Pop to the top when new alarms are received.

5. Click OK.
The stand-alone AMV will be positioned according to your specifications.

Step 6.3. Install a Shortcut of a Stand-alone AMV File
1. Click File on the stand-alone AMV menu bar..
2. Select Install.
A Create Shortcut dialog box opens.

Runtime | 4 - Alarm Viewers | 85

3. Select the folder in which the shortcut should appear, e.g., Desktop.
4. Click OK.

The shortcut is created where you specified, e.g.

.

If you open the shortcut when the project is not running a Select CIMPLICITY Project dialog box
opens to let you easily start the project.
Important: Specify how the Alarm Viewer file should connect to a CIMPLICITY project when
the shortcut is double-clicked. If one or more projects are running, your specification will guide the
project selection. You do this on the General tab in the Alarm List
Tip: : Select Browse for system when connecting on the General tab in the Alarm List
Configuration dialog box to make sure a user can connect to a project no matter where the shortcut is
placed.

Step 7. Configure the Alarm Viewer Fields and Buttons.
The stand-alone AMV fields and buttons configuration (page 86) is similar to configuration for
the AMV Control.

Step 8. Exit the Stand-alone AMV
1. Do one of the following.
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Method 1
a. Click File on the stand-alone AMV menu bar.
b. Select Exit.
Method 2
Press Alt+F+X on the keyboard.
Method 3
Click the Window Close button

.

If you made unsaved changes, a stand-alone AMV message box appears asking you if you want
to save them.
2. Click either:
a. Yes to save the changes, or
b. No to discard the changes, or
c. Cancel to return to the stand-alone AMV .
The stand-alone AMV will close or re-appear based on your selection.

Alarm Viewer Fields and Buttons Configuration
Alarm Viewer Fields and Buttons Configuration
The core configuration for both the stand-alone AMV and AMV OCX is the fields and buttons.
Step 1
(page
86)

Select the AMV Control/AMV alarm list fields.

Step 2
(page
94)

Select the button display for the AMV Control/AMV.

Step 3
(page
105)

Work with AMV Control/AMV buttons.

Step 1. Select the AMV Control/Stand-alone AMV Alarm List Fields
Step 1. Select the AMV Control/Stand-alone AMV Alarm List Fields
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Use the Alarm List Configuration dialog box to configure the Alarm List for the Static Alarm list
view and the Dynamic Alarm list view.
Steps include:
Step 1.1
(page
87)

Display the Fields tab (in the AMV Control/AMV Properties dialog box).

Step 1.2
(page
88)

Select fields for static view.

Step 1.3
(page
89)

Select fields for dynamic view.

Step 1.4
(page
90)

Configure the field display order for each view.

Step 1.5
(page
90)

Specify field column widths and titles.

Step 1.6
(page
91)

Set the alarm message date/time format.

Step 1.1. Display the Fields Tab
Step 1.1. Display the Fields Tab
How you display the Fields tab depends on whether you are working in the AMV Control or the
AMV.
Option
1.1.1 (page
87)

Display the Fields tab in the CIMPLICITY AMV Control Properties dialog box (AMV Object).

Option
1.1.2 (page
88)

Display the Fields tab in the Alarm List Configuration dialog box (stand-alone Alarm Viewer).

Option 1.1.1. Display the Fields Tab in the CIMPLICITY AMV Control Properties Dialog Box
1. Double-click the AMV Control.
The CIMPLICITY AMV Control Properties dialog box opens.
2. Select the Fields tab.
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The list of fields you configure will depend on whether you are configuring a static or dynamic alarm
list.
Note: If any field titles have been modified, the modified title appears in parentheses to the right
of the field name. For example, (Ack), the new name, appears to the right of Ack State, the previous
name.
Option 1.1.2. Display the Fields tab in the Alarm List Configuration Dialog Box
1. Click Configure on the Alarm Viewer menu bar.
2. Select List Layout...
The Alarm List Configuration dialog box appears.
3. Select the Fields tab.
4. Check Display Field Titles if you want the titles to display in the Alarm Viewer in either static
or dynamic view.
The list of fields you configure will depend on whether you are configuring a static or dynamic alarm
list.
Note: If any field titles have been modified, the modified title appears in parentheses to the right
of the field name. For example, (Ack) appears to the right of Ack State.

Step 1.2. Select Fields for Static View
1. Check Static in the Display box on the Fields tab.
The available fields display in the Fields box. The fields describe specifications made for the
point, e.g., Resource ID, as well as current alarm status, e.g., State.
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A

CIMPLICITY AMV Control Properties dialog box

B

Alarm List Configuration dialog box

2. Check the fields you want displayed.

Step 1.3. Select Fields for Dynamic View
1. Check Dynamic in the Display box on the fields tab.
The available fields display in the Fields box. The fields describe specifications made for the
point, e.g., Resource ID, as well as current alarm status, e.g. State.

A

CIMPLICITY AMV Control Properties dialog box
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B

Alarm List Configuration dialog box

2. Select the fields you want displayed.

Step 1.4. Configure the Field Display Order for Each View
1. Select a field when you are in either mode.
The field's static to other fields determines which buttons (to the right of the Fields box) are
enabled.
2. Click the buttons according to where you want the field to display in the Alarm Viewer. The
buttons that are enabled might change as the field moves.
Button

Each Click Moves the Field

Position
Left

One column left.

Position
Right

One column right.

Row Up

Up one row, to the furthest left position in an alarm's message area. Note: The button will only be
active if there is a row above the one in which the field is placed. Example You:
• Start with two rows for each alarm message.
• Select Alarm ID, which currently is in the second row.
• Click Row Up once.
The Alarm ID appears in the first row, furthest left position of each alarm's message. Row Up is no
longer active when Alarm ID is selected.

Row
Down

Down a row in the message. The field will be placed at the start of the message row. (The maximum
row number is 10.) Example You
• Start with two rows for each alarm message.
• Select Alarm ID, which currently is in the first row.
• Click Row Down twice.
The Alarm ID appears in the third row of each alarm's message.

Step 1.5. Specify Field Column Widths and Titles
Columns in the AMV Control/AMV adhere to the width and display the titles that you specify for
the fields that are in the first row. You can associate a title and length with any field that will be used
whenever that field is positioned in the first row of the alarm message.
Note: Column titles appear in the AMV Control only if you check Field titles on the Sort/
Display tab in the CIMPLICITY AMV Control Properties dialog box.
1. Select a field in either Static or dynamic view.
2. Click Modify…
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The Field Properties dialog box for the select field opens.

3. Change the maximum field length in for the Alarm Viewer in the Length field if it should be
different from the current length that displays.
4. Enter a new title for the Alarm Viewer field in the Title Field if it should be different from the
current title that displays.
If you change the title of a field, its original title appears next to the check box in the Fields list,
and the modified title appears to the right in parentheses.
5. Click either:
• OK to accept the changes.
• Cancel to retain the current settings.
The Alarm List Configuration dialog box appears. The field is changed (or not) according to your
specifications.
Tip: Field length is based on the average size of characters in the font you have chosen.
Thus, a length of 6 may be sufficient to display the string IIIIII, but may be too short to display
WWWWWW. To ensure that the length is always adequate, select a fixed pitch font (such as
Courier New) for your alarm page display.

Step 1.6. Set the Alarm Message Date/Time Format
1. Do one of the following:
For the AMV Control
Select the Date Format tab in the CIMPLICITY AMV Control Properties dialog box.
For the stand-alone AMV
Select the Date/Time Format tab in the Alarm List configuration dialog box.
The Date Format or Date/Time Format tab displays a sample of the current format selection.
2. Either:
• Select one of the date format options in the Format list or
• Construct your own format in the (Date) Format field.
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Acceptable entries are:
m

Numeric month with no leading zero.

mm

Numeric month with leading zero.

mmm

Short text month.

mmmm

Long Text month.

d

Numeric day with no leading zero.

dd

Numeric day with leading zero.

ddd

Short text day of the week.

dddd

Long text day of the week.

y

Last two digits of year. For digits 00 through 09, only the last digit is displayed.

yy

Last two digits of year. For digits 00 through 09, both digits are displayed.

yyyy

All four digits of year

You can use spaces, dashes, slashes or any other delimiter of your choice to separate the date
fields.
Example
If you enter dddd dd mmmm yyyy, the sample date will be Saturday 05 March 1994.
3. Either:
• Select one of the time format options in the Time list or
• Construct your own format in the (Time) Format field.
Acceptable entries are:
H

Hours based on a twelve-hour clock with no leading zero.

HH

Hours based on a twelve hour clock with leading zero.

HHH

Hours based on a 24-hour clock with no leading zero.

HHHH

Hours based on a 24-hour clock with leading zero.

M

Minutes with no leading zero.

MM

Minutes with leading zero.

S

Seconds with no leading zero.

SS

Seconds with leading zero.

TT

Hundredths of seconds with leading zeros.

T

Thousandths of seconds with no leading zero.
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TTT

Thousandths of seconds with leading zeros.

P, A, p, or a

AM/PM indicator.

You can use colons, spaces or any other delimiter of your choice to separate the date fields.
Example
If you enter HHHH:MM:SS:TTT p, the sample time will be 13:05:06:085 PM.

AMV Alarm Fields
Each of the AMV Alarm fields that can appear as columns in the AMV OCX Control or AMV
Stand-alone alarm viewer are listed below.
Field/
Column

Description

Comment

The number of operator comments on an alarm.

Stacked

The number of retained occurrences for an alarm that is generated more than once before an operator
deletes it. When the designated number is reached, the system deletes the oldest alarm occurrence as
each new alarm is generated.

Project
Name

Name of the CIMPLICITY project generating the alarm.

Alarm ID

Identifier of the alarm.

Resource ID

Identifier of the factory resource identifier for the alarm, used to control its routing.

Class

Class of the alarm.

Date

Alarm generation date.

Time

In the stand-alone Alarm Viewer, the time is the:
• Alarm generation time.
• In the Alarm Viewer OCX, the time is either the:
◦ Alarm generation time
◦ Alarm generation time and Alarm cleared (Normal) time
Tip: Select what time will display on the Display (page 46) tab in the CIMPLICITY AMV Control
Properties dialog box.

State

Current State of the alarm.

Ack State
(Ack)

Boolean value that indicates whether an alarm has been acknowledged or not.

Reference

Reference identifier for the alarm, used to distinguish to identical alarms.

Severity

A number that indicates the importance of the alarm; the higher the Severity the more severe the state.
CIMPLICITY treats more severe alarms with a higher priority.
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Field/
Column
Category

Description
(AMV Control Properties only) The name of the general category for the generated alarm: Level,
Discrete, or System.
• Level is generated by non Boolean point alarms.
• Discrete is generated by Boolean point alarms.
• System is generated by all alarms not generated by points.

Condition

(AMV Control Properties only) The condition for the generated alarm's Category. Each Category
currently has a Condition that qualifies the type of alarm.
Condition

Generated for

Level

Level alarms

Trip

Discrete alarms

System

System alarms

Subcondition

(AMV Control Properties only) A specific Subcondition that further qualifies the alarm's Condition. For
Level and Trip conditions, the Subcondition column displays a state string associated with the alarm's
State. For the System condition, this column displays "System."

Message

The alarm Message. This message contains the fixed text for the alarm and optional information for the
run-time parameters.
This field normally appears as the first field in the list area below the column headers in the AMV.

Description
The description of the alarm.
For Point Alarms, this is the Point Description.
For Event Alarms, this is the Alarm Definition Description.

Step 2. Select the Button Display for the AMV Control or Stand-alone
AMV
Step 2. Select the Button Display for the AMV Control or Stand-alone AMV
The Alarm Viewer provides a user with several buttons to deal with alarms. For example, a user can
acknowledge, reset or delete an alarm, if you select to display the button for those actions.
Dynamic View updates alarms whenever there is a change.
Dynamic view buttons:
• In the AMV Control, function the same as they do in static view.
• In the AMV, enable you to filter the list of alarms and toggle back to Static View.
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Static View updates alarms when an operator clicks the Refresh button.
Static view buttons provide the user with the capability to respond to alarms.
• You can select which buttons you want to display and, as a result, control the actions a user can
take when an alarm displays.
• You do the configuration on the Button Layout tab in the Alarm List Configuration dialog box.
Steps for handling buttons include:
Step 2.1
(page
95)

Display the Buttons or Button Layout tab (for AMV Control or AMV).

Step 2.2
(page
97)

Select buttons for static view.

Step 2.3
(page
98)

Select buttons for dynamic view.

Step 2.4
(page
98)

Create custom buttons.

Step 2.5
(page
103)

Configure the button display order for each view.

Step 2.6
(page
103)

Specify the button caption, description and command string.

Step 2.1. Display the Buttons or Button Layout Tab
Step 2.1. Display the Buttons or Button Layout Tab
Whether you display the Buttons tab or the Button Layout tab depends on whether you are working
in the AMV Control or the stand-alone AMV.
Option
2.1.1 (page
96)

AMV Control.

Display the Buttons tab in the CIMPLICITY AMV Control Properties dialog box.
Option
2.1.2 (page
96)

Stand-alone Alarm Viewer.

Display the Button Layout tab in the Alarm List Configuration dialog box
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Option 2.1.1. Display the Buttons Tab in the CIMPLICITY AMV Control Properties Dialog Box
1. Right-click the Alarm Viewer control.
2. Select CIMPLICITY AMV Control Object>Properties.
The CIMPLICITY AMV Control Properties dialog box opens.
3. Select the Button Layout tab.
The Buttons tab initially displays the buttons selected for the static view.

Option 2.1.2. Display the Button Layout Tab in the Alarm List Configuration Dialog Box
1. Click Configure on the Alarm Viewer menu bar.
2. Select List Layout...
The Alarm List Configuration dialog box appears.
3. Select the Button Layout tab.
The Button Layout tab initially displays the buttons selected for the static view.
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Step 2.2. Select Buttons for Static View
1. Check Static in the Display box on the Button Layout tab.
The available buttons display in the Buttons box.

2. Check the buttons you want users to display.
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Step 2.3. Select Buttons for Dynamic View
1. Check Dynamic in the Display box on the Button Layout tab.
The available buttons display in the Buttons box.
Note: The AMV Control has all buttons available for dynamic view; the AMV has Toggle and
Setup only.

2. Check the buttons you want users to display.
Once you have selected the buttons for display in the alarm list, you can configure which button
row the button will be placed in, where in the row it will be placed, and what caption will be
displayed.

Step 2.4. Create Custom Buttons
Step 2.4. Create Custom Buttons
Both the stand-alone alarm viewer and AMV control provide the option to create custom buttons.
There are two types of custom buttons that can be added:
• Stand-alone AMV and AMV control custom button.
• AMV control only CustomButton event.
Stand-alone AMV and AMV control custom button
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Custom buttons are available in both the stand-alone Alarm Viewer and AMV Control.
A custom button additional functionality to make sure the Alarm Viewer meets your system's
requirements. Custom buttons can be configured to trigger command strings that perform several
functions, such as run a program, create a set of long term notes that describe the historical
conditions surrounding past alarm conditions in a factory or, for the AMV Control, fire an ActiveX
event.
1. Select a Custom<N> button to customize.
2. Click Modify....
The Button Caption dialog box opens for the selected custom button.
Options are as follows.

Field

Description

Button
Caption

Caption that will display on the button

Description

Brief description of the button purpose.

Command
string

Command string that will be executed when the button is clicked. Note: Check Run program in the
AMV Control Button Caption dialog box.

Run
program

Check to run the command string when the button is clicked.

Fire ActiveX
event

(Alarm Viewer Control only) Use a CustomButton (page 131) event.

3. Click OK.
The configured action will occur when a user clicks the customized button in the Alarm Viewer.
Parameters for Alarm Viewers
Parameters for substitution in Alarm Viewers
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You may include any of the following parameters, which will be substituted with characteristics of
the selected alarm, in your command:
Parameter

Value

%ACK

Y or N, if selected alarm is acknowledged

%CATEGORY

OPC Category (page 93): Level, Discrete, or System (AMV Control only)

%CONDITION

OPC Condition (page 93): Level, Trip, or System (AMV Control only)

%DATETIME

Alarm Generation date and time

%DT

same as %DATETIME

%DATE

Alarm Generation date

%TIME

Alarm Generation time

%ID

Alarm Identifier of the selected alarm

%CLASS

Alarm class of the selected alarm

%RESOURCE

Factory resource of the selected alarm

%RES

same as %RESOURCE

%REFERENCE

Alarm reference identifier for the selected alarm

%REF

same as %REFERENCE

%MESSAGE

Alarm message for the selected alarm

%MSG

same as %MESSAGE

%SCREEN

(Alarm Viewer Control only) Provide access to the screen associated with an alarm so the user can
run CimView using that screen and any additional options.

%STATE

Current alarm state of the selected alarm

%SUB
CONDITION

OPC Subcondition (page 93) (AMV Control only).

Parameter for a selected alarm
(AMV Control only) The following parameter provides a user access to other CimView screens.
Parameter
%SCREEN

Value
Provide access to the screen associated with an alarm so that the user can run CimView using that
screen and any additional options they wish.

Parameters in Alarm Viewer that don't require a selected alarm
The following additional parameters do not require the user to select an alarm:
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Parameter

Value

%%

An embedded percent sign

%USER

User ID of the user invoking the command

%PRODUCT

CIMPLICITY distribution directory

%CIM

same as %PRODUCT

%DIRECTORY

CIMPLICITY project directory

%DIR

same as %DIRECTORY

%PROJECT

CIMPLICITY project name

%PRJ

same as %PROJECT

Example. Create a Run a Message Program Custom Button
1. Open the Basic Control Engine Program
2. Enter the following script in the CIMPLICITY Program Editor.
Sub Main()
MsgBox Command$
End Sub

3. Create the script as a program in the project's scripts directory.
Example
C:\Projects\ECimp\Scripts\GetMessage.exe.
4. Open a Button Caption (page 98) dialog box for a Custom Button in either of the Alarm
Viewers.
5. Enter the following.
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Field

Enter

Button
caption

Message.

Description

Alarm message

Command
string

...\<project

path>\<project name>\Scripts\GetMessage.exe %Message Where <project path> is
the full path to the project. <project name> is the project's name %Message is the Alarm Viewer
Message (page 99) parameter.

6. Check Run program.
7. Click OK.
A Message button is added to the Button bar.

8. Test the button in runtime.
The message associated with the selected alarm displays in a message box.

A

Select an alarm ID.

B

Click Message.

C

A Basic Script message box displays the message specified for the alarm in the Alarm Message field.

Example. Use a Custom Button to Create a Set of Long-term Notes
1. Select a Custom<N> button to customize.
Example

2. Enter the following.
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Field

Enter

Button caption

Notes.

Description

Edit Alarm notes for a selected alarm.

Command string

NOTEPAD %DIR\NOTES\%ID.TXT

3. Click OK.
When a user clicks this button, a new Notepad will be executed for a file in the Notes sub-directory
of the CIMPLICITY project directory. The Alarm ID of the selected alarm determines the filename.

Step 2.5. Configure the Button Display Order for each View
1. Select a button in either view.
The buttons to the right of the Buttons box activate based on what position the button is
currently in.
2. Click the following buttons according to where you want the button to display in the Alarm
Viewer.
Button

Each Click Moves the Button

Position Left

One button left.

Position
Right

One button right.

Row Up

Up one row. The button will only be active if there is a row above the one in which the button is
placed.

Row Down

Down one row.

Step 2.6. Specify the Button Caption, Description and Command String
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1. Select a button in the list of buttons.
2. Click Modify....
The Button Caption dialog box opens.
If you are modifying a CIMPLICITY AMV Control or stand-alone AMV button, the Button
Caption dialog displays the default entries in the Button Caption and Description field. The
Command String field is dimmed.

If you are creating a custom button all three fields are available for entry.

3. Enter the new caption that will appear on the button in the Button Caption field. You may enter
up to 100 characters.
4. Enter a description in the Description field.
5. (For a custom button) Enter the command string, in the Command String field, that you want
to be executed when the button is clicked.
6. Click OK.
The new button name appears in parentheses next to the original button name or Custom 1, 2, 3, etc.
If the buttons are selected to display, the new names appear on them immediately.
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Step 3. Work with the AMV Control/Stand-alone AMV Buttons
Step 3. Work with the AMV Control/Stand-alone AMV Buttons
Option
3.1 (page
105)

Setup button: Configure AMV Control/Stand-alone AMV Alarm setups. Note: And Setup icon in the
Workbench.

Option
3.2 (page
120)

Ack and/or Reset buttons: Acknowledge and Reset alarms.

Option
3.3 (page
123)

Help button: Using customized help.

Option
3.4 (page
124)

Refresh button: Refresh the Alarm Viewer list.

Option
3.5 (page
124)

Toggle button: Toggle between Alarm Viewer static and dynamic view.

Option
3.6 (page
125)

View Stack button: Viewing the alarm stack.

Option
3.7 (page
126)

Comments button: View alarm comments.

Option
3.8 (page
129)

CimView screen button: View an alarm's CimView screen.

Option
3.9 (page
130)

Delete button: Delete an alarm.

Option 3.1. Setup Button: Configure AMV Control/Stand-alone AMV Alarm Setups
Option 3.1. Setup Button: Configure AMV Control/Stand-alone AMV Alarm Setups
Normally, all alarms for the roles assigned to your CIMPLICITY User ID are displayed on the Alarm
Viewer screen.
Alarm filtering, which is configured in a Modify Setup dialog box, enables a user to filter the list by
displaying certain subsets of alarms.

Runtime | 4 - Alarm Viewers | 106

Authorized users can open the Modify Setup dialog box through the Workbench, the Alarm Viewer
control or the Alarm Viewer. The procedure to open the Modify Setup dialog box and its setup
options are slightly different based on the application through which it is opened.
Steps to open the Modify Setup dialog box and create alarm filter setups include:
Step 3.1.1
(page
106)

Select a filter to load or to modify.

Step 3.1.2
(page
109)

Modify the Alarm Viewer setup class list.

Step 3.1.3
(page
109)

Modify the Alarm Viewer setup resource list.

Step 3.1.4
(page
110)

Configure the AMV setup time, state and sort.

Step 3.1.5
(page
115)

Modify the Alarm Viewer Setup String Filters

Step 3.1.6
(page
116)

Create a new alarm filter setup.

Step 3.1.7
(page
119)

Delete an alarm filter setup.

Step 3.1.8
(page
119)

Select the default alarm filter setup.

Note: Only users who have been granted the Modify Alarm Setups privilege in the Role
Properties dialog box can save a new setup, load a different setup or make the current setup the
default.
Step 3.1.1. Select a Filter Setup to Load or to Modify
• Alarm Viewer Control Setup button.
• Alarm Viewer Setup button.
• Workbench Alarm Setups icon (modify a setup)
• Alarm Sound Manager Setup field
Alarm Viewer Control Setup Button
1. Click Setup

in an Alarm Viewer:
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The Alarm Setups dialog box opens.
2. Select a setup to modify as follows.

A

Select the project to which the Alarm Viewer control will be connected.

B

Select the alarm setup that will be loaded or modified. The setup name displays in the Setup field.

C

Click one of the following buttons.
Load

The setup loads in the Alarm Viewer. The Alarm List is re-filtered and re-displayed.

Modify Current

The Modify Setup dialog box opens. Continue to Step 3.1.2 (page 109).

Alarm Viewer Setup Button
3. Click Setup

in an Alarm Viewer:

The Alarm Setups dialog box opens.
4. Select a setup to modify as follows.

A

Select the alarm setup that will be loaded or modified. The setup name displays in the Setup field.

B

Click one of the following buttons.
Load

The setup loads in the Alarm Viewer. The Alarm List is re-filtered and re-displayed.
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Modify Current

The Modify Setup dialog box opens. Continue to Step 3.1.2 (page 109).

Workbench Alarm Setups Icon (Modify a Setup)
Note: An authorized user can open a Modify Setup dialog box to modify an existing setup.
The project does not have to run to open the Modify Setup dialog box through the Workbench.
5. Select a Setup ID in the Workbench right-pane.
6. Do one of the following.

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm Setups.
b. Select Properties on the Popup menu.

D

In the Workbench right pane:
Either
Double click the Setup ID

E

Or
a. Right-click the Setup ID.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

7. Right-click Alarm Setups.
8. Select Properties on the Popup menu.
9. Right-click the Setup ID.
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10. Select Properties on the Popup menu.
Step 3.1.2. Modify the Alarm Viewer Setup Class List
The Classes tab displays the currently available and selected classes.
Select the Classes tab and do the following.

A

Do one of the following for each class to include it in/exclude it from the setup.

B

Check

Include in the setup.

Clear

Exclude from the setup.

(Optional) Click one of the following to make global changes.

C

Add All

Selects all classes

Remove All

De-selects all classes.

Click OK, Cancel or Apply to apply or cancel your changes.

Step 3.1.3. Modify the Alarm Viewer Setup Resource List
1. Select the Resources tab.
The Resources tab displays the currently available and selected resources.
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2. Do the following.

A

B

C

Do one of the following for each resource to include it in/exclude it from the setup.
Check

Include in the setup.

Clear

Exclude from the setup.

(Optional) Click one of the following to make global changes.
Add All

Selects all resources

Remove All

De-selects all resources.

Click OK, Cancel or Apply to apply or cancel your changes.

Step 3.1.4. Configure the AMV Setup Time, State and Sort
Step 3.1.4. Configure the AMV Setup Time, State and Sort
Configuration options include:
Option 3.1.4.1
(page 110)

(For the AMV Control or Alarm Sound Manager (page 155)) Configure
time/state criteria.

Option 3.1.4.2
(page 112)

(For the stand-alone AMV) Configure time/state/sort criteria.

Option 3.1.4.1. AMV Control Setup Time and State
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Select the Time and State Filter tab.
• Time and State filter.
• Sorting.

Time and State Filter
Time and state filter options are as follows.

rect 125, 269, 144, 288 (page 112)
rect 4, 131, 23, 150 (page 112)
rect 6, 49, 25, 68 (page 111)
A
(page
111)

Filter by time.

B
(page
112)

Filter by state.

C
(page
112)

Buttons

A

Filter by time

Check or clear the Use Time filter checkbox to select whether or not alarms will be filtered by time.
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Check

The Select alarms since field is enabled and displays the current date and time. Enter the date and time that
is the start criteria for displaying alarms as follows.
Select alarms since

Month

Day

Year

Hour

Minutes

Seconds

Important: Enter hours as 1-23. There is no AM/PM specification.
The AMV control displays alarms that were generated starting at the entered date.
Clear

B

Alarms will display regardless of when they occurred. Alarms that have not been removed from the list by other
means, e.g. acknowledge and reset, display, regardless of when they occurred.

Filter by state

Check the options in the Filter by State box to limit the alarms displayed on the Alarm List to only
those that occur in the state you select.
The options are:
State

Ack Status

Alarm

N

Display points in Alarm State that have not been acknowledged.

Alarm

Y

Display points in Alarm State that have been acknowledged.

Normal

N

Display points that have returned to a normal state but have not been acknowledged.

C

Check to

Buttons

Click OK, Cancel or Apply to apply or cancel your changes.

Sorting
Sorting in the AMV control can be selected:

• On the Sorting tab in the CIMPLICITY AMV Control Properties dialog box when the Control is
configured.
• By clicking the title bar in any of the columns.
Note: Sorting needs to be permitted in the CIMPLICITY AMV Control Properties dialog
box.

Option 3.1.4.2. Modify the Stand-alone AMV Setup Time, State and Sort
Select the Time/State/Sort tab.
Time and state filter options and sort options are as follows.
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rect 125, 269, 144, 288 (page
rect 4, 131, 23, 150 (page 114)
rect 6, 49, 25, 68 (page 113)
A
(page
113)

Filter by time.

B
(page
114)

Filter by state.

C
(page
114)

Buttons.

D
(page
114)

Sort.

A

)

Filter by time.

Check or clear the Use Time filter checkbox to select whether or not alarms will be filtered by time.
Check

The Select alarms since field is enabled and displays the current date and time. Enter the date and time that
is the start criteria for displaying alarms as follows.
Select alarms since

Month

Day

Year

Hour

Minutes

Seconds

Important: Enter hours as 1-23. There is no AM/PM specification.
The AMV control displays alarms that were generated starting at the entered date.
Clear

Alarms will display regardless of when they occurred. Alarms that have not been removed from the list by other
means, e.g. acknowledge and reset, display, regardless of when they occurred.
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B

Filter by state

Check the options in the Filter by State box to limit the alarms displayed on the Alarm List to only
those that occur in the state you select.
The options are:
State

Ack Status

Alarm

N

Display points in Alarm State that have not been acknowledged.

Alarm

Y

Display points in Alarm State that have been acknowledged.

Normal

N

Display points that have returned to a normal state but have not been acknowledged.

C

Check to

Sort

Sorting
Select the option in the Sort box to select the primary sort parameter for the Alarm list.
Note: Sort options are not available in the Modify Setup window that is opened through the
Workbench. A user who has authority to modify an existing setup must access the Modify Setup
window through the Alarm Viewer to change the alarm list.
The sort options are:
Option

Select to Sort Alarms

Class

In the selected classes, alarms are sorted, lowest to highest, in the sort order assigned to each Alarm Class
when it was created.

Resource

In the selected resources, alarms are sorted alphabetically, lowest to highest, by Resource ID.

State
According to a combination of their State and Ack Status in the following order:
All unacknowledged alarms in Alarm state
All unacknowledged alarms in Normal state
All acknowledged alarms in Alarm state
Time
(Default) Alarms are arranged according to the time of their occurrence, with the most recent first.
The default sort key is Time. If a category other than Time is selected as the primary sort key, the
secondary sort key is Time.

D

Buttons

Click OK, Cancel or Apply to apply or cancel your changes.
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Step 3.1.5. Modify the Alarm Viewer Setup String Filters
You can use string filters to filter alarm IDs, messages, or descriptions using substrings, wildcards, or
regular expressions.
Select the String Filters tab.
The String Filter options are as follows.

String Filters
Item

Description

Alarm ID filter

Enter the ID of the alarm that you want to filter using one of the string formats described below.

Alarm message filter

Enter the message of the alarm that you want to filter using one of the string formats described
below.

Alarm description
filter

Enter the description of the alarm that you want to filter using one of the string formats described
below.

String Filter Formats
Item

Description

Substring
Enter a substring based on which the alarm filter will be applied.
Example
If you wish to display all alarms that contain the substring ABC in their IDs, in the Alarm ID filter box, select
the Substring option, and enter ABC.
All the alarms containing the substring ABC in their IDs will be displayed.

Runtime | 4 - Alarm Viewers | 116

Item

Description

Wildcard
Enter a string containing a wildcard character based on which the alarm filter will be applied.
Example
If you wish to display all alarms that contain the string ABC as the first three characters in their message, in
the Alarm message filter box, select the Wildcard option, and enter ABC*.
All alarms containing the string ABC as the first three characters in their message will be displayed.
Regex
Enter a string containing a regular expression based on which the alarm filter will be applied. The regular
expression grammar supported is ECMAScript.
Example
If you wish to display all alarms that contain the strings ABC1, ABC2, and ABC3 as their description, in the
Alarm description filter box, select the Regex option, and enter ABC[1-3].
All alarms containing the strings ABC1, ABC2, and ABC3 as their description will be displayed.

Step 3.1.6. Create a new Alarm Filter Setup
This task describes how to create a new alarm filter. It mentions the Alarm Viewer Control Setup
button, Alarm Viewer Setup button, Workbench Alarm Setups icon, Alarm Sound Manager Setup
field, and the Global setup name.
Alarm Viewer Control Setup Button
1. Click Setup

in an Alarm Viewer. The Alarm Setups dialog box opens.

2. Create a new setup as follows.

A

Select the project to which the Alarm Viewer control will be connected.

B

Enter a new setup name in the Setup field.

C

Click Modify Current.
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The Modify Setup dialog box opens. Continue to Step 3.1.2 (page
96).

Alarm Viewer Setup Button
3. Click Setup

in an Alarm Viewer. The Alarm Setups dialog box opens.

4. Create a new setup as follows.

A

Enter a new setup name in the Setup field.

B

Click Modify Current.
The Modify Setup dialog box opens.
Continue to Step 3.1.2 (page 109).

Workbench Alarm Setups Icon
Note: The project does not have to run to open the Modify Setup dialog box through the
Workbench.
5. Select a Setup ID in the Workbench right-pane.
6. Do one of the following.
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A

Click File>New>Object on the Workbench menu bar.

B

Click the New button on the Workbench toolbar.

C

In the Workbench left pane:
Either
Double click Alarm Setups.

D

Or
a. Right-click Alarm Setups.
b. Select New on the Popup menu.

In the Workbench right pane:
a. Right-click the Setup ID.
b. Select Properties on the Popup menu.

E

a. Press Ctrl+N on the keyboard.

A New Setup dialog box opens when you use any method.
7. Enter the following.

Field

Description

Setup
ID

A new setup name.

User
ID

User who will be associated with the setup. The assigned can modify the setup at any time, whether or
not their role has been assigned the Modify alarm setups privilege in the Roles dialog box.

8. Click OK.
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The Modify Setup dialog box opens for the new setup.
Alarm Sound Manager Setup Field
An Alarm Setups dialog box can also be opened through the CIMPLICITY© Alarm Sound Manager
(page 155) . This dialog box opens the same Modify Setup dialog box that is opened through the
Alarm Viewers or the Workbench.
Global Setup Name
Use the prefix $ to make the setup global, available to all project users.
Example
Prefix

Setup Name

Description

$

$Setup1

The setup is available to all project users.

Setup1

The setup is available only to the user who configured it.

Step 3.1.7. Delete an Alarm Filter Setup
1. Select the setup name in the list.
The name appears in the Setup field.
2. Click Delete.
The setup name is removed from the list.
Note: Any user created Alarm Viewer setup can be deleted. System created setups require the
Modify alarm setups privilege.
Step 3.1.8. Select the Default Alarm Filter Setup
1. Select the setup in the list that will be the default.
The setup name appears in the Setup field.
2. Click Make Default.
The next time the Alarm Viewer file opens the selected setup will be loaded.
One setup in the list is the default setup, which loads when the Alarm Viewer file opens.
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When you install CIMPLICITY software, the default setup is <<UNFILTERED>>. However, you
can choose any setup to be the default.
Note: For the AMV Control, you can also select the default filter in the CIMPLICITY AMV
Control Properties dialog box.

Option 3.2. Ack and/or Reset Buttons: Acknowledge and Reset Alarms
Option 3.2. Ack and/or Reset Buttons: Acknowledge and Reset Alarms
Whether or not an operator can (or needs to) acknowledge and/or reset and/or delete alarms depends
on a variety of factors including:
• Deletion requirements for each alarm are specified on the Alarm Options tab in the
• Point Properties dialog box or
• Alarm Definition dialog box.
• Automatic actions are specified on the same tabs.
• Manual reset allowed is also specified on the same tabs.
• An operator's deletion privilege is specified on the Privileges tab in the Roles Properties dialog
box.
Available buttons include:
Button
Option
3.2.1 (page
121)
Option
3.2.2 (page
121)
Option
3.2.3 (page
122)
Option
3.2.4 (page
122)
Option
3.2.5 (page
122)

Description

Ack

Acknowledge a selected alarm.

Reset

Reset a selected alarm.

Ack First

Acknowledge the first alarm in the list.

Ack All

Acknowledge all alarms.

Ack and Reset

Acknowledge and reset a selected alarm.

(page
121)

(page
121)

(page 122)

(page
122)

(page 122)

How the Alarm Viewer responds to each of the qualified user's actions depends on the specifications
made during alarm configuration.
1. Do one of the following, depending on the alarm being configured.
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Method 1. Configure a system alarm.
a. Select Project>Alarms in the Workbench left pane.
b. Double-click the appropriate Alarm ID in the Workbench right pane.
The Alarm Definition dialog box opens.
Method 2. Configure a point alarm.
a. Select Project> Points in the Workbench left pane.
b. Double-click the appropriate point ID in the Workbench right pane.
The Point Properties dialog box opens.
2. Select the Alarm Options tab.
3. Select the options required for the alarm.
4. Click OK.
AMV Control/AMV responses may include changing the font color, resetting the Alarm state to
Normal or automatically deleting the Alarm ID. The exact response depends on these specifications
static to the button that is clicked.
Option 3.2.1. Ack Button: Alarm ID Acknowledged
A user can acknowledge an alarm to inform other users that the alarm has been seen and, if
necessary, the condition that set off the alarm is being investigated and worked on.
How the Alarm Viewer responds when a user clicks Ack, depends on what was configured on the
Alarm Options tab in the Alarm Definition (or Point Properties) dialog box.
On Alarm Options
Reset is required

In Alarm Viewer

Alarm ID

Reset is not clicked and No auto reset

Font color changes

Reset is clicked or Auto reset

Is deleted

Reset is not required

Is deleted

Option 3.2.2. Reset Button: Alarm ID Reset
If manual reset is enabled, a user can manually reset an alarm to indicate to the system that the alarm
condition is being manually overridden. The alarm will not be triggered again until the situation
returns to the configured acceptable range and then goes back out of the acceptable range.
Manual reset is enabled on the Alarm Options tab of the Alarm Definition (or Point Properties)
dialog box.
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The system automatically resets an alarm if the condition that triggered the alarm returns to within
acceptable limits.
How the Alarm Viewer responds when a user clicks Reset, depends on what was configured on the
Alarm Options tab in the Alarm Definition dialog box.
On Alarm Options

In Alarm Viewer

Alarm ID

Ack is required

Ack is not clicked and No auto acknowledge

Font color changes

Ack is required

Ack is clicked or Auto acknowledged

Is deleted

Ack is not required

Is deleted

Option 3.2.3. Ack First Button: First Alarm Acknowledged
A user can acknowledge the first alarm in an alarm list.
How the Alarm Viewer responds when a user clicks Ack First, depends on what was configured on
the Alarm Options tab in the Alarm Definition (or Point Properties) dialog box.
On Alarm Options

In Alarm Viewer

First Alarm ID

Reset is required

Reset is not clicked and No auto reset

Font color changes

Reset is required

Reset is clicked or Auto reset

Is deleted

Reset is not required

Is deleted

Option 3.2.4. Ack All: All Alarms Acknowledged
A user can acknowledge all the alarms in an alarm list.
How the Alarm Viewer responds when a user clicks Ack All, depends on what was configured on the
Alarm Options tab in the Alarm Definition (or Point Properties) dialog box.
In Alarm Options

In Alarm Viewer

All Alarm IDs

Reset is required

Reset is not clicked and No auto reset

Font colors change

Reset is required

Reset is clicked or Auto reset

Are deleted

Reset is not required

Are deleted

Option 3.2.5. Ack and Reset: Alarm Acknowledged and Reset
If manual reset is enabled, a user can simultaneously acknowledge and manually reset an alarm.
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The alarm will not be triggered again until the situation returns to the configured acceptable range
and then goes back out of the acceptable range.
When Ack and Reset is clicked:
How the Alarm Viewer responds when a user clicks Ack and Reset, depends on what was
configured on the Alarm Options tab in the Alarm Definition (or Point Properties) dialog box.
Manual Reset is not Enabled
On Alarm Options

In Alarm Viewer

Alarm ID

Reset is required

Ack and Reset is clicked

Font color changes

Reset is required

Auto acknowledged and reset

Is deleted

Reset is not required

Ack and Reset is clicked or Auto acknowledged and reset

Is deleted

Manual Reset is Enabled
In Alarm Options

In Alarm Viewer

Alarm ID

Reset is required

Ack and Reset is clicked or Auto Ack and reset

Is deleted

Reset is not required

Ack and Reset is clicked or Auto acknowledged and reset

Is deleted

Option 3.3. Help Button: Using Customized Help
When a user clicks Help an alarm help file displays if one was assigned to the Alarm ID on the
Alarm tab of the Alarm Definition dialog box.
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Option 3.4. Refresh Button: Refresh the Alarm Viewer List
When the Alarm Viewer is in static view, a user needs to refresh the screen in order to view alarms
that have occurred since the last time the screen was refreshed.
The Refresh button enables the user to refresh the screen.

Option 3.5. Toggle Button: Toggle Between Alarm Viewer Static and Dynamic View
A user may want to keep the Alarm Viewer in dynamic view in order to see alarms as they occur.
In the Alarm Viewer the user will have to switch to static view in order to deal with the alarm.
The Toggle button enables the user to switch back and forth.
When the user clicks:
Toggle in Static View

Dynamic View displays

Toggle in Dynamic View

Static View Displays.
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Option 3.6. View Stack Button: Viewing the Alarm Stack
An alarm can be configured so the states it passes through can be kept or stacked.
If the number of states exceeds the maximum number configured for the alarm's stack, the oldest
occurrences are eliminated.
Note: The maximum stack number is specified on the Alarm Options tab in the Point ID's Point
Properties dialog box.
If an alarm has stacked occurrences, and the Stacked field is being displayed, a user will see an
asterisk (*) in the Stacked field.
When an alarm is deleted, all occurrences of the stacked alarm are deleted.
Example

To view stacked alarm messages:
1. Click View Stack.
A Stacked Alarm Messages window opens displaying the date, time, state, message, and
acknowledged state of each alarm.

2. Click Done.
The Stacked Alarm Messages window closes. The Alarm Viewer screen reappears.
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Comments Button: View Alarm Comments
Option 3.7. Comments Button: View Alarm Comments
A comment is a line of text that can be entered by any user who can view the alarm.
Up to 20 comments can be associated with a current alarm.
If an alarm has comments, and the Comments field is being displayed, a user will see a C in the
Comments field.
Example

You can specify that comments will be available for viewing in the Project Properties dialog box.
Comments can be:
• Available only while an Alarm ID appears in the Alarm Viewer. When the Alarm ID has been
reset, deleted, or automatically removed, the comment ceases to exist, or
• Stored until 20 comments have been listed for one Alarm ID, regardless of whether the alarm
has been acknowledged, reset, deleted, etc. When 20 comments have accumulated, the first
comment entered is deleted to make room for the newest comment.
Options for comments include:
Option
3.7.1 (page
126)

View comments.

Option
3.7.2 (page
127)

Add comments.

Option
3.7.3 (page
128)

Store comments.

Option
3.7.4 (page
129)

Delete comments.

Option 3.7.1. View Comments for an Alarm
1. Click Comments.
An Alarm Comments window displays existing comments for the alarm.
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2. Click either:
• Done when you finish reading the comments.
The Alarm Comments dialog box closes.
• Click Add Comment to add a comment.
The Add Comment dialog box opens.
Option 3.7.2. Add Comments for an Alarm
1. Click Add Comment in the Alarm Comments dialog box.
An Add Comment dialog box opens.
2. Enter a comment.

3. Click OK.
The comment appears at the top of the list of comments in the Alarm Comments dialog box.
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4. Click Done.
A C appears next to the Alarm ID indicating that the alarm has comments.
Option 3.7.3. Store up to 20 Alarm Comments
Alarms can be temporarily stored in either of two ways:
• Only while an Alarm ID appears in the Alarm Viewer.
When the Alarm ID has been reset, deleted, or automatically removed, the comment ceases to exist.
• Until 20 comments have been listed for one Alarm ID, regardless of whether the alarm has been
acknowledged, reset, deleted, etc.
When 20 comments have accumulated, the first comment entered is deleted to make room for the
newest comment.
1. Click Project>Properties on the Workbench menu bar.
The Project Properties dialog box opens.
2. Select the Settings tab.
3. Select Alarms.
4. Click Settings.
The Alarm Properties dialog box opens.
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5. Check Store alarm comments to store up to 20 comments for an Alarm ID.

6. Click OK.
7. Update the project configuration.
The next time the project starts comments will be stored according to your specifications.
Option 3.7.4. Delete an Alarm's Comments
1. Select a comment in the Add Comments dialog box.
The Delete Comments button is enabled.
2. Click the Delete Comments button.

The comment is deleted and is no longer visible in the Alarm Comments dialog box.

Option 3.8. CimView Screen Button: View an Alarm's CimView Screen
1. (If not already configured) associate the involved Point ID with a CimView screen.
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a. Open the Point Properties dialog box for selected Point ID that has a configured alarm.
b. Click Advanced on the General tab.
c. Select the View tab that appears.
d. Select a Screen from the selection in the drop down menu. Your options include CimView
screens that are in the project directory.
e. Update the project's configuration.
2. Open the Alarm Viewer while the project is running.
3. Select the Alarm ID when the point is in Alarm State and appears in the Alarm Viewer.
4. Click CimView Screen.
The associated CimView screen opens.
Note: If no screen is defined for the alarm, an appropriate message display.

Option 3.9. Delete Button: Delete an Alarm
1. Select the Points icon.
2. Double-click the appropriate Point ID in the right pane of the Workbench.
3. Open the Alarm Viewer.
4. Click Delete.
If the specified conditions are met, the alarm will be deleted.

AMV Control ActiveX Events
AMV Control ActiveX Events
1. Right-click the Alarm Viewer control.
2. Select Properties on the Popup menu.
3. Select the Events tab.
4. Configure any of the available Alarm Viewer control ActiveX events.
CustomButton
NewAlarm
AlarmItemClick
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CustomButton
CustomButton
CustomButton triggers a procedure or script when a user clicks a custom button in the Alarm Viewer
control.

Field

Description

Event

ActiveX Event provides the CustomButton expression.

ActiveX Event

CustomButton is included in the drop-down list.

Action

Contains a drop-down list of existing procedures and scripts. Use either of the following.

Parameter

Procedure

Create or use an existing procedure.

Script

Create or use an existing script.

Can be used if the event invokes a script directly or through a procedure. The
default code begins as follows. Private cimOleObj As AMVOCXLib.IAmvOcx Sub
OnCustomButton(ButtonNumber As Long, ButtonString As String) Where parameters
are:
ButtonNumber

Number assigned to the custom button, e.g. 1 for Custom1.

ButtonString

Value returned when a command string (page 98) is executed.

Example: Create an ActiveX Event Custom Button
1. Open a Button Caption (page 98) dialog box for a Custom Button in the CIMPLICITY
AMV Control Properties dialog box.
Note: The mode on the Buttons tab can be Static or Dynamic.
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2. Enter the following.

Field

Enter

Button caption

Point Value.

Description

Message for selected alarm.

Command string

%MSG

3. Check Fire ActiveX event.
4. Click OK.
5. Repeat 1-4 for either the Static or Dynamic mode, whichever still needs the button, so the button
will display in both modes.
6. Close the CIMPLICITY AMV Control Properties dialog box.
A PointValue button displays in the Button bar.

7. Open the Properties - Object dialog box (Alt+Enter).
8. Select Events.
9. Configure a CustomButton event as follows.
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rect 81, 121, 110, 152 (page 133)
rect 79, 150, 113, 181 (page 133)
rect 75, 202, 117, 233 (page 133)
A

Event

Select ActiveX Event.
B

ActiveX Event

Select CustomButton.
C

Action

Create a new script.
For this example:
a. Copy the PointGet (function) script example from the Basic Control Engine
documentation into the Script editor to create message boxes that will display the value for
a specified point.
b. Include the ButtonString (page 131) parameter value in the message.

The script is as follows.
Sub OnCustomButton(ButotonNumber As Long, ButtonString As String)
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MsgBox "Value is " & PointGet(InputBox$("Enter Point Id") ) & ebCRLF
_
& "ATTENTION: = " &ButtonString
End Sub

10. Click OK.
11. Test the PointView button.
When a user clicks Point Value, a message box displays for a Point ID; the specified point ID value
and the alarm message are returned.

A

Click Point Value. A BasicScript message box opens.

B

Enter a Point ID in the message box field.

C

A Basic Script message box displays the:
• Point value.
• Message for the selected alarm.

NewAlarm
NewAlarm triggers a procedure or script when a new alarm is received or when an existing alarm has
a state change.
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Field

Description

Event

ActiveX Event provides the NewAlarm expression.

ActiveX Event

NewAlarm is included in the drop-down list.

Action

Contains a drop-down list of existing procedures and scripts. Use either of the following.

Parameter

Procedure

Create or use an existing procedure.

Script

Create or use an existing script.

Can be used if the event invokes a script directly or through a procedure. The
default code begins as follows. Private cimOleObj As AMVOCXLib.IAmvOcx Sub
OnNewAlarm(NewAlarms As Boolean, AlarmCount As Long, AlarmDate As String)
Where parameters are:
NewAlarms

True if a new alarm was received.

AlarmCount

Number of alarms being displayed.

AlarmDate

Time stamp of the alarm update or new alarm.

AlarmItemClick
AlarmItemClick
AlarmItemClick triggers a procedure or script that can provide a list of information when a user
clicks an alarm in the Alarm Viewer control.
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Field

Description

Event

ActiveX Event provides the AlarmItemClick expression.

ActiveX
Event

AlarmItemClick is included in the drop-down list.

Action

Contains a drop-down list of existing procedures and scripts. Use either of the following.

Parameter

Procedure

Create or use an existing procedure.

Script

Create or use an existing script.

Can be used if the event invokes a script directly or through a procedure. The default code begins
as follows. Private cimOleObj As AMVOCXLib.IAmvOcx Sub OnAlarmItemClick(AlarmInfo As
AMVOCXLib.AmvOcxAlarmItemInfo, ClickSource As Long) Where parameters are:
AlarmInfo

Object that accesses several properties as follows.
Property

Description

String
AlarmIdentifier()

Alarm ID

String
ResourceIdentifier()

Resource ID

String
ReferenceIdentifier()

Reference ID

String Project()

Project name

Date
GenerationTime()

Date/time the alarm was generated

Long AlarmState()

Alarm state

Long AckState()

Acknowledge state

String AlarmScreen()

(For point alarms only) Screen that is associated with the point on
the Point Properties dialog box View tab.

Long Severity()

Alarm severity
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Field

Description
String
AlarmMessage()

Alarm message

Long Duration()

Alarm duration

String
Alarm message translated into the language specified for screen
TranslatedAlarmMessage()
on which the alarm is selected. Important: The language and
translated string must be in the CIMPLICITY Language Mapper to
display correctly.
ClickSource

Source that was used to click on an alarm in the Alarm Viewer list. The source is identified
as follows.
Source

Identified by

Leftmouse
button

0

Rightmouse
button

1

Enter key

2

Note: The AlarmItemClick event will not be fired for the right-mouse button if the
Context (Popup) menu is enabled for the Alarm Viewer control.
The Popup menu can disabled by clearing either of the following check boxes.
Checkbox

Location

Right
click
menu

Privileges tab in the Role Properties dialog box.

Allow
runtime
popup
menu

Display tab in the CIMPLICITY AMV Control Properties dialog box.

Example: Configure an AlarmItemClick Event
1. Open the Properties - Object dialog box (Alt+Enter).
2. Select the Events tab.
3. Configure an AlarmItemClick event as follows.
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rect 76, 126, 124, 158 (page 138)
rect 72, 156, 117, 188 (page 138)
rect 63, 206, 120, 238 (page 138)
A

Event

Select ActiveX Event.
B

ActiveX Event

Select AlarmItemClick.
C

Action

Create a new script.
For this example a user will display a message box when an alarm is selected and either of the
following occurs.
• Right mouse button is clicked.
Note: The Allow runtime popup menu (page 48) checkbox on the CIMPLICITY AMV
Control Properties dialog box Display tab is clear (page 137) .
• Enter is pressed on the keyboard.
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The script is as follows.
Private cimOleObj As AMVOCXLib.IAmvOcx
Sub OnAlarmItemClick(AlarmInfo As AMVOCXLib.AmvOcxAlarmItemInfo,
ClickSource As Long)
Dim sourceStr As String
Select Case ClickSource
Case AMV_LeftMouseButton
sourceStr = "AMV_LeftMouseButton"
Case AMV_RightMouseButton
sourceStr = "AMV_RightMouseButton"
Case AMV_EnterKey
sourceStr = "AMV_EnterKey"
End Select
If ClickSource=AMV_EnterKey Or ClickSource=AMV_RightMouseButton Then
Dim DataString As String
DateString = Format(AlarmInfo.GenerationTime, "mmm dd hh:nn:ss AM/
PM")
MsgBox "AlarmIdentifier = " & AlarmInfo.AlarmIdentifier & ebCRLF & _
"ResourceIdentifier = " & AlarmInfo.ResourceIdentifier &
ebCRLF & _
"ReferenceIdentifier = " & AlarmInfo.ReferenceIdentifier &
ebCRLF & _
"AlarmGenTime = " & DateString & ebCRLF & _
"AlarmScreen = " & AlarmInfo.AlarmScreen & ebCRLF & _
"AlarmMessage = " & AlarmInfo.AlarmMessage & ebCRLF & _
"TranslatedAlarmMessage = " & AlarmInfo.TranslatedAlarmMessage
& ebCRLF & _
"Click Source = " & sourceStr
End If
End Sub

4. Click OK.
5. Test the Properties script.
When a user selects an alarm and either right-clicks or presses Enter on the keyboard, a Message box
displays. Values for the properties specified in the script are listed.
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A

AMV_RightMouseButton is the Click Source when the alarm is right-clicked.

B

AMV_EnterKey is the Click Source when the Enter key is pressed.

Alarm Viewer Methods for the AMV Control
Alarm Viewer Methods for the AMV Control
The Alarm Viewer methods operate on Alarm Viewer OCX controls in a CimView screen. They
give you access to the button functions used by the control so that you can invoke the button
functions from other objects on your CimView screen.
Steps to implement an AMV Control method include:
Step 1
(page
140)

Name the Alarm Viewer OCX control you want to use for the method.

Step 2
(page
141)

Create an Invoke Method action for the screen object and select the Alarm Viewer method you want to invoke.

When a user clicks on the object at runtime, the button function executes.

Step 1. Name an AMV Control
1. Select the AMV Control.
2. Click Edit on the menu bar,
3. Do one of the following.
• Select Properties
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• Press Alt+Enter.
The Object Properties dialog box opens.
4. Select the General tab.
5. Enter a name for the AMV Control in the Object name field.

6. Do one of the following.
• Click OK to save your changes and close the Object Properties dialog box.
• Click Apply to apply the name and continue configuration.
You can now select the control when you create an Invoke Method action.

Step 2. Create an Invoke Method Action
You can create an Invoke Method action for any object or group for which you can define procedures
in your CimEdit screen. The methods that are available depend on the selected object or group.
1. Select the Procedure tab in the Properties dialog box.
Note: You can also create a new procedure through the Events tab.
2. Click New.
The Procedure Information dialog box opens.
3. Click New.
4. Create an Invoke method action as follows.
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A

Action type

Invoke method

B

Object
name

Select the Alarm Viewer control object. Names of objects that have available methods are
listed.

C

Method

Select a method. Alarm Viewer Control methods are listed when the Alarm Viewer control is
selected.

D

Confirmed

Currently not implemented for the Alarm Viewer control.

E

Advanced

When enabled:
a. Click Advanced…
An Edit Method dialog box opens.
a. Configure advanced specifications for the method.
b. Click OK.
The Edit Method dialog box closes.

5. Click Advanced…
An Edit Method dialog box opens.
6. Configure advanced specifications for the method.
7. Click OK.
The Edit Method dialog box closes.
8. (For all methods) Click either:
• New to add another method or
• OK to close the Procedure Information dialog box.
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Alarm Viewer Methods
Alarm Viewer Methods
• AboutBox
• DoToggle
• AddProject
• DoViewStack
• DoAckAll
• GetProjectSetup
• DoAckFirst
• MoveDownOneAlarm
• DoAcknowledge
• MoveUpOneAlarm
• DoAckReset
• PageDownalarms
• DoCimviewScreen
• PageUpAlarms
• DoComments
• RemoveProject
• DoCustom<n>
• SelectAllAlarms
• DoDelete
• SelectFirstAlarm
• DoHelp
• SelectPageAlarms
• DoRefresh
• SelectTopAlarm
• DoReset
• SupressConnectionWarning
• SetProjectSetup
• DoSetup
• Methods reserved for GE Intelligent Platforms use.

AboutBox Method
Purpose:

Display the Help About dialog box for the CIMPLICITY AMV Control. There is no equivalent to this
method in the AMV Control.

Advanced
parameters

Not required.

AddProject Method
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Purpose

Add a project to the AMV Control.

Advanced parameters

Described next.

Advanced parameters for AddProject
1. Click Advanced… to open the Edit Method dialog box.
2. Enter a project name.
3. Enter one of the following for the Setup value:
• An empty string (""), which will be the selected project's default setup, or
• A setup name.
Important: Enclose the string entries in quotes.

DoAckAll Method
Purpose

Acknowledge all alarms in the CIMPLICITY AMV Control's alarm list.

Equivalent to

Ack All button in the AMV Control.

Advanced Parameters

Not required.

DoAckFirst Method
Purpose

Acknowledge the first alarm in CIMPLICITY AMV Control's alarm list.

Equivalent to

Ack First button in the AMV control.

Advanced parameters

Not required.

DoAcknowledge Method
Purpose

Acknowledge the currently selected alarm(s) in the alarm list on the CIMPLICITY AMV Control .

Equivalent to

Ack button in the AMV Control .

Advanced parameters

Not required.

DoAckReset Method
Purpose

Acknowledge and reset the currently selected alarm(s) in the alarm list on the CIMPLICITY AMV
Control

Equivalent to

Ack and Reset button in the AMV Control.
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Advanced
parameters

Not required.

DoCimviewScreen Method
DoCimviewScreen Method
Purpose

Display the CimView screen configured for the currently selected alarm in the alarm list on the
CIMPLICITY AMV Control .

Equivalent
to

CimView Screen button in the AMV Control. Important: At runtime, the user must select only one alarm
for this method to work. If the user selects more than one alarm, the method will not execute.

Advanced
parameters

Not required.

Note: The CimView screen that you assign to a point on the View tab in the Point Properties
dialog box is the screen that displays when a user selects the alarm in the AMV Control and the
DoCimviewScreen method is invoked.

DoCimviewScreen and Viewers
1. Display the C:\Program Files\Proficy\Proficy CIMPLICITY\Data directory in Windows
Explorer or at a Command prompt on the Viewer.
2. Open the log_names.cfg file in a text editor.
The control looks for the path to the screen in this file. By default, it assumes that the Alarm
Viewer OCX is running on the server.
3. Find the following lines.
* GSM Logical names * GMMI_SCREENS|S|default|30|SITE_ROOT:\screens GMMI_SCREENS|P|default|30|
SITE_ROOT:\screens

4. Change SITE_ROOT to the actual path that leads to the Screens folder.
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Example * GSM Logical names * GMMI_SCREENS|S|default|30|M:\PROJECTName:\screens GMMI_SCREENS|P|
default|30|M:\PROJECTName:\screens

Where
M:

is a mapped drive from the server

\PROJECTName

is the name of the project that has the assigned screens.

DoComments Method
Purpose

Open the Alarm Comments dialog box for the currently selected alarm in the CIMPLICITY AMV Control's
alarm list so that users can view, add, or delete comments for the alarm.

Equivalent
to

Comments button in the AMV Control. At runtime, the user must select only one alarm for this method to
work. If the user selects more than one alarm, the method will not execute.

Advanced
parameters

Not required.

DoCustom<n> Method
Purpose

Launch user-defined applications from the CIMPLICITY AMV Control .

Equivalent to

Custom1 through Custom8 buttons in the AMV Control .

Advanced parameters

Not required.

DoDelete Method
Purpose

(If users have the Alarm delete privilege) delete the currently selected alarm(s) in the alarm list on
the CIMPLICITY AMV Control.

Equivalent to

Delete button in the AMV Control .

Advanced
parameters

Not required.

DoHelp Method
Purpose

Open the Alarm Operator Help dialog box for the currently selected alarm in the CIMPLICITY AMV
Control's alarm list.

Equivalent
to

Help button in the AMV Control. At runtime, the user must select only one alarm for this method to work.
If the user selects more than one alarm, the method will not execute.

Advanced
parameters

Not required.

DoRefresh Method

Runtime | 4 - Alarm Viewers | 147

Purpose

Refresh Static Alarm list in the CIMPLICITY AMV Control with the latest alarms.

Equivalent to

Refresh button in the AMV Control.

Advanced parameters

Not required.

DoReset Method
Purpose

Let a user reset the currently selected alarm(s) in the CIMPLICITY AMV Control's alarm list.

Equivalent to

Reset button in the AMV Control. A reset alarm will not be generated again until it returns to its
normal state then goes back to an alarm state.

Advanced
parameters

Not required.

DoSetup Method
Purpose

Open the Alarm Setups dialog box so that users can select the filtering they want when viewing
alarms in the CIMPLICITY AMV Control.

Equivalent to

Setup button in the AMV Control.

Advanced
parameters

Not required.

DoToggle Method
Purpose

Toggle the CIMPLICITY AMV Control between the Static Alarm list and the Dynamic Alarm list.

Equivalent to

Toggle button in the AMV Control.

Advanced parameters

Not required.

DoViewStack Method
Purpose

Open the Stacked Alarms dialog for the selected alarm in the CIMPLICITY AMV Control.

Equivalent
to

View Stack button in the AMV Control. At runtime, the user must select only one alarm for this method to
work. If the user selects more than one alarm, the method will not execute.

Advanced
parameters

Not required.

GetProjectSetup Method
Purpose

Return a string that contains the current setup name.

Advanced parameters

Described next.
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Advanced parameters for GetProjectSetup:
1. Click Advanced to open the Edit Method dialog box.
2. (Optional) Enter one of the following for the Project value.:
• An empty string ("").
The AMV Control attaches a project to the string, in the following order of priority.
a. A default project.
If you run CimView in the context of a project, it creates a default project.
a. The connected project.
a. The first project in a list of projects to which the user is connected.
The list of projects displays in the Alarm Viewer Project Name field. To display this field
check Project Name on the Fields tab in the CIMPLICITY AMV Control Properties dialog
box.
• A project name.
3. Click OK.
Important: Enclose the string entries in quotes.

MoveDownOneAlarm Method
Purpose

Highlight the next alarm in the CIMPLICITY AMV Control's alarm list. If the current alarm is the last alarm
on the screen but not the last in the list, this method moves the list up to highlight the next alarm.

Equivalent
to

Down arrow on a user's keyboard.

Advanced
parameters

Not required.

MoveUpOneAlarm Method
Purpose

Highlight the previous alarm in the CIMPLICITY AMV Control's alarm list. If the current alarm is the first
alarm on the screen but not the first alarm in the list, this method moves the list down to highlight the
previous alarm.

Equivalent
to

Up arrow on a user's keyboard.

Advanced
parameters

Not required.
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PageDownAlarms Method
Purpose

(If there is more than one screen of alarms in the AMV Control's alarm list) display the next
screen of alarms.

Equivalent to

Page Down button on the user's keyboard.

Advanced
parameters

Not required.

PageUpAlarms Method
Purpose

(If there is more than one screen of alarms in the CIMPLICITY AMV Control's alarm list) displays the
previous page of alarms.

Equivalent to

Page Up key on the user's keyboard.

Advanced
parameters

Not required.

RemoveProject Method
Purpose

Remove a project from the AMV Control.

Advanced parameters

Described next.

Advanced parameters for RemoveProject:
1. Click Advanced… to open the Edit Method dialog box.
2. Enter one of the following for the Project value.
An empty string ("").
• The AMV Control attaches a project to the string, in the following order of priority.
a. A default project.
If you run CimView in the context of a project, it creates a default project.
a. The connected project.
b. The first project in a list of projects to which the user is connected.
The list of projects displays in the Alarm Viewer Project Name field. To display this field
check Project Name on the Fields tab in the CIMPLICITY AMV Control Properties dialog
box.
• A project name.
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Important: Enclose the string entries in quotes.

SelectAllAlarms Method
Purpose

Select all alarms in the CIMPLICITY AMV Control's alarm list.

Advanced parameters

Not required.

SelectFirstAlarm
Purpose

Selects the first alarm in the list and displays it.

Advanced parameters

Not required.

SelectPageAlarms Method
Purpose

Select all alarms displayed on the current screen in the CIMPLICITY AMV Control .

Advanced parameters

Not required.

SelectTopAlarm Method
Purpose

Select the first alarm from the current page displayed in the CIMPLICITY AMV Control and de-select
all other selected alarms.

Advanced
parameters

Not required.

SetProjectSetup Method
Purpose

Allow a user to select a specified alarm setup that is currently supported by a project.

Advanced parameters

Described next.

Advanced parameters for SetProjectSetup:
1. Click Advanced… to open the Edit Method dialog box.
2. Enter one of the following for the Setup value.
• An empty string ("") that results in an unfiltered alarm list, or
• A setup name.
3. (Optional) Enter one of the following for the Project value.
• An empty string (""), which will
• Attach to a current project running inside a project or

Runtime | 4 - Alarm Viewers | 151

• Use the first project to which the user is connected.
• A project name.
4. (Optional) Enter a text point ID in the Method result field.
Important: Enclose the string entries in quotes.

SuppressConnectionWarning Method ame
Purpose

Allows you to suppress warning dialog pop up that appears when an alarm viewer is disconnected from the
project.

Example
Private cimOleObj As AMVOCXLib.IAmvOcx
Sub OnScreenOpen()
cimOleObj.SuppressConnectionWarning = True
End Sub

Note: This script should be available in Alarm Viewer Object to work as expected.

Methods Reserved for GE Use
The following method is reserved for GE use:
NotifyAllPropertySinks

Chapter 5. Alarm Sound Manager
About the Alarm Sound Manager
The Alarm Sound Manager is a stand-alone utility that plays sound and displays alarm information
for selected running CIMPLICITY projects that are broadcasting on your local network. The Alarm
Sound Manager plays sound for one alarm at a time, the alarm that has the highest priority based on
your configuration (in both the Alarm Class Configuration dialog box and the CIMPLICITY® Alarm
Sound Manager dialog box).
The CIMPLICITY® Alarm Sound Manager can be opened (page 154) through the Windows Start
menu and through the CIMPLICITY Workbench. Once opened, an icon is placed on the Windows
Task bar. The icon can be used to display or minimize the dialog box.
The following are important requirements for operating systems in general and for Windows Server
2008 R2, specifically.
(All Operating Systems) Sound Configuration Required
You configure the sound (. wav file or beeps) for projects in each class' Alarm Classes
Configuration dialog box.
The Alarm Sound Manager only deals with classes for which sound is configured.
As a result, the Alarm Sound Manager does not report alarms associated with classes for which no
sound is configured.
You can create sound either:
• From a wave file if your system supports .wav files.
• With the beep, if your system has a speaker.
(Windows Server 2008 R2) Configuration Requirements
Windows Server 2008 R2 disables sound features in the default installation. The following sound
features must be enabled in order to enable the Alarm Sound Manager to play sound.
1. Install the Desktop Experience server feature.
2. Configure the Windows Audio service to start automatically.
3. Configure the Beep service to start automatically, as follows.
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sc config beep start= auto

4. Enable the SystemSoundsService task to run on user logon, as follows.
5. Open the Task Scheduler.
6. Select the Task Library.
7. Navigate to Microsoft/Windows/Multimedia.
8. Right-click the SystemSoundsService task and click Enable.
9. Restart the server.
The Alarm Sound Manager will be able to play sound for a running project after the server is
rebooted and the sound is configured.

Alarm Sound Manager Configuration
Steps to configure alarm audio support include:
Step 1
(page
153)

Configure sound for relevant alarm classes.

Step 2
(page
154)

Open the CIMPLICITY® Alarm Sound Manager dialog box.

Step 3
(page
155)

Add projects to a sound manager profile.

Step 4
(page
159)

Configure runtime sound options.

Step 5
(page
163)

Auto-start the Alarm Sound Manager.

Step 1. Configure Sound for Relevant Alarm Classes
You select .wav files or configure beeps for an alarm class on the Audio tab in the Alarm Class
Configuration dialog box.
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Step 2. Open the Alarm Sound Manager Dialog Box
1. Make sure that the projects that will be added to the Alarm Sound Manager are running.
2. Select Project>Runtime>Alarm Sound Manager in the Workbench left pane.
3. Select Alarm Sound Manager in the Workbench right pane.
4. Do any of the following:

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench, double-click Alarm Sound Manager, or press Alt+Enter on the keyboard.

D

In the Workbench, double-click Alarm Sound Manager, or press Alt+Enter on the keyboard.
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E

Press Alt+Enter on the keyboard.

F

Click an Alarm Sound Manager icon on the Windows Task bar. One of the following icons displays on the
Windows Task bar if the Alarm Sound Manager is running. The Alarm Sound Manager sound is:

the CIMPLICITY® Alarm Sound Manager dialog box opens when you use either method.

Step 3. Add/Modify Projects in the Alarm Sound Manager
Step 3. Add/Modify Projects in the Alarm Sound Manager
Step 3.1
(page
155)

Configure projects to add to the list.

Step 3.2
(page
158)

Save an alarm sound profile.

Step 3.1. Configure Projects to add to the List
Note: The Add Project dialog box opens when you modify an existing project's specifications.
However, the Project field is disabled.
1. Select the Projects tab in the CIMPLICITY® Alarm Sound Manager dialog box..
2. Click Add.
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The Add Project dialog box opens.
3. Fill in the fields as follows.

rect 8, 24, 245, 55 (page 156)
rect 7, 54, 134, 85 (page 156)
rect 7, 91, 244, 122 (page 156)
A
(page
156)

Project

B
(page
156)

Priority

C
(page
156)

Setup

A

Project

Select a project from the drop down menu.
Projects that are running and available (e.g. broadcast) are listed.
B

Priority

A number equal to or greater than 0 in the Priority field to specify the project's priority static to
other projects.
0 is the highest priority.
The higher the number you enter, the lower the priority.
The list of projects on the Projects tab is sorted in the order of priority that you specify. The
Alarm Sound Managers uses this project ordering to help determine which sound plays first at
runtime.
C

Setup

An alarm setup that will filter alarms that trigger a sound.
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Either:
• Type a setup in the Setup field.
• Click the Browse button to the right of the Setup field.
An Alarm Setups dialog box opens.

(page 105)
Setups listed in the Alarm Setups dialog box were created in any of the following.
• Stand-alone Alarm Viewer
• Alarm Viewer OCX
• Alarm Sound Manager
Note:
• You can create a new or modify an existing setup (page 105) to enter in the Setup field.
• If you do not select a setup, CIMPLICITY uses the <<Unfiltered>> setup, which will
trigger sound for any alarm in the project.
4. Click OK.
If you are not logged into CIMPLICITY, a CIMPLICITY® Login dialog box opens.
Enter your User ID and Password.

Once you are logged in, the project displays in the list of projects on the Projects tab in the
CIMPLICITY® Alarm Sound Manager dialog box. If an alarm is generating a sound, a message
provides the alarm's:
• Project
• Class
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• Generation date/time
• Message

5. Repeat adding projects until all of the projects that should have sound for alarms appear in the
Projects list.
Note: Select a project in the list and click Delete if you want to remove it from the Alarm
Sound Manager.

Step 3.2. Save an Alarm Sound Profile
1. Click Save profile… on the Projects tab

An Open dialog box opens.
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2. Open the folder in which you want to save the profile.
3. Enter a file name.
The file is an .ini file.
4. Click OK.
The Alarm Sound Manager saves the configuration that display on all of the tabs in the
CIMPLICITY® Alarm Sound Manager dialog box in an .ini file.
You can continue to save the profile if you change the configuration on any other tabs.
The profile is available whenever it is required.
Tip: Click Load profile… on any tab in the CIMPLICITY® Sound Manager dialog box to load
any of the profiles you saved.

Step 4. Configure Runtime Sound Options
Step 4. Configure Runtime Sound Options
Select the Options tab in the CIMPLICITY® Alarm Sound Manager dialog box.
Options are as follows.
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Sound/beep priority

2
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Project default priority

3
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161)

Stop sound/beep on

4
(page
162)

Repeat sound/beep on

5
(page
162)

Clear mute on new alarm/Mute

6
(page
162)

Save profile

1

Sound/beep priority

Select which priority the Alarm Sound Manager should check first when concurrent alarms are
received as follows.
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Check

Alarm Sound Manager Checks static Priority of each alarm's:

Alarm
Class

Class, as specified in the Alarm Class Configuration dialog box. Determination of the highest priority alarm is:
1. The sound for the first alarm with the highest priority alarm class is played first.
2. If alarms exist for the same alarm class in more than one project, then the highest priority alarm for the
highest priority project is played first.
3. If alarms exist for the same alarm class in the same project, the alarm that is triggered first is played first.

Project

Project as specified in the Add Project dialog box that is opened through the Projects tab in the CIMPLICITY®
Alarm Sound Manager dialog box. Determination of the highest priority alarm is:
1. The sound for the alarm with highest priority Alarm Class in the highest priority project is played first.
2. If more than one project has the highest priority, then the order in which the projects display in the Alarm
Sound Manager dialog box determines the project priority.

Tip: The following keys select the alarm class or project.
Key

Selects

Alt+R

Alarm Class

Alt+P

Project

2

Project default priority

Specifies the default priority that the Alarm Sound Manager will assign to each project that is added
to a current session.
Enter 0 or higher.
0 is the highest priority. The higher the number, the lower the priority.
The number you enter displays in the Priority (page 155) field when you open a new Add Project
dialog box.
3

Stop sound/beep on

Specify the condition under which the sound/beep for an alarm is stopped as follows.
Check

Alarm sound/beep stops when the alarm is:

Acknowledge only

Acknowledged

Reset only

Reset.

Both Ack and Reset

Acknowledged and reset.

Either Ack or Reset

Acknowledged or reset.

When the Alarm Manager stops the sound for one alarm, it provides sound for the next highest
priority alarm.
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4

Repeat sound/beep

Select whether or not to have the Alarm Sound Manager repeat the sound for an alarm until it meets
the stop sound/beep on conditions, as follows.
Repeat
sound/
beep

Description

Check

The Alarm Sound Manager repeats the sound. The .wav sound or group of beeps (as specified in the Alarm
Class Configuration dialog box) repeats every 10 seconds for the alarm until the stop sound/beep condition
is satisfied. When the stop condition is satisfied the Alarm Manager repeats the sound for the alarm that
assumes the highest priority status.

Clear

The Alarm Sound Manager provides a .wav sound or group of beeps once and then moves to the next alarm.
The Alarm Sound Manager rotates through the alarms, playing the sound for each during its turn in the
rotation. When the stop condition is met for an alarm, the Alarm Sound Manager removes that alarm from the
rotation. Tip: Press Alt+U to check/clear Repeat sound/beep.

5

Clear mute on new alarm

Play or mute the sound as follows:
Check

To

Mute

Mute all alarms. Note: The message still displays.

Mute and Clear
mute on new alarm

Mute existing alarms, but enable the sound when there is a new alarm. The Alarm Sound
Manager clears the Mute check box.

Neither (clear both)

Enable sound for all alarms. The sound is repeated for the highest priority alarm or rotated among
alarms depending on whether or not Repeat sound/beep is checked.

6

Save profile

Click Save profile (page 158) to save your selections in the open profile.

Example: Prioritize Alarm Sounds
You have three projects, each with two Alarm Classes as follows:
Project
Priority

Project

Alarm
Class 1

Class 1
Priority

Alarm
Class 2

Class 2
Priority

PROJ_A

3

ALM_A

1

ALM_B

2

PROJ_B

2

ALM_A

1

ALM_B

2

PROJ_C

1

ALM_A

1

ALM_B

2

In addition, you currently have one alarm generated for each class in each project.
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If you prioritize audio alarms by:
Alarm Class, the alarm order is:
Alarm Sound

Alarm

Order

Project

Class

1

PROJ_C

ALM_A

2

PROJ_B

ALM_A

3

PROJ_A

ALM_A

4

PROJ_C

ALM_B

5

PROJ_B

ALM_B

6

PROJ_A

ALM_B

Project, the alarm order is:
Alarm Sound

Alarm

Order

Project

Class

1

PROJ_C

ALM_A

2

PROJ_C

ALM_B

3

PROJ_B

ALM_A

4

PROJ_B

ALM_B

5

PROJ_A

ALM_A

6

PROJ_A

ALMB

Step 5. Auto-start the Alarm Sound Manager
Select the Startup tab in the CIMPLICITY® Alarm Sound Manager dialog box.
Options are as follows.
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1
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Start at Windows startup

2
(page
164)

Use profile

3
(page
164)

Mute

1

Start at Windows startup

Check Start at Windows Startup to start an Alarm Sound Manager profile when Windows starts up.
2

Use profile

Specify the Alarm Sound Manager profile that will be used as follows.
1. Click the Open dialog box button at the right of the Use profile field.
The Open dialog box opens.
1. Find and select the profile (.ini file).
2. Click OK.
3

Mute
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Check or clear to specify the following.
Check

The Alarm Sound Manager will:
• Be mute when Windows opens
• Start and load the selected profile when Windows reboots.

Clear

The Alarm Sound Manager will:
• Provide the selected sounds as soon as one of the listed projects is running as soon as Windows reboots.
Note: If the projects are running on the same server as the Alarm Sound Manager, select them to start
when Windows reboots in the CIMPLICITY Options dialog box.
• Start and load the selected profile when Windows reboots.

4

Save profile

Click Save profile (page 158) to save your selections in the open profile.
Results
One of the Alarm Sound Manager icons (page 155) displays in the Windows Task bar when
Windows starts.

When the Alarm Sound Manager is opened the following displays.

1

Projects in the selected profile that are running display as connected (green).

2

Projects in the selected profile that are not running display as not connected (red).

3

The Alarm Sound Manager will be mute or will provide sound, as specified.

Chapter 6. DGR
About Dynamic Graphic Replay
Dynamic Graphical Replay (DGR) is a powerful tool to help you, a system administrator,
troubleshoot problems that have occurred in your processes.

• Configuration for DGR use.
• DGR operation.

Overview
DGR enables you to review and diagnose what conditions may have led to an event of interest.
Because the DGR automates reviewing either Database Logger or Proficy Historian logged data you
can quickly and precisely pinpoint when and by how much one or more points deviated from the
norm.
Using the DGR, you can:
• View logged point data history using a project:
• CimView screen.
• Trend chart.
• Point Control Panel.
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Note: Replay speed can be up to a maximum of 100 times faster than real-time and a down to a
minimum speed of 1/10 real-time.
• Search logged data to locate when a point value meets a specified condition.
• A Start Search functionality sets the playback start time to the time of a corresponding
specified condition.
• A Stop Search functionality pauses playback each time a specified condition is met.
• Run independent DGR sessions on one or more terminal sessions, serving requests for play
backs
• DGR plays back values as follows.
DGR mode

For

DGR Plays Back

Live

Points

Real time values.

Point or class attributes

Real time values.

Historical Replay

Points

Logged

Logged values.

Points

Not logged

Not available

Point or class attributes

Logged to SQL Server

Logged values.

POINT_ID and TIMESTAMP

Logged to Historian

Logged values

Point attributes or class attributes

Not logged

Current values.

Note:
• Point ID and TIMESTAMP are the only attributes that are logged to Historian.
• The DGR is local to the Viewer or Server on which it is running. When you switch to DGR
mode all of the local CimView point data switches to DGR mode. As a result, your system can
continue displaying live data on one viewer while it displays DGR time on another.
Example

• When running DGR with SQL Server, current Point attribute and class attribute values can be
viewed. However, they are read-only.
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Important: DGR does not run in Demo mode.

Configuration for DGR Use
Configuration for DGR Use
Do the following before you open the DGR.
Step 1
(page
168)

Select the playback source.

Step 2
(page
169)

Check Log Data in the Point Properties dialog box.

Step 3
(page
170)

(Configure and) Run a runtime application to display point values.

Important: DGR is supported for projects logging to SQL Server or Proficy Historian.

Step 1. Select the Playback Source
1. Open the Project Properties dialog box.
2. Check one of the following.
• Pull historic Data from SQL Server.

A

Check Database Logger - Points
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B

Clear Historian OPC Interface

• Pull historic data from Historian.

A

Clear Database Logger - Points.

B

Check Historian OPC Interface.

3. Configure your selection to receive logged data.
DGR will play back data from the selected source.

Step 2. Check Log Data in the Point Properties dialog box.
1. Select each point for which logged data should be available for diagnosis.
2. Open the point's Point Properties dialog box.
3. Select the General tab.
4. Check Log data.
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Step 3. Run a Runtime Application to Display Point Values
When you are working with the DGR, point values that display in either live or DGR mode display
on runtime applications.
• Example: CimView
• Example: Trend chart

Example: CimView
During live runtime, a CimView screen displays logged and non-logged values, as follows.

Value Type

Logged

Display

A

Point

Yes

Yes

B

Point

No

Yes

C

Point attribute

Yes

Yes
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D

Value Type

Logged

Display

Point attribute

No

Yes

Example: Trend Chart
During live runtime, a Trend chart displays logged and non-logged values as follows.

Value Type

Logged

A

Point

No

B

Points

Yes

C

Legend

No and Yes

DGR Operation
DGR Operation
Operating the DGR is straightforward.
Note: Make sure the DGR project is running.
Step 1
(page
172)

Open the DGR.

Step 2
(page
173)

Start Historical Replay mode.
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Step 3
(page
176)

Set the start date and time.

Step 4
(page
177)

Select playback speed.

Step 5
(page
179)

View playback.

Step 6
(page
193)

Exit the DGR.

When you are in DGR mode you can view the date and time that data was logged in the DGR Date
Time box.
At any time you can switch back to Live mode.

Step 1. Open the DGR
1. Make sure the project is running.
2. Select Computer>DGR in the Workbench left pane.
3. Select DGR in the right pane.
4. Do one of the following.

A

Click Edit>Properties on the Workbench menu bar.
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B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
Either
Double click DGR.

D

a. Right-click DGR.
b. Select Properties on the Popup menu.

In the Workbench right pane:
Either
Double click DGR.

E

Or

Or
a. Right-click DGR.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

5. Right-click DGR.
6. Select Properties on the Popup menu.
7. Right-click DGR.
8. Select Properties on the Popup menu.

Step 2. Start Historical Replay Mode
• Historical Replay Mode startup.
• Start Historical Replay Mode examples.

Historical Replay Mode Startup
Check Historical Replay on the CIMPLICITY DGR.
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Result: The DGR does the following.
A

Switches to DGR mode.

B

Adds points.

C

Displays the status as Stopped.

D

Enables the Play buttons.

E

Turns off point displays in runtime user applications.

Start Historical Replay Mode Examples
• CimView.
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• Trend chart.
CimView
The values in CimView revert to the default text that was entered when:
• CimEdit was being configured.
• Attribute values were entered in the Point Properties dialog box, e.g. Alarm High and Alarm
Low values.

Trend Chart
The Trend is stopped. Lines that were drawn during live runtime remain until Historical playback
begins.

Important: DGR mode only affects user applications, e.g. CimView, Point Control Panel.
CIMPLICITY resident processes, e.g. PTDL , EMRP , are not affected.
The Alarm Viewer continues to display live data.
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Step 3. Set the Start and Stop Date and Time
The following data and time fields on the CIMPLICITY DGR selects the playback start and end
date and time.

Feature
A

Start date

Description
Month/day/year to start the DGR replay.
Note: Click the Down arrow to the right of the Start Date field to select a date from a
calendar.

B

Start time

Hour:Minute:Second to start DGR replay.

C

Set Start Date and
Time

Click to set the start date and time.
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Feature
D

End date

Description
Month/day/year to end the DGR replay.
Note: Click the Down arrow to the right of the Start Date field to select a date from a
calendar.

E

End time

Hour:Minute:Second to end DGR replay.

F

Set End Date and
Time

Click to set the end date and time.

Result: The DGR loads the values of the points at that time. Clicking the Play button starts playing
back updates.

Step 4. Select Playback Speed
The Playback speed box on the left of the CIMPLICITY DGR enables you to specify the speed that
the data should be played back.
Slide the slider to the speed that you want the data to play back.
The speed changes as the slider is moved.
• Speed range
• Procedure to select the exact playback speed
Speed Range
The range of speed choices is as follows.
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A

Lowest

0.002X of normal speed

B

Normal

1.000X

C

Highest

100.000X the normal speed

Note: The actual speed, which is also driven by your system hardware and setup, may vary
slightly from the indicated selection.
Procedure to Select the Exact Playback Speed
1. Click the Pause button.
Note: You can click the Stop button if you want the DGR to return to the playback start.
2. Move the slider to the speed or close to the speed you want.

3. (When the speed is close to what you want) press the arrow keys on the keyboard to select the
exact playback speed.
Right arrow key
Each time you press the right arrow key the speed increases 0.100x
Continue to press the right arrow key until the speed you want displays as the playback speed.
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Left arrow key
Each time you press the left arrow key the speed decreases 0.100X.
Continue to press the left arrow key until the speed you want displays as the playback speed.

Step 5. View Playback
Step 5. View Playback
The DGR provides several options for starting and stopping playback.
Options include the following.
Option
5.1 (page
180)

Manually control playback.

Option
5.2 (page
185)

Use jog interval.

Option
5.3 (page
187)

Enable start search.

Option
5.4 (page
190)

Enable stop search.

Note: In order for DGR playback to take advantage of microsecond logging, the following
logging application versions are required.
SQL Server

At least SQL Server 2008.

Historian

Historian v4.5 or higher.
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Option 5.1. Manually Control Playback
1. Enter a date and time in the Start date and Start time fields when the DGR is in DGR mode.
The DGR is ready for playback.
2. Use the playback buttons as follows.
Button

Action

Play

The DGR begins playback from the start date/time.

Pause

Playback pauses. When you click the Play button to resume, the DGR begins playing from
where it paused. It does not go back to the beginning.

Stop

The DGR stops and goes back to the start playback point.

(page
180)

(page
182)

(page
183)
Play

Click the Play button.
The CIMPLICITY DGR does the following.
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A

Reports that playback is in progress.

B

Disables the Start/End date and Start/End time fields. Note: Start and end dates and/or time cannot be changed
while the DGR is playing.

C

Displays the playback date and time in the DGR Date Time Display box. Note: Applications that display
timestamps, e.g. Trend, will play back millisecond or microsecond time.

D

Disables the Enable Start Search (page 187) and Enable Stop Search (page 190) checkboxes.

E

Disables the Jog Interval options.

Note: Note: Start and End date and time fields are disabled.
Example: CimView during DGR playback
During playback, CimView displays the logged and non-logged values as follows.

Either
Logged to

Logged to

Value Played Back

Value Type

SQL

Historian

SQL

Historian

A

Points

Yes

Yes

Logged

Logged

B

Points

No

No

None

None

C

Point or class attributes

Yes

NA

Logged

Current

D

Point or class attributes

No

NA*

Current

Current

*Point ID and TIMESTAMP are the only attributes that are logged to Historian.
Example: Trend Chart during DGR Playback
The Trend chart displays the values for the selected historical playback, as follows.
Note: Playback reflects the speed with which data was collected. DGR supports microseconds.
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A

No lines/values are available for non-logged point values.

B

Lines/values display for the logged points.
Pause

Click the Pause button.
the DGR dialog box does the following.

A

Reports that playback is paused.

B

Disables the Start/End date and Start/End time fields. Note: Start and end dates and/or time cannot be changed
while the DGR is paused.

C

Displays the paused date and time in the DGR Date Time Display box. Note: When playback is resumed, it
resumes from the paused date and time.

D

Enables the Enable Stop Search (page 190) checkbox.
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E

Enables the Jog Interval options.

Runtime applications pause playback and continue to display the values that were found when Pause
was clicked.
Example: CimView

A

Values that are found when DGR stops continue to display until DGR is re-started. When DGR restarts the start
values that display are based on either the same or new search criteria.

B

Disabled fields represent unavailable values.

Example: Trend
Note: The word Paused displays on the Trend chart when the DGR is paused.

Values that are found when DGR is paused continue to display until DGR is re-started.
When DGR restarts Trend continues the historical playback.
Stop
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Click the Stop button.
The DGR dialog box does the following.

A

Reports that playback is stopped.

B

Enables the Start/End date and Start/End time fields. Note: When playback is restarted, DGR does one of the
following.
• Rewinds to the original start time and starts playing again.
• Starts from a new date and time in the Start date and Start time fields.

C

Displays the paused date and time in the DGR Date Time Display box, if the DGR has been running. Note: When
DGR is restarted, it restarts from the stopped date and time.

D

Enables the Enable Start Search (page 187) and Enable Stop Search (page 190) checkboxes.

E

Enables the Jog Interval options.

Runtime applications stop playback and continue to display the values that were found when Stop
was clicked.
Example: CimView
At the time DGR is stopped and still in Historical mode, CimView displays values that were found.
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A

Values that are found when DGR stops continue to display until DGR is re-started. When DGR restarts the start
values that display are based on either the same or new search criteria.

B

Disabled fields represent unavailable values.

Example: Trend when DGR is Stopped
Note: When the DGR is stopped, the word Stopped displays on the Trend chart.

Values that are found when DGR is stopped continue to display until DGR is re-started.
When DGR restarts Trend continues the historical playback.

Option 5.2. Use Jog Interval
A Jog feature plays the indicated interval every time it is pressed. This allows a user to step through
the data time slice by time slice utilizing the visualization of CimView.
• Jog definition.
• Jog playing.
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• Single jog completed.

Jog Definition
Anytime that the DGR is in Stopped or

A

Status
Field/
Buttons

Report that playback is stopped.

B

DGR
Date
Time
Display

Displays the stopped date and time in the DGR Date Time Display box. Note: When playback is
resumed, it starts from the stopped date and time, if the times have not been changed in the Start/End
date and Start/End time fields.

C

Jog
Interval

Defines the jog interval length. The acceptable range is:

D

Jog
button

Minimum

0.001 second

Default

1.0 second

Starts the jog.

Jog Playing
When the Jog button is clicked CIMPLICITY DGR plays for the specified jog interval.
DGR displays, as follows.
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A

Status Field/Buttons

Report that playback is playing..

B

DGR Date Time Display

Displays the playback date and time in the DGR Date Time Display box.

C

Jog interval/button

Disabled.

Note:
• The jog can be stopped at any time. If it is stopped, the job interval can be changed. The new
interval will be used when the jog is restarted.
• While DGR is jogging, the timestamps for points that have been logged using milliseconds or
microseconds display that progress in any application, e.g. Trend, that displays timestamps.

Single Jog Completed
When the single jog is complete, the DGR resumes Paused mode.
• The Jog button can be clicked again to start the next jog.
• Any criteria can be changed before a new jog is initiated.

Option 5.3. Enable Start Search
The DGR can stop its search when a point value fulfills a specified criterion; it can then be paused
and restarted from that point to find the next instance for the same criterion or the first instance for a
new criterion.
Note: Playback can be manually paused or stopped using the Pause or Stop buttons.
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A
(page
188)

Enable Start Search criteria.

B
(page
188)

Review Start Search playback.

C
(page
189)

Pause of stop playback.

1. Enable Start Search criteria
Enter the following.

1

Check Enable Start Search. The Start Search fields are enabled. Entries are as follows.

2

Field

Description

Point

Point ID that DGR should look for.

Cond

Condition options are: > = < Example LEVELT201 is a point in the DGR project. LEVELT201>500 is
entered as the Enable Start Search condition.

Value

The value (in relation to the condition) that, when found, will start the DGR playback.

1. Review Start Search playback
The DGR does the following.
1. Searches for the first instance that fulfills the condition.
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Note: While the DGR is searching for the first instance, the playback status is STOPPED.
However, the DGR Date Time Display indicates the hour:minutes:seconds as the search
progresses.
2. When DGR finds the first instance that fulfills the condition, DGR does the following.

1

Changes the selected Start date and/or Start time to display the time that the playback actually starts.

2

Shows that it is playing.. Note: Playback values display in runtime applications, e.g. CimView.

3

Displays the date and time playback status. Note: The playback speed (page 177) can be changed
at any time.

4

Disables the Enable Start Search fields.

Example
The selected application to display values, e.g. CimView, displays logged values starting from
the date and time the DGR finds the value LEVELT201>500.
a. Pause or Stop Playback
DGR provides several methods to pause or stop playback; DGR does the following based on
what you do.
• Enter criteria in the Enable Stop Search fields before you start playback.
DGR pauses when the Stop Search criteria are met.
• Click Stop (page 183) .
• Do the following.
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1. Click Pause.
2. Enter criteria in the Enable Stop Search fields.
3. Click Start.
DGR starts from the paused date and time and stops when the stop search criteria are met.

Option 5.4. Enable Stop Search
The DGR can stop its search when a point value fulfills a specified criterion; it can then be paused
and restarted from that point to find the next instance for the same criterion or the first instance for a
new criterion.
A
(page
190)

Enable Stop Search criteria.

B
(page
191)

Review Stop Search playback.

C
(page
192)

Resume playback.

1. Enable Stop Search criteria
Enter the following.

1

Check Enable Stop Search. The Stop Search fields are enabled. Entries are as follows.
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2

Field

Description

Point

Point ID that DGR should look for.

Cond

Condition options are: > = < Example LEVELRT201 is a point in a DGR project. LEVELT201>500 is entered
as the Enable Stop Search condition.

Value

The value (in relation to the condition) that, when found, will start the DGR playback.

1. Review Stop Search playback
The DGR does the following.
Searches for the first instance that fulfills the condition.

1

Starts its search at the selected Start date and Start time.

2

While playing searches for the first instance of a value that fulfills the Stop Search criteria.

3

Displays the date and time playback status. Note: The playback speed (page 177) can be
changed at any time.

4

Disables the Enable Stop Search fields.

When DGR finds the first instance that fulfills the condition, DGR does the following.
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1

Pauses the play

2

Displays the data and time the pause occurred.

3

Enables the Enable Stop Search fields.

Pauses the value display in the runtime applications, e.g. CimView.
Example
The DGR pauses the runtime display when it finds the value LEVELT201>500.
1. Resume Playback
When the DGR stops the search, you can do any of the following.
• Click Start.
Result: DGR resumes playback to find the next instance that fulfills the current condition.
• Enter a new condition in the Enable Stop Search fields; click Start.
Result: DGR resumes playback from the stop search point to find the first instance of a new
condition.
• Clear the Enable Stop Search checkbox; click Start.
Result: DGR resumes normal playback from the paused point.
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• Click Stop.
Result: DGR rewinds to the Start data and Start time ready to resume the playback type from the
beginning.

Step 6. Exit the DGR
Do the following to resume normal operation.

A

Click the Stop button (when still in Historical Replay mode).

B

Check Live in the Mode box.

C

Click the Exit button on the top right of the DGR.

Result: The following happens.
• The DGR closes.
• Runtime applications display real time values.

Technical Notes about DGR Functionality
DGR Functionality Technical Notes
The following sections provide technical notes about DGR functionality.
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GefVCRService and the GefVCRControlApp.

• Context of DGR Mode.
• VCRServer.cfg file.
• Point attributes.

GefVCRService and the GefVCRControlApp
Dynamic Graphical Replay consists of the GefVCRService and the GefVCRControlApp .
It works by letting supported client applications connect to an alternate data source, the
GefVCRService.
The GefVCRControlApp controls point data source switching, playback of data, and searching.
Use the GefVCRControlApp to switch from the live Point Manager connection to the historical
GefVCRService connection. This puts the local node in DGR mode.
Once the switch to DGR mode is complete, the GefVCRControlApp provides the means to send
commands to the GefVCRService. Commands can include functions such as setting the start time
for replaying data; start, stop and pause of data replay; controlling the speed of the data replay and
searching for when a point value meets a specified condition.
When the GefVCRService receives the commands it queries the CIMPLICITY Database Logging
default point logging table (DATA_LOG) for the historical point values and notifies CimView of
changes in point values during replay.
When you finish replaying data, use the GefVCRControlApp to switch your local node back to
Live mode..

Context of DGR Mode
When you switch to DGR mode,
• All supported client applications on the local node switch to DGR mode.
• If you have more than one CimView screen open all of the screens will be switched.
• If you have other CIMPLICITY client applications running on the local node (e.g. Point Control
Panel, Quick Trends, etc.) those connections will also be switched to DGR mode.
There is no way to control which client applications should switch and which should not.
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• The switch over to DGR mode is local to the node. This means that several viewers can switch
in and out of DGR mode without affecting each other.
You can safely run CimView screens in DGR mode on a CIMPLICITY server because only client
applications are switched into DGR mode. Your project’s runtime processes such as the Event
Manager and Database Logging will remain connected to the live Point Manager.
• When DGR switches from Live mode to Historical Replay mode, it builds a list of the points
and point configurations used in each CimView screen. This point list is saved when you switch
from Historical Replay to Live mode, so they can be reused when you switch back from Live
mode to Historical Replay mode.
• There may be an issue with the Windows firewall where it prevents SQL from running DGR
on a Viewer. If the Viewer appears to hang, adding the sqlbrowser.exe file and path to the
Windows Firewall exception list may solve the issue.

Point and Class Attributes
Dynamic Graphical Replay provides limited support for point attributes (e.g. time stamp, resource,
etc.). The point attributes that are supported include only those accessible from the CIMPLICITY
Point Browser’s tree view.
Point attributes in DGR that are supported are supported in one of the following ways.
Historical
values (if
available)

Some point attributes can be logged to the DATA_LOG table as follows.

If Attributes are:

DGR Displays:

Configured for logging
to the SQL DATA_LOG
table,

The following attributes are logged to the SQL database.
•
•
•
•
•
•
•
•
•

Point Value
Prev. Value
Raw value
Alarm state
Resource
Time last Logged
Engineering Units
Quality
User flags

These attributes will be replayed from SQL database Attributes other
than these point attributes will be replayed from project configured data.
Not configured for logging

Current value.
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Currently
configured
value

• Some point attributes cannot be logged to the DATA_LOG table. Generally speaking, these
attributes are set at configuration time only and don’t change over time.
The currently configured value for these attributes will be displayed in DGR mode.
• The only attributes logged to Historian are POINT_ID and TIMESTAMP. DGR displays the
currently configured value for all other attributes associated with points that are logged to
Historian.

VCRServer.cfg File
For Projects logging to SQL only:
Before the GefVCRService can make queries for historical data it must know how to connect to the
actual data archive. Information needed to make the connection includes the name of the node where
the database server is running and which database on the server holds the DATA_LOG table.
In order to get this information, the service must be able to connect to and login to each
CIMPLICITY project of interest. You provide the CIMPLICITY login information to the service
with the VCR Server.cfg file, located in the data directory of your CIMPLICITY installation.
The format of this file is as follows.
<project name1>|<userid>|<password>
<project name2>|<userid>|<password>
.
.
.

DGR Limitations
1. Active-X controls, including CIMPLICITY Active-X controls (e.g. Alarm Viewer and SPC)
will not replay in DGR mode. Putting a screen with an Alarm Viewer control may cause the
Alarm Viewer to malfunction.
Note: The Trend Active-X control does work with DGR.
2. DGR cannot replay array points and may malfunction as a result of attempting to do so.
3. The DGR does not replay BYTE, WORD and DWORD points; however it does not generate
errors. (Historian).
4. The following attributes are not supported in DGR mode.
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• analog_deadband_n
• deviation_ptid
• setpt_check_ptid
• extended_user_flags_high
• extended_user_flags_log

