Proficy CIMPLICITY 11.1
Alarm and Messages

GE Digital

Proficy Historian and Operations Hub: Data Analysis in Context

1

Proprietary Notice
The information contained in this publication is believed to be accurate and reliable. However, General Electric Company assumes no
responsibilities for any errors, omissions or inaccuracies. Information contained in the publication is subject to change without notice.
No part of this publication may be reproduced in any form, or stored in a database or retrieval system, or transmitted or distributed in any
form by any means, electronic, mechanical photocopying, recording or otherwise, without the prior written permission of General Electric
Company. Information contained herein is subject to change without notice.
© 2021, General Electric Company. All rights reserved.
Trademark Notices
GE, the GE Monogram, and Predix are either registered trademarks or trademarks of General Electric Company.
Microsoft® is a registered trademark of Microsoft Corporation, in the United States and/or other countries.
All other trademarks are the property of their respective owners.

We want to hear from you. If you have any comments, questions, or suggestions about our documentation, send them to the following email
address:
doc@ge.com

Chapter 1. Alarm Configuration........................................................................................................7
About Alarms................................................................................................................................. 7
CIMPLICITY Event Alarms..........................................................................................................8
Event Alarm Configuration............................................................................................................9
Event Alarm Configuration....................................................................................................9
Step 1. Open an Alarm Definition Dialog Box................................................................... 10
Step 2. Configure an Event Alarm...................................................................................... 12
Step 3. Configure Alarm Routing........................................................................................14
Step 4. Configure Alarm Options........................................................................................15
Step 5. Set Global Alarm Settings.......................................................................................16
Chapter 2. Alarm Blocking Configuration......................................................................................19
About Alarm Blocking.................................................................................................................19
Alarm Blocking Configuration.................................................................................................... 21
Alarm Blocking Configuration............................................................................................ 21
1. Create a new Alarm Blocking Group..............................................................................21
2. Open an Existing Alarm Blocking Dialog Box...............................................................22
3. Configure an Alarm Blocking Group..............................................................................23
4. Add/Remove/Modify Alarms.......................................................................................... 24
Chapter 3. Alarm Classes Configuration........................................................................................ 27
About Alarm Classes................................................................................................................... 27
Alarm Class Configuration.......................................................................................................... 27
Alarm Class Configuration.................................................................................................. 27

Contents | iii

Step 1. Open the Alarm Class Configuration Dialog Box.................................................. 27
Step 2. Enter Alarm Class Specifications............................................................................30
Step 3. Select Sound for an Alarm Class............................................................................ 33

Alarm Class Color Assignments..................................................................................................37
Default Alarm Color Mappings........................................................................................... 38
Procedure to Map Alarm Class Colors in rgb.dat............................................................... 38
Chapter 4. Alarm Strings Configuration........................................................................................ 40
About Alarm Strings.................................................................................................................... 40
Alarm String Configuration......................................................................................................... 41
Alarm String Configuration................................................................................................. 41
Step 1. View Existing Alarm Strings.................................................................................. 41
Step 2. Open the Alarm String Index Dialog Box.............................................................. 42

Step 3. Configure an Alarm String Index Set..................................................................... 44
Chapter 5. Alarm Printer Configuration........................................................................................ 51
About Alarm Printer Configuration.............................................................................................51
Alarm Printer configuration......................................................................................................... 51
Alarm Printer Configuration................................................................................................ 51
Step 1. Open an Alarm Printer Dialog Box........................................................................ 52

Step 2. Configure General Alarm Printer Properties...........................................................54
Step 3. Configure Alarm Printer Layout Properties............................................................ 56

Contents | iv

Step 4. Configure Alarm Printer Date/Time Format........................................................... 57
Step 5. Continue for Serial, Redundant or Network Printers.............................................. 58

Alarm Printer Global Parameters.................................................................................................61
Chapter 6. CIMPLICITY Language Mapper.................................................................................62
About CIMPLICITY Language Mapping................................................................................... 62
CIMPLICITY Language Mapper Window Overview.................................................................62
Step 1. Review Alarm Messages that are Available for Translation...........................................63
Step 1. Review Alarm Messages and Strings that are Available for Translation................ 63
Step 1.1. Open the CIMPLICITY Language Mapper Window...........................................64
Step 1.2. Make New Point Alarm Messages Available for Translation.............................. 66
Step 1.3. Make a New Alarm String Available for Translation.......................................... 67
Step 2. Make CimEdit Text Available for Translation............................................................... 68
Step 2. Make CimEdit Text Available for Translation....................................................... 68
Step 2.1. Select Text Strings on CimEdit Screens.............................................................. 68
Step 2.2. Automatically Enter CimEdit Text Strings into a Map File.................................80
Step 3. Translate Keys into other Languages or other English Strings....................................... 86
Step 3. Translate Keys into other Languages or other English Strings............................... 86
Step 3.1. Open the CIMPLICITY Language Mapper Window...........................................86
Step 3.2. Select a Translation File.......................................................................................87
Step 3.3. Select a Font.........................................................................................................90
Step 3.4. Select Languages or other English Strings...........................................................91
Step 3.5. Translate Keys that should Display in Selected Languages................................. 93
Step 4. Work with Keys in a Translation File............................................................................ 95
Step 4. Work with Keys in a Translation File.....................................................................95
Option 4.1. Add a New Key Manually to a Translation File.............................................. 95
Option 4.2. Copy and Paste Keys in a Translation File...................................................... 96
Option 4.3. Delete a Key in a Translation File................................................................... 98
Step 5. Print a Translation File Configuration.......................................................................... 100

Contents | v

Step 5. Print a Translation File Configuration.................................................................. 100
Step 5.1. Preview the Printed File..................................................................................... 100
Step 5.2. Print the Translation File Configuration............................................................ 102
Step 6. Configure Translation Options for Runtime................................................................. 102
Step 6. Configure Translation Options for Runtime......................................................... 102
Step 6.1. Configure Translation Options for CimView Users...........................................102
Step 6.2. Configure an Alarm Viewer Control for Translation......................................... 106
Chapter 7. Historical Alarm Viewer Control............................................................................... 110
About the Historical Alarm Viewer Control............................................................................. 110
Historical Alarm Viewer Control Configuration....................................................................... 110
Historical Alarm Viewer Control Configuration............................................................... 110
Step 1. Place an Historical Alarm Viewer Control on a CimEdit Screen..........................111
Step 2. Open the CIMPLICITY Historical Alarm Viewer Properties Dialog Box............ 114
Step 3. Enter General Specifications for the HAV............................................................114
Step 4. Configure Connection Options for the CIMPLICITY Historical Alarm
Viewer.................................................................................................................................117
Step 5. Configure the SQL Display...................................................................................120
Step 6. Select Column Justification...................................................................................130
Step 7. Configure Row Styles........................................................................................... 131
Step 8. Specify Runtime Configuration Capability........................................................... 137
Technical Reference: Historical Alarm Viewer.........................................................................143
Technical Reference: Historical Alarm Viewer.................................................................143
1. Default Historian Tables and Field Options..................................................................143
2. <Local> or <Project Name> Tables and Field Options................................................ 154
Chapter 8. OPC Alarm and Event Server and Client................................................................. 159
About the OPC Alarm and Event Server and Client.................................................................159
Alarm Categories for an OPC Alarm and Event Server........................................................... 160
Configure the OPC Alarm and Event Server and Client...........................................................160
Configure the OPC Alarm and Event Server and Client...................................................160
Step 1. Configure the OPC Alarm and Event Server........................................................ 161
Step 2. Configure the OPC Alarm and Event Client.........................................................167

Contents | vi

Step 3. Use the OPC Alarm and Event Client and Server at Runtime.............................. 183
OPC Alarm and Event Server Technical Notes........................................................................ 187

Chapter 1. Alarm Configuration
About Alarms
CIMPLICITY software generates alarms for:
• Alarm messages about system events, such as device failures, program terminations, system
startups, and system shutdowns. You create and modify system event alarms in the Alarm
Definition dialog box through the Alarms folder.
• Points that are in an alarm state. You create point alarms in the Point Properties dialog box. You
can modify them in the Point Properties dialog box or through the Alarms folder.
Note: CIMPLICITY comes with several configured Event alarms.
CIMPLICITY alarm features in the Workbench left-pane include the following:

Other features of alarming include:
Feature

Description

Alarm classes (page 7)

Group alarms with similar characteristics.

Alarm strings (page 40)

Name alarm states.

Alarm printer (page 51)

Print alarms and/or events as they occur.

Alarm OPC client (page 159)

Send and receive data through an Alarm and Event OPC server.

Alarm blocking (page 19)

Configure a hierarchy of alarms to receive the most important alarms first.
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Feature
Alarm translator (page 62)

Description
Offer language and text string options for configuration.

CIMPLICITY Event Alarms
A set of CIMPLICITY event alarms is included in your base configuration. These alarms are not
associated with any single CIMPLICITY point ID during configuration. CIMPLICITY event alarms
may be modified, but they should never be deleted. They are:
CIMPLICITY Event Alarms

Function During Runtime

$ACAL_ADD_OV

Event added alarm generated by the Action Calendar.

$ACAL_CFG_ERROR

Configuration error alarm generated by the Action Calendar.

$ACAL_DAYTYPE_OV

Day type override alarm generated by the Action Calendar.

$ACAL_EVENT

Setpoint event occurred successfully generated by the Action
Calendar.

$ACAL_TIME_OV

Event time override alarm generated by the Action Calendar.

$ALARM_DISABLED

Alarm is disabled for the specified point.

$ALARM_ENABLED

Alarm is enabled for the specified point

$ALARM_MODIFIED

Alarm limits are modified for the specified point.

$ALARM_RAWLIM

Range limits exceeded for the specified point.

$ALARM_RESTORED

Alarm limits restored for the specified point.

$AM_STATUS

Alarm Management status message used to analyze system
performance. This message is issued every half-hour and shows the
number of alarms generated, the count of alarms acknowledged, reset
and deleted, and the average number of seconds required to log an
alarm.
Note: Alarms generated is also incremented when an alarm is
reset. In the case of reset, the message must be re-sent to clients to
change state. Alarms Deleted is only incremented when a manual
delete is performed.

$DEVICE

Indicates if the device is up (able to communicate) or down. When the
device is up Normal displays. When the device is down is in Alarm
State. Configure a separate resource for each device. This helps
separate the alarms, which would get stacked with the same resource.

$DEVICE_DOWN

Device failure message for specified device.

$DEVICE_FAILOVER

Reserved for future use.

$DL_FILE_FULL

Log file full message for specified log file.
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CIMPLICITY Event Alarms

Function During Runtime

$DOWNLOAD

Setpoint was downloaded to specified device.

$DYN_CFG

The specified entity has been changed dynamically.

$EM_OUTOF_MEMORY

An out of string space error has occurred.

$HIST_COLLECTOR

Indicates that the Historian Collector has stopped collecting data.

$HIST_SERVER

Indicates that CIMPLICITY cannot connect to the Historian server.

$LOGIN_FAILURE

Specified user failed to log in to the specified CIMPLICITY project.

$LOGON

Specified user has logged in to a specified CIMPLICITY project.

$LOGOUT

Specified user has logged out from a specified CIMPLICITY project.

$OPC_MODEL_EVENT

Generates alarms from OPC events.
Note: Alarms that are logged to the event log are treated as OPC
A&E events by the OPC server. OPC events received by the OPC
client are logged to the event log by default.

$REDUND_DEV_DOWN

Alarm message for PLC redundancy.

$RTR_LINK_DOWN

Router link has been lost to specified node.

AMSI_ALARM

AMSI_ALARM is generated when a XASMGR (External Alarm State
Manager) stops unexpectedly; the alarm is cleared when XASMGR
restarts.

DB_CONN_DOWN

Process has lost connection to specified logging database.

DB_START_FORWARD

Process is forwarding data to specified logging database.

MCP_PROC_DOWN

Specified CIMPLICITY process has terminated unexpectedly.

Event Alarm Configuration
Event Alarm Configuration
In most cases you will create and configure alarms through the Point Propertiesdialog box or through
scripting. CIMPLICITY places the alarms in the Alarms folder, where you can conveniently modify
them.
It is recommended that you do not create event alarms. In almost all cases, CIMPLICITY creates and
configures these alarms for you.
These steps are available if there is some reason that you must create or configure an event alarm.
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Step 1
(page
10)

Open an Alarm Definition dialog box.

Step 2
(page
12)

Configure an event alarm.

Step 3
(page
14)

Configure alarm routing.

Step 4
(page
15)

Configure alarm options.

Step 5
(page
16)

Set global alarm settings.

Step 1. Open an Alarm Definition Dialog Box
Step 1. Open an Alarm Definition Dialog Box
Option
1.1 (page
10)

Create a new event alarm.

Option
1.2 (page
11)

Open an existing Alarm Definition dialog box.

Option 1.1. Create a new Event Alarm
CIMPLICITY provides several methods to open a new Alarm Definition dialog box.
1. Select Project>Alarms in the Workbench left pane.
2. Do one of the following.

Alarms and Messages | 1 - Alarm Configuration | 11

A

Click File>New>Object on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left pane:
Either
Double click Alarms.

D

In the Workbench right pane:
a. Right-click any alarm.
b. Select New on the Popup menu.

E

Press Ctrl+N on the keyboard.

Or
a. Right-click Alarms.
b. Select New on the Popup menu.

The New Alarm dialog box opens when you use any method.
3. Enter the name of the new event alarm in the Alarm ID field.

4. Click OK.
The system verifies that the Alarm ID does not already exist, and that no invalid characters have been
used.
If the Alarm ID you entered is valid, the Alarm Definition dialog box for the new alarm opens.

Option 1.2. Open an existing Alarm Definition Dialog Box
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CIMPLICITY provides several methods to open an existing Alarm Definition dialog box.
1. Select Project>Alarms in the Workbench left pane.
2. Select an alarm in the Workbench right pane.
3. Do one of the following.

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarms.
b. Select Properties on the Popup menu.

D

In the Workbench right pane:
Either
Double click an alarm.

E

Or
a. Right-click an alarm.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

The selected alarm's Alarm Definition dialog box opens when you use any method.

Step 2. Configure an Event Alarm
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rect 13, 45, 385, 78 (page 13)
rect 171, 182, 322, 215 (page 14)
rect 16, 176, 167, 231 (page 14)
rect 9, 77, 245, 107 (page 13)
rect 12, 104, 247, 124 (page 13)
rect 12, 123, 209, 150 (page 13)
rect 208, 122, 343, 151 (page 14)
rect 11, 149, 383, 176 (page 14)
Fill in the fields as follows.
Field

Description

Description

Describes the alarm so a user can identify it more
easily. Can display in the Workbench and the Alarm
Viewer.

Alarm Class (page 27)

Selection groups this alarm with alarms that have
similar characteristics.

Alarm type

Identifies the application with which the alarm is
associated.

Help file

A text help file that users can display when they click
the Help button in the Alarm Viewer.
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Field
Severity

Description
A number from 1 through 1000. The higher the number
the more severe the alarm is considered. CIMPLICITY
treats more severe alarms with a higher priority.
Note: The Severity for the Alarm String Index
must conform to the OPC UA specification guidelines.
If you are using Web HMI with CIMPLICITY, be sure
to read the "Alarm Microservice" topic or search for
"alarm severity" in the Web HMI documentation. It's
important to configure this severity correctly so that you
get the results that you want to see in Web HMI. For
example, events of high urgency can be mapped into
the OPC severity range of 667-1000, events of medium
urgency can be mapped into the OPC severity range of
334 to 666, and events of low urgency can be mapped
into the OPC severity of 1 to 333.

Alarm message

Message that displays in the Alarm Viewer when the
alarm displays.

Alarm Logging

Check if and when you want an event alarm to
be logged in the Alarm Logging box on the Alarm
Definition tab. You can select any or all of the options:
•
•
•
•

Generate
Acknowledge
Delete
Reset

When the configuration is applied, CIMPLICITY will
add the point to its default EVENT_LOG.
Maximum stacked

Enter a number between 0 and 20.
Note: Maximum stacked treats event alarms the
same way as it does point alarms.

Note: Many fields on the Alarm tab in the Alarm Definition dialog box is the same as the
Advanced Alarm tab in the Point Properties dialog box.

Step 3. Configure Alarm Routing
Alarm Routing lets you select the roles that can view any alarms generated for the selected event
alarm.
Configuration for Alarm Routing , which is done on the Alarm Routing tab in the Alarm Definition
dialog box, is the same for event alarms and as alarm routing configuration for point alarms.
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Step 4. Configure Alarm Options
Configuration for the features included on the Alarm Options tab in the Alarm Definition dialog
box is the same for both event alarms and point alarms.
Change approval provides the functionality to maintain an audit trail of user performed alarm
operations.

Note: CIMPLICITY v9.0 clients will not support acknowledging or resetting alarms from
a CIMPLICITY v6.1 or earlier server. (CIMPLICITY v6.1 and earlier versions are no longer
supported.)
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Step 5. Set Global Alarm Settings
You can choose to store runtime alarm comments that a user enters while the alarm is being
displayed in the Alarm Viewer. Normally, these comments are deleted when the alarm is deleted.
CIMPLICITY saves the 20 most recent alarm comments in a file in the project's alarm_help
directory.
• Guidelines for storing alarm comments
• Set global alarm settings

Guidelines for storing alarm comments
• Each comment can contain up to 720 characters.
• Up to 20 comments are stored in an alarm comment file. When the 21st comment is placed in
the file, the first (oldest) comment is removed.
• If you intend to enable the Store alarm comments option, make sure that the alarm_help
directory is writable.
• If you want a comment to be associated permanently with an alarm, put it in the alarm's help
file.

Set Global Alarm Settings
1. Select Project > Properties on the Workbench menu bar.
The Project Properties dialog box opens.
2. Select the Settings tab.
3. Select Alarms.
4. Click Settings.
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The Alarm Properties dialog box opens.
Options are as follows.

Checkbox
Store alarm
comments

Filter A&E
OPC alarms
by user

Unfilterable
severity

Description
Check

Save up to 20 alarm comments beyond the life of alarms.

Clear

Alarms comments are deleted when the alarm is deleted.

Check

Filter alarms and events that go to the Alarm & Event OPC server. The filter is
determined by the resources that are allotted to the Alarm & Event OPC server user.
Note: The user is specified in the Alarm & Event OPC server's Project Properties (page
163) dialog box.

Clear

All alarms and events go to the Alarm & Event OPC server.

An alarm that has a severity (page 44) that is equal to or greater than the entered value
cannot be filtered out. Even if the value dips below the alarm severity threshold, the alarm will
continue to display in the Alarm Viewer until it is deleted. Once deleted, the cycle will begin again.
If the value again goes into an alarm state that is equal to or greater than the entered severity the
alarm will display until it is deleted.

5. Click OK.
Note: Click Cancel to cancel the changes.

Up to 20 alarm comments are stored in a file in the project's alarm_help directory.
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Note: Configuration update will overwrite read-only files.

Chapter 2. Alarm Blocking Configuration
About Alarm Blocking
• Overview
• Assign alarms
• Choose blocking modes
• Assign alarm priorities
• Alarm blocking guidelines

Overview
Monitoring and control systems do an excellent job of informing operators of problem conditions
through alarms. However, there are times when operators can be overwhelmed by numerous alarms
that are the result of one major problem. For example, when a process conveyor stops, it affects all
machines feeding into it. The operator needs to know that the major problem is the stopped conveyor
and not waste valuable time looking through all the other resulting alarms. Alarm Blocking lets you
configure a hierarchy of alarms for your process so users see the important alarms first.
Alarm Blocking lets you:
• Logically group alarms into blocking groups.
• Select a runtime blocking mode for each blocking group.
• Assign a priority level to each alarm in a blocking group.
Each Alarm Blocking group works independently. This means that the high priority alarms in one
group do not block the high priority alarms in another group.
Before you implement Alarm Blocking, you need to plan how you want to group and prioritize your
alarms for your project. You need to decide:
• The number of blocking groups you need.
• Which alarms are to be assigned to each blocking group.
• How the alarms are to be prioritized in each blocking group.
• How to handle the display of equal priority alarms in each blocking group.
Alarms that you do not assign to Alarm Blocking groups are not affected by Alarm Blocking.
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Assign alarms
CIMPLICITY software generates two types of alarms; point alarms and system alarms. Each point
alarm is uniquely identified by its Alarm ID. Each system alarm is uniquely identified by its Alarm
ID and Resource ID.
For example:
• For point XYZ, the unique Alarm ID is XYZ.
• Each unique instance of the $ALARM_MODIFIED system alarm is identified by the Alarm ID
and the Resource ID of the affected device.
Note: A possible exception is for $DEVICE_DOWN. You can use the Global parameter
DEVICE_DOWN_DEVICE_REF to put only the Device ID as the alarm reference.
For Alarm Blocking, you can assign a uniquely identified alarm to only one group. This means:
• You can assign a point alarm to only one blocking group.
• You can assign a uniquely identified system alarm to only one blocking group.
This means that you can have more than one instance of a system alarm in a blocking group or you
may have system alarms in more than one blocking group, provided that the Resource ID you assign
to each instance is unique across all Alarm Blocking groups.

Choose blocking modes
You can select (page 23) one of two blocking modes for each Alarm Blocking group that you
create.
• Peer Blocking mode: Only the first alarm in a set of alarms with equal priority displays.
• Non-Peer Blocking mode: All alarms in a set of alarms with equal priority display.

Assign alarm priorities
You need to assign each alarm in an Alarm Blocking group a number from 0 to 32767. The higher
the number you enter, the higher the priority of the alarm. For example, alarm XXX with priority 100
blocks alarm YYY with priority 10. You can assign the same priority number to more than one alarm
in an Alarm Blocking group. The priority of an alarm and the blocking mode of the group determine
whether the alarm is blocked or not.

Alarm blocking Guidelines
When an alarm that is assigned to an Alarm Blocking group is generated:
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• If there is a current alarm with higher priority in the group, the newly generated alarm is
blocked.
• For Peer Blocking, if there is a current alarm with equal priority in the group, the newly
generated alarm is blocked. In other words, only one alarm in a set of alarms with equal priority
displays at any given time.
• For Non-Peer Blocking, all current alarms with equal priority display at any given time.
When the blocking alarm returns to Normal state or is deleted:
• For Peer Blocking, if alarms of equal priority exist, the oldest one displays and becomes the new
blocking alarm.
• For Non-Peer Blocking, all alarms with the next lower priority display and become the new
blocking alarms.
If lower priority alarm is the current blocking alarm and a higher priority alarm is generated, the
lower priority alarm remains on the list of alarms and the higher priority alarm becomes the new
blocking alarm.
If an alarm already exists in Normal state and it returns to Alarm state, the alarm is not blocked.

Alarm Blocking Configuration
Alarm Blocking Configuration
1
(page
21)

Create a new alarm blocking group.

2
(page
22)

Open an existing Alarm Blocking dialog box.

3
(page
23)

Configure an alarm blocking group.

4
(page
24)

Add/remove/modify alarms.

1. Create a new Alarm Blocking Group
CIMPLICITY provides several methods to open a new Alarm Blocking dialog box.
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1. Select Project>Alarms>Alarm Blocking in the Workbench left pane.
2. Do one of the following.

A

Click File>New>Object on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left-pane:
Either
Double click Alarm Blocking.

Or
a. Right-click Alarm Blocking.
b. Select New on the Popup menu.

D

In the Workbench right pane.
a. Right-click any Alarm Blocking group.
b. Select New on the Popup menu.

E

Press Ctrl+N on the keyboard.

A new Alarm Blocking dialog box opens when you use any method.

2. Open an Existing Alarm Blocking Dialog Box
CIMPLICITY provides several methods to open an existing Alarm Blocking dialog box.
1. Select Project>Alarms>Alarm Blocking in the Workbench left pane.
2. Select an Alarm Blocking group in the Workbench right pane.
3. Do one of the following.
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A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm Blocking.
b. Select Properties on the Popup menu.

D

In the Workbench right pane:
Either
Double click an Alarm Blocking
group.

E

Or
a. Right-click an Alarm Blocking group.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

An Alarm Blocking dialog box associated with the selected alarm blocking group opens when you
use any method.

3. Configure an Alarm Blocking Group
Enter the following information to create a new Alarm block group:
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Field

Description

Group ID

Enter a new, unique Alarm group name. The group name can be up to 32 characters long.

Description

Enter a description of the Alarm group. The description can be up to 40 characters long.

Peer block
• Check to enforce Peer Blocking mode (page 20) for this group.
• Clear if you want to use Non-Peer Blocking mode (page 20).
The Blocking Mode and alarm priorities determine the alarm blocking hierarchy at run-time.
Alarms

Displays the current list of alarms in the Alarm block group; Alarm ID, Priority (page 20) and Resource
ID. Change an alarm on the list by directly editing its Alarm ID, Priority or Resource ID or by selecting the
Alarm ID and clicking Set attributes .

Note: You can resize the width of the Alarm ID, Priority and Resource ID fields to suit your
needs.
Click one of the following:
Button

Description

Add

Select an Alarm ID from the Browser dialog box.

Delete

Delete an alarm from the list.

Set Attribute (page 24)

Open the Set Attributes dialog box for a selected alarm ID.

OK

Close the Alarm Blocking dialog box and save the configuration.

Cancel

Cancel the configuration done while the Alarm Blocking dialog box was
open.

4. Add/Remove/Modify Alarms
• Add an alarm.
• Remove an alarm.
• Modify an alarm.

Add an alarm
You can enter the name of an Alarm ID in the Alarm ID field in the Alarm Blocking dialog box in
any of the following ways:
• Click Add to open the Browser dialog box and browse for the Alarm ID you want.
• Click the Browser button to the right of the input field to open the Browser dialog box and
browse for the Alarm ID you want.
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• Click the Popup menu button to the right of the input field to create a new Alarm ID, modify
the current Alarm ID or browse for an Alarm ID.
Enter the priority of the Alarm ID in the Priority field. This can be a number from 0 to 32767. The
higher the number you enter, the higher the blocking priority for the alarm. For example, if you have
alarm XXX with priority set to 10 and alarm YYY with priority set to 100 in the same group, when
alarm YYY generates, it blocks alarm XXX.
If the Alarm ID does not have a Point ID, you must assign a Resource ID to the alarm. You can
click the Browser button to the right of the input field to open the Browser dialog box and browse
for the Resource ID you want. You can also use the Pop-up menu button to create a new Resource
ID, modify the current Resource ID or browse for a Resource ID. Remember that each Alarm ID/
Resource ID combination must be unique within a group and across all groups.

Remove an alarm
1. Select the alarm from the list in the group's Alarm Blocking dialog box.
2. Click Delete.

Modify an alarm

To modify an alarm's name, priority and Resource ID in the list:
1. Select the alarm ID you want to edit in the selected group's Alarm Blocking dialog box.
2. Type in your changes.
If you are changing an Alarm ID or Resource ID, you can also use the Browser and Popup menu
buttons in the field to search for a new one.

To set a number of alarms to the same priority and/or Resource ID at the same
time:
1. Select the alarms whose priority and/or Resource ID you want to set. You can use the Shift and
Ctrl keys while making your selection.
2. Click Set Attributes.
The Set Attributes dialog box opens.

3. Enter the new priority and/or Resource ID for the alarms.
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4. Click OK.
All the selected alarms will be assigned the new priority. Non-point alarms will be assigned the new
Resource ID.

Chapter 3. Alarm Classes Configuration
About Alarm Classes
You can group Alarms with similar characteristics by Alarm Class.
You can then assign:
• An order or priority to each Alarm Class. The order is a number from 0 to 99, where 0 is the
highest priority and 99 is the lowest priority.
• Colors and blinking that provide immediate visual recognition of different levels in the alarm
class state.
For example, an alarm class may be defined as a high priority alarm. The alarm state may be in
a High state.
• Audio support that provides immediate recognition when an alarm in the class is generated.
Important: The default number of alarm classes is 550. This number can be changed by adding
a MAX_ALARM_CLASSES parameter to a globals.ini file.

Alarm Class Configuration
Alarm Class Configuration
Step 1
(page
27)

Open the Alarm Class Configuration dialog box.

Step 2
(page
30)

Enter alarm class specifications.

Step 3
(page
33)

Configure sound for an alarm class.

Step 1. Open the Alarm Class Configuration Dialog Box
Step 1. Open the Alarm Class Configuration Dialog Box
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Option
1.1 (page
28)

Create a new alarm class.

Option
1.2 (page
29)

Open an existing Alarm Class Configuration dialog box.

Option 1.1. Create a new Alarm Class
CIMPLICITY provides several methods to open a new Alarm Class configuration dialog box.
1. Select Project>Alarms>Alarm Classes in the Workbench left pane.
2. Do one of the following:

A

Click File > New > Object on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left pane, do the following:
Either
Double click Alarm Classes.

D

In the Workbench right pane, do the following:
a. Right-click any alarm.
b. Select New on the Popup menu.

E

Press Ctrl+N on the keyboard.

Or
a. Right click Alarms.
b. Select New on the Popup
menu.

An Alarm Class Configuration dialog box that includes information for the selected alarm class
opens when you use either method.
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Option 1.2. Open an existing Alarm Class Configuration Dialog Box
CIMPLICITY provides several methods to open an existing Alarm Class configuration dialog box.
1. Select Project>Alarms>Alarm Classes in the Workbench left pane.
2. Select an alarm class in the Workbench right pane.
3. Do one of the following:

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.
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C

In the Workbench left pane:
a. Right-click Alarm Classes.
b. Select Properties on the Popup menu.

D

In the Workbench right pane:
Either
Double click an Alarm Class.

E

Or
a. Right click an alarm.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

The Alarm Class Configuration dialog box for the selected alarm class opens when you use either
method. The Class ID field is read-only.

Step 2. Enter Alarm Class Specifications
Step 2. Enter Alarm Class Specifications
Step 2.1
(page
31)

Enter alarm class general specifications.

Step 2.2
(page
32)

Select colors and blink rates for the alarm states.
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Step 2.1. Enter Alarm Class General Specifications
General specifications on the Alarm Class tab in the Alarm Class Configuration dialog box include
the following.

rect 11, 21, 156, 55 (page 31)
rect 193, 55, 338, 89 (page 32)
rect 20, 87, 437, 121 (page 31)
rect 50, 55, 195, 89 (page 31)
Field
Class ID

Description
Alarm class name.
• New alarm class
The Class ID field is read/write when the alarm class is created. The class ID:
◦ Can be up to 5 characters in length.
◦ Must be unique.
◦ Cannot include the $ or | characters.

• Previously created alarm classes
The Class ID field is read-only for previously created alarm classes.

Description
• Can be up to 64 characters in length
• Displays in the Class Description field in the Workbench right pane.
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Field
Order

Description
Priority number
• Alarms with a 0-order number have the highest priority. The higher the number, the
lower the priority.
• Alarms use these priorities internally and to prioritize occurrences, such as alarm
sound.
• If you assign the same order to more than one class, the classes are alphabetized
within the order.
Example
You assign order 0 to High, Medium and Low alarm classes. When you select to sort
classes in the CIMPLICITY AMV Control Properties dialog box, the Alarm Viewer will
sort by the selected order, descending or ascending.
◦ High
◦ Low
◦ Medium

Step 2.2. Select Colors and Blink Rates for Alarm States
Selected foreground (font) and background colors display in the Alarm Viewer for each of the
following states and levels.

Other States
Field
State

Description
Normal
Unavailable

Foreground

Font color

Background

Background color

Blink rate in tenths of a second

Alarms in either or both Other states can blink when the
state is active.
Blink rates for each Other state include:
Value
0
1
2
20
N

Blink foreground color

Font blink color.
The second color is the Foreground color for the selected
state.
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Field
Blink background color

Description
Blackground blink color.
The second color is the Background color for the
selected state.

Alarm state
Field

Description

Alarm level

Levels map to the point alarm limits defined in the Point
Properties dialog box, which use the alarm string indices.

Foreground

Font color.
A different color can be selected for each level.

Background

Background color.
A different color can be selected for each level.

Use the same settings for all alarm levels

When clicked, uses the Foreground and Background for
the selected Alarm level.
1.
2.
3.
4.

Select an Alarm level.
Select a Foreground.
Select a Background color.
Click Use the same settings for all alarm levels.

Blink rate in tenths of a second
Blink foreground color
Blink background color

Acknowledged state
Specifications for alarm levels when the alarms are acknowledged.
Configuration options are the same as for Alarm State.

Step 3. Select Sound for an Alarm Class
Step 3. Select Sound for an Alarm Class
You can configure an alarm class to use audio alarming on the Audio tab in the Alarm Class
Configuration dialog box.
• Hardware and software requirements to generate an audio alarm.
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• Steps to configure an audio alarm.

Hardware and software requirements to generate an audio alarm
Sound

Requirements

Wave file
• Sound card to generate the sound.
• Sound system, such as a speaker or headset, to make the sound audible.
• Appropriate .wav file on the computer being used.

Beep
• No requirements for:
◦ A beep
◦ (Supported Windows versions) the frequency, duration and number of beeps
• Sound card for:
A beep, the frequency, duration and number of beeps.

Steps to configure an audio alarm
Step 3.1
(page
34)

Display the Audio tab in the Alarm Class Configuration dialog box.

Step 3.2
(page
35)

Configure sound for selected alarm levels.

Important: Sounds only play if the CIMPLICITY® Alarm Sound Manager is running.

Step 3.1. Display the Audio Tab
Select the Audio tab in the Alarm Class Configuration dialog box.
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Note: You can open the Alarm Class Configuration dialog box and configure the audio for a
point alarm through the Point Properties dialog box.

Step 3.2. Configure .wav Files for an Alarm Class Sound
1. Select an Alarm level.
Note: Alarm levels (page 32) map to the point alarm limits defined in the Point
Properties dialog box, which use the alarm string indices.
Alarm levels for sound use the alarm conditions and sub-conditions as follows.
HiHi
Hi
Lo
LoLo
2. Select a sound option for the selected level.
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Option

Description

No sound

There is no sound
when the selected
level is reached.

Wave file

The sound from the
.wav file plays when
the selected level is
reached. Enter the
path and .wav file you
want to use as the
sound for the selected
level.
Tip: You can
specify logical names
in the file name,
such as SITE_ROOT
and BSM_ROOT
in the path name
for the wave file.
These are expanded
into actual directory
names when the file
is used. For example,
SITE_ROOT: \sounds
\high.wav refers to
the file high.wav in
the sounds directory
within the project's
directory.

Alarms and Messages | 3 - Alarm Classes Configuration | 37

Option
Beep

Description
A defined beep
sounds when the
selected level is
reached.
Frequency
Duration
No of
beeps
Delay

Test

Click to test the sound.

3. Do one of the following:
• Repeat the above steps for the Alarm Viewer to play the selected sound for the active alarm
state level.
• Click Use the same settings for all alarm levels for the Alarm Viewer to play the selected
sound for all levels when the point is in an alarm state.

Alarm Class Color Assignments
Alarm Class, alarm state animation and color index animation use indexes 0 through 15 in the
rgb.dat file as the default colors.
If you define an rgb.dat file and change the colors in indexes 0 through 15 of the, you need to
change colors displayed in the Alarm Class dialog box to match them.
Reasons to define an rgb.dat file include:
• Change any of the default colors (0 through 95)
• Add more colors to the default table (indexes 96 through 255 are available for this purpose)
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• Import screens from a CIMPLICITY System-I/U, -D/V, -H/U or -RS/U system that do not use
the default color mappings.

Default Alarm Color Mappings
The default mappings for Alarm Colors are:
Number

Red

Green

Blue

Color

0

0

0

0

Black

1

255

0

0

Red

2

0

255

0

Lime

3

0

0

255

Blue

4

128

0

0

Maroon

5

0

128

0

Green

6

128

0

128

Purple

7

255

255

255

White

8

0

128

128

Teal

9

128

128

128

Gray

10

128

128

0

Olive

11

32

64

64

Dark

12

224

176

160

Rose

13

255

0

255

Fuchsia

14

0

255

255

Aqua

15

255

255

0

Yellow

Procedure to Map Alarm Class Colors in rgb.dat
1. Create an am_colors.cfg file in the same directory as your rgb.dat file.
The first line in the file must contain only the |-* characters.
Each succeeding line contains an index number (0 through 15) followed by a vertical bar ( | )
and the color name.
2. Use the same rgb.dat and am_colors.cfg files for all projects.
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Important: The file that is used to display colors is the file for the project in which Alarm
Viewer or CimView was started in, not the file for the project where the alarm classes or
CimView screens were configured.

am_colors.cfg file

The colors listed in this sample file match the default colors.
|-*
0|Black
1|Red
2|Lime
3|Blue
4|Maroon
5|Green
6|Purple
7|White
8|Teal
9|Gray
10|Olive
11|Dark
12|Rose
13|Fuchsia
14|Aqua
15|Yellow

Chapter 4. Alarm Strings Configuration
About Alarm Strings
You use Alarm Strings to name alarm states. An alarm displays the string for its alarm state when
%State is included in the alarm message.
Alarm messages are configured in the Point Properties and Alarm Definition dialog boxes.
• Analog point alarm strings.
• Digital point alarm strings.
• Alarm string sets.

Analog point alarm strings
For analog points, you can define up to four alarm values for a point. Each value corresponds to an
alarm state; each state has a corresponding alarm string:
Point Value

Alarm State

%State field Display

Greater than or equal to Alarm High.

Alarm High

Alarm High Msg

Greater than or equal to Warning High and Less than Alarm High.

Warning High

Warning High Msg

Less than or equal to Warning Low and Greater than Alarm Low.

Warning Low

Warning Low Msg

Less than or equal to Alarm Low.

Alarm Low

Alarm Low Msg

Less than Warning High and Greater than Warning Low.

Normal

Normal Msg

Digital point alarm strings
For digital points, only one alarm state can be defined. That is, a digital point is in alarm state when it
is either 1 or 0. Otherwise, the point's value is in the Normal state. Also, note the following:
Point Value

Alarm State

%State field Display

1

Alarm state

Alarm High Msg

0

Alarm state

Warning High Msg
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Alarm string sets
An index number, which is specified when a set is defined, identifies each set of alarm strings. You
can configure up to 99 alarm string sets, numbered 1 through 99. When you configure a point you
can select the set that applies to the point for inclusion in the point's alarm message.
The CIMPLICITY default configuration includes a set of alarm strings for Index number 1. The
Index number 1 alarm string is the default when you add a device point. This string may be modified
but should never be deleted.

Alarm String Configuration
Alarm String Configuration
The Workbench displays a project's existing alarm strings (message groups) in the right pane.
Steps to configure an alarm string include:
Step 1
(page
41)

View existing alarm strings.

Step 2
(page
42)

Open the Alarm String Index dialog box.

Step 3
(page
44)

Configure an Alarm String Index Set

Step 1. View Existing Alarm Strings
Select Project > Alarms > Alarm Strings in the Workbench left-pane.
The Workbench right pane displays the following fields for each Alarm String Index:
• HiHi (alarm high) Msg
• LoLo (alarm low) Msg
• Hi (warning high) Msg
• Lo (warning low) Msg
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Note: Use the Workbench Field Chooser to remove or re-display any of the fields, except the
Index. The Index is required.
The Alarm Definition list is initially sorted by Index. You can click on any of the other column titles
at the top of the list to sort the list by that attribute.

Step 2. Open the Alarm String Index Dialog Box
Step 2. Open the Alarm String Index Dialog Box
Option
2.1 (page
42)

Create a new alarm string set.

Option
2.2 (page
43)

Open an existing Alarm String Index dialog box.

Option 2.1. Create a new Alarm String Set
CIMPLICITY provides several methods to open a new Alarm String Definition dialog box.
1. Select Project>Alarms>Alarm Strings in the Workbench left-pane.
2. Do one of the following:
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A

Click File>New>Object on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left-pane:
Either
Double click Alarm Strings.

D

In the Workbench right-pane.
a. Right-click any alarm string.
b. Select New on the Popup menu.

E

Press Ctrl+N on the keyboard.

Or
a. Right-click Alarm Strings.
b. Select New on the Popup menu.

An Alarm String Index dialog box that displays the next highest number opens when you use
any method.

Option 2.2. Open an existing Alarm String Index Dialog Box
CIMPLICITY provides several methods to open an existing Alarm String Index dialog box.
1. Select Project>Alarms>Alarm Strings in the Workbench left-pane.
2. Select an alarm string in the Workbench right-pane.
3. Do one of the following:

Alarms and Messages | 4 - Alarm Strings Configuration | 44

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left-pane:
a. Right-click Alarm Strings.
b. Select Properties on the Popup menu.

D

In the Workbench right-pane:
Either
Double click an alarm string.

E

Or
a. Right-click an alarm string.
b. Select Properties on the Popup menu.

Press Alt+Enter on the keyboard.

An Alarm String Index dialog box associated with the selected alarm string opens when you use
any method. The Alarm string index field is read-only.

Step 3. Configure an Alarm String Index Set
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1
(page
45)

Alarm string index

2
(page
45)

String values

3
(page
46)

Severity

4
(page
46)

Example 1

5
(page
48)

Example 2

1. Alarm String Index
Alarm string identification.
• New alarm string sets
The next available number displays in the Alarm string index field when the alarm string is
created. The field is read/write.
If the default number is changed, the new alarm string index number:
◦ Must be from 1 to 99 and
◦ Cannot conflict with an existing Alarm String Index.

• Existing alarm string sets
The Class ID field is read-only for previously created alarm string sets.

The index number is selected for an alarm to associate an alarm string set with that alarm.
2. String Values
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Values for each of the following fields can contain up to 16 characters.
Alarm high
Warning high
Warning low
Alarm low
Normal
The value you enter for an alarm string index:
• Corresponds to Normal and Alarm State levels in the Alarm Class Configuration dialog box.
• Displays on the Alarm tab in the Point Properties dialog box when the string index is selected.
• Displays when specified as %STATE in a point's alarm message when the point is in the related
alarm state.
3. Severity
A number from 1 through 1000. The higher the number the more severe the alarm is considered.
CIMPLICITY treats more severe alarms with a higher priority.
Note: The Severity for the Alarm String Index must conform to the OPC UA specification
guidelines. If you are using Web HMI with CIMPLICITY, be sure to read the "Alarm Microservice"
topic or search for "alarm severity" in the Web HMI documentation. It's important to configure this
severity correctly so that you get the results that you want to see in Web HMI. For example, events
of high urgency can be mapped into the OPC severity range of 667-1000, events of medium urgency
can be mapped into the OPC severity range of 334 to 666, and events of low urgency can be mapped
into the OPC severity of 1 to 333.
Note: You can select and display the Severity in the Alarm Viewer.
This example shows how the alarm string value for alarm string index 2 displays in the Alarm

Viewer Message field.
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1

2

String values are entered in the Alarm String Index dialog box.
String field

Value

Alarm high

Too Full

Warning high

Almost Full

Warning low

Almost Empty

Alarm low

Empty

Normal

NORMAL

A

%STATE in the Alarm message displays the
string values for the selected alarm string
set.

B

String index 2 is selected.

C

Alarm limit fields correspond to the selected
string index values.
String Value

Alarm Limit

Too Full

Too Full

Almost Full

Almost Full

Almost Empty

Almost
Empty

Empty

Empty
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Message is selected as
a field in an Alarm Viewer

3

configuration.
The Alarm Viewer displays the alarm string
values for every point that includes %STATE in
the alarm message.

This example shows configurations for the Alarm String 2 index severity displays in the Alarm
Viewer.
1

An alarm severity is entered for each string value in the Alarm String Index dialog box.

String value

Severity

Too Full

250
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2

Almost Full

200

Almost Empty

200

Empty

250

NORMAL

0

The selected string index is 2.

The alarm limits fields correspond to the string index 2 values.
The fields inherently include the severity levels defined for the alarm string set.

3

String value

Alarm limit

Too Full

Too Full

Almost Full

Almost Full

Almost Empty

Almost Empty

Empty

Empty

Class and Severity are selected as fields in an Alarm Viewer configuration.
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4

The Alarm Viewer displays the class and severity.

Class

NORTH

Severity

Value corresponds to each level.

Severity value

Corresponds to

275

HiHi and LoLo

200

Hi and Lo
Note: Foreground and background colors for each alarm correspond to the alarm class configuration.

Chapter 5. Alarm Printer Configuration
About Alarm Printer Configuration
You can configure a serial or parallel printer in CIMPLICITY software that prints alarms and/or
events as they occur. You may also configure an alarm printer to write to a file, rather than to a
device. You may configure a local or network printer as the alarm printer. If your project includes the
Host Redundancy option, you may configure a redundant alarm printer.
Important: Before you start, make sure that the printer is not configured in Windows.

Alarm Printer configuration.
Alarm Printer Configuration
The Alarm Printer dialog box enables you to define the device, and the types of alarms handled by it.
You can configure local and network printers.
Note: You can also configure redundant alarm printers if your project supports the Host
Redundancy option.
When you are finished defining the alarm printer properties, click OK to close the Alarm Printer
dialog and create the new alarm printer, or click Cancel to close the property sheet without creating
the new alarm printer.
Step 1
(page
52)

Open an Alarm Printer dialog box.

Step 2
(page
54)

Configure General Alarm Printer Properties

Step 3
(page
56)

Configure Alarm Printer Layout Properties

Step 4
(page
57)

Configure Alarm Printer Date/Time Format

Step 5
(page
58)

Continue for Serial, Redundant or Network Printers
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Step 1. Open an Alarm Printer Dialog Box
Step 1. Open an Alarm Printer Dialog Box
Option
1.1 (page
52)

Add an alarm printer.

Option
1.2 (page
53)

Modify an existing alarm printer.

Option 1.1. Add an Alarm Printer
CIMPLICITY provides several methods to open a new Alarm Printer dialog box.
1. Select Project > Alarms > Alarm Printer in the Workbench left pane.
2. Do one of the following:

A

Click File > New > Object on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left pane, double click Alarm Printer.

D

In the Workbench right pane:
a. Right-click any alarm printer.
b. Select New on the Popup menu.

E

Press Ctrl+N on the keyboard.

The New Alarm Log Printer dialog box opens when you use any method.
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3. Enter the name of the new alarm printer, or the name of the file you want to write alarms to in
the Name field.
You may enter a maximum of 11 characters.

4. Click OK.
The system verifies that the alarm printer name does not already exist, and that no invalid characters
have been used.
If the alarm printer name you entered is valid, the Alarm Printer dialog box for the new alarm printer
opens.

Option 1.2. Open the Dialog Box for an Existing Alarm Printer
CIMPLICITY provides several methods to open an existing Alarm Printer dialog box.
1. Select Project>Alarms>Alarm Printer in the Workbench left pane.
2. Select an alarm printer in the Workbench right pane.
3. Do one of the following:

A

Click Edit>Properties on the Workbench menu bar.
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B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm Printer.
b. Select Properties on the Popup menu.

D

In the Workbench right pane, double click an alarm printer.

E

Press Alt+Enter on the keyboard.

An Alarm Printer dialog box associated with the selected alarm string opens when you use any
method.

Step 2. Configure General Alarm Printer Properties
1. Enter specification using the following check boxes.

Check box

Description

Log Events

Check to log events to the printer.

Log Alarms

Check if you want to log alarms to the printer.
Note: If you clear this check box, the Alarm logging are dimmed.

Alarm Logging
Options

These options are available only when you select the Log alarms check box. Use these fields to
specify the types of alarms, and alarms classes that will be printed on this alarm printer:

Generated
alarms

Check to log messages when alarms are generated.

Acknowledged
alarms

Check to log messages when alarms are acknowledged.
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Check box

Description

Reset alarms

Check to log messages when alarms are reset.

Deleted
alarms

Check to log messages when alarms are deleted.

Important: You must either check All alarm classes or select an Alarm Class.
All alarm
classes

Check to log messages for all alarm classes. When you do, the Alarm Class field will be dimmed.

Alarm
Class

This field is available when you uncheck the All alarm classes check box. If you want log alarms for a
particular Alarm Class, enter that class name in this field. You can also:
• Display the Select Alarm Class browser and use it to select the Alarm Class.
• Click the Popp Menu button
browse for an Alarm Class.

to create a new Alarm Class, edit the current Alarm Class, or

2. Enter the device name for the alarm printer in the Output field. You can do any of the
following:
• Enter the name of a local port on the project's computer (e.g. LPT1 or COM1 ) where
you have attached the alarm printer.
Note: If you are connecting to serial port COM10 and above, the format is \\.
\COM< n > .
• Enter a file name to write alarms to a file. If you wish, you may also enter a period
followed by a three character file extension (e.g. alarms.fil ).
If you do not enter a file extension, none is automatically provided. The file is placed in the
project directory (not in the project's log directory) .
Example
If a project name is systest, the file is placed in the systest folder:
I:\testplans\systest
• Enter the path for a network printer (e.g. \\M_005ad4\d5prn1 ).
Note: If the printer is connected locally on your computer, use the local port name
instead of the network path.
• Enter the path for a file on a network disk (e.g. \\nt001\proj1\alarms ).
Tip: You can associate more than one alarm printer with a network printer or file on a
network disk. If you use a network printer or file, clear the Print header field in the Layout tab
of the Alarm Printer dialog box.
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Step 3. Configure Alarm Printer Layout Properties
The Layout tab of the Alarm Printer dialog box enables you to determine whether a header should be
printed at the top of a page.

Specifications include:
Field

Description

Print
Headers

Check to print a header at the top of each page. If you have more than one alarm printer process sending
messages to the same printer or file, uncheck this check box. When you uncheck the check box, the Page
length field is disabled.

Page
Length

Enter the number of lines per page that can be printed. The number must be an integer between 1 and
999.

Page
Width

Enter the number of characters that can be printed on a line. The number must be an integer between 80
and 157.
Important: If the printer is configured as 80 characters wide then AMLP will print on two lines
regardless of the actual width of the printer.

Redundant
Alarm
Printing
(page
59)

This field is enabled if your project has the Host Redundancy option.
• Check for both the Active and Standby computers to print alarms.
• Uncheck for only the Active computer to print alarms.
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Step 4. Configure Alarm Printer Date/Time Format
Use the Date/Time Format tab on the Alarm Printer dialog box to choose how the alarm printer will
print the date and time.

You can define the following:
Header Date

Select the format you want to use to print the date on the alarm printer
page header. This field is not available if you are not printing a page
header. A sample for the format you choose displays in the Sample field
in this box. You may select one of the formats from the list, or construct
your own format.

Alarm Date/Time

Select the format you want to use to print the date and time of each alarm.
A sample for the format you choose displays in the Sample field in this
box. You may select one of the formats from the list, or construct your own
format.

To construct month/day/year formats, use the following information.
m

Numeric month with no leading zero.

mm

Numeric month with leading zero.

mmm

Short text month.

mmmm

Long Text month.

d

Numeric day with no leading zero.

dd

Numeric day with leading zero.

ddd

Short text day of the week.
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dddd

Long text day of the week.

y

Last two digits of year. For digits 00 through 09, only the last digit is displayed.

yy

Last two digits of year. For digits 00 through 09, both digits are displayed.

yyyy

All four digits of year

If you enter dddd dd mmmm yyyy, the sample date will be Saturday 05 March 1994.
You may use spaces, dashes, slashes or any other delimiter of your choice to separate the date fields.
To construct time formats, use the following information:
H

Hours based on a twelve-hour clock with no leading zero.

HH

Hours based on a twelve-hour clock with leading zero.

HHH

Hours based on a 24-hour clock with no leading zero.

HHHH

Hours based on a 24-hour clock with leading zero.

M

Minutes with no leading zero.

MM

Minutes with leading zero.

S

Seconds with no leading zero.

SS

Seconds with leading zero.

T

Hundredths of seconds with no leading zero.

TT

Hundredths of seconds with leading zeros.

P, A, p, or a

AM/PM indicator.

If you enter HHHH:MM:SS:TT p, the sample time will be 13:05:06:08 PM.
You may use colons, spaces or any other delimiter of your choice to separate the time fields.

Step 5. Continue for Serial, Redundant or Network Printers
Step 5. Continue for Serial, Redundant or Network Printers
Option
5.1 (page
59)

Continue for serial printers.

Option
5.2 (page
59)

Continue for redundant alarm printers.

Option
5.3 (page
61)

Continue for network printers.
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Option 5.1. Continue for Serial Alarm Printers
If you are configuring a serial printer, its printer baud rate, parity, and data length will have to be set
each time your system is rebooted. You can do this by creating a file called cimp_port.bat in the
top-level directory on the disk where your project is located. The file will be called by the Alarm
Printer program when it initiates printing on the printer. The file contains:
@echo off
mode <port> baud=<rate> parity=<set> data=<n> stop=<m>

Where
<
port>

Is the serial port to which the printer is connected.

< rate
>

Is the baud rate of the printer.

< set
>

Is the parity used by the printer.

<n>

Is the number of data bits.

<m>

Is the number of stop bits.

Example
If you have a printer on COM1: port that communicates at 9600 baud, no parity, 8 data bits and 1
stop bit, the file would look like this:
@echo off
mode COM1: baud=9600 parity=n data=8 stop=1

If you have more than one serial printer, you will need one mode line per printer.
To create a mode line file:
1. Open a Notepad window.
2. Enter the printer configuration information according to the above template.
3. Save the file called cimp_port.bat in the top-level directory on the disk where your project is
located.

Option 5.2. Continue for Redundant Alarm Printers
In a redundant configuration, both the active and standby computer have the same configuration.
When you perform a Configuration Update, the configuration data for the project on the active
computer is copied to the project on the standby computer.
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The information you enter in the Redundant alarm printing and Output fields determine where
alarms will be printed.
Configuration for the following computer setups is as follows:
1. For a redundant configuration where each computer has a local line printer (LPT1) configured.
The primary computer is COMP1 and the secondary computer is COMP2.

• If you enter LPT1 in the Output field and check Redundant alarm printing, the active
project on COMP1 sends alarm messages to LPT1 on COMP1 and the standby project
on COMP2 sends alarm messages that it generates while in standby mode to LPT1 on
COMP2.
When the project on COMP2 becomes the active project, it continues to send alarm printer
messages to LPT1 on COMP2.
• If you enter LPT1 in the Output field and uncheck Redundant alarm printing, the
active project on COMP1 sends alarms to LPT1 on COMP1. The standby project on
COMP2 sends no alarms until it becomes the active project.
When the project on COMP2 becomes the active project, it sends alarm messages to LPT1
on COMP2.
2. For a redundant configuration with a network line printer (\\ABC\NET1 ). The primary
computer is COMP1 and the secondary computer is COMP2.

• If you enter \\ABC\NET1 in the Output field and check Redundant alarm printing, the
active project on COMP1 sends alarm messages to \\ABC\NET1 and the standby project
on COMP2 sends alarm messages that it generates while in standby mode to \\ABC\NET1
.This may result in duplicate messages.
If you select this option, disable the Print header field.
• If you enter \\ABC\NET1 in the Output field and uncheck Redundant alarm printing,
the active project on COMP1 sends alarms to the network device. The standby project on
COMP2 sends no alarms until it becomes the main project.
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When the project on COMP2 becomes the main project, it sends alarm messages to \\ABC
\NET1 .
Note: Check Redundant alarm printing on the Layout tab in the Alarm Printer dialog box
if you want both the active and standby computers to print alarms.

Option 5.3. Continue for Network Alarm Printers
When you print directly to a network printer the Alarm Page functionality does not print alarm
messages as they happen, by default. Instead, it waits until there is a full page of alarms to send to the
printer.
To print the current set of unprinted alarms:
1. Click Tools > Command Prompt on the Workbench menu bar.
A DOS window opens in the CIMPLICITY project directory.
2. Enter amlp_flush.exe.
The alarms will be printed.
Note: You can also initiate amlp_flush.exe from scripts within the CIMPLICITY environment.
This will trigger printing whenever the specified conditions (for example an alarm going off) are met.

Alarm Printer Global Parameters
1. The Alarm Line Printer program (AMLP) assumes that there is no restriction for the size of the
alarm message queue. If the output device is disabled, a virtual memory overflow can result.
You can use the AMLP_MAX_QUEUE global parameter to restrict the size of the alarm
message queue.
2. The Alarm Line Printer program (AMLP) assumes that the time to be printed when an alarm is
acknowledged or deleted is the time the alarm was generated.
You can use the AMLP_USE_GEN_TIME global parameter to select whether you want the
generation time or the action (acknowledge or delete) time to be printed.

Chapter 6. CIMPLICITY Language Mapper
About CIMPLICITY Language Mapping
CIMPLICITY Language mapping can speed up configuration and offer language and text string
options during runtime when you have Alarm Viewers and/or CimView screens that:
• Will be viewed in different languages during runtime.
• Require only text string modification to be used for different situations.
Tip: CIMPLICITY Language Mapping also provides an efficient method for using the same
screen in different locations when it will require different text strings for the same messages, e.g. Call
the North Tank supervisor or Call the South Tank Supervisor instead of Call the Tank Supervisor.
Text strings for each screen version can be mapped as a different language.
The following steps demonstrate CIMPLICITY language mapping configuration and runtime use.
Step 1 (page 63)

Review alarm messages that are
available for translation.

Step 2 (page 68)

Make CimEdit text available for
translation.

Step 3 (page 86)

Translate keys into other languages
or English strings.

Step 4 (page 95)

Work with keys in the CIMPLICITY
Language Mapper.

Step 5 (page 100)

Print a translation file configuration.

Step 6 (page 102)

Configure translation options for
runtime.

CIMPLICITY Language Mapper Window Overview
The CIMPLICITY Language Mapper window is the central location for viewing the translation
files and is where you translate the keys (selected strings) in the translation files. It also offers other
administrative tools for maintaining the files.
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1

Title bar displays the active translation file name.

2

Menu bar

3

Toolbar

4

Status bar

5

Primary strings that are available for translation

6

Translated strings

Step 1. Review Alarm Messages that are Available for
Translation
Step 1. Review Alarm Messages and Strings that are Available for
Translation
The CIMPLICITY Language Mapper automatically makes all of a project's alarm messages available
for translation.
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Step 1.1
(page
64)

Open the CIMPLICITY Language Mapper Window to View Existing Alarms

Step 1.2
(page
66)

Make new point alarms available for translation.

Step 1.3
(page
67)

Make a new alarm string available for translation

Step 1.1. Open the CIMPLICITY Language Mapper Window
• Open the CIMPLICITY Language Mapper window.
• CIMPLICITY Language Mapper window just opened.

Open the CIMPLICITY Language Mapper window
1. Select Project > Alarms > Alarm Translator in the Workbench left pane.
2. Select Alarm Translator in the Workbench right pane.
3. Do any of the following:

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm Translator.
b. Select Properties on the Popup menu.

D

In the Workbench right pane, double-click Alarm Translator.
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E

Press Alt+Enter on the keyboard.

CIMPLICITY Language Mapper window just opened
The CIMPLICITY Language Mapper window opens displaying the project's default file,
AlarmTranslation.clm.

The following are automatically entered as keys in AlarmTranslation.clm:

A
(page
66)

Point alarm messages

B

System alarm messages

C
(page
67)

Alarm strings
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Note: The alarm manager uses %s to substitute strings into the alarm message. This is changed
in a key to %1, %2, … %n so that a fixed order of substitution parameters can be passed but the
actual order they appear in the message can be dictated by the location of the substitution.
This allows for different orders that are dependant on the needs for a specific language.
CAUTION: Do not change the name or location of the AlarmTranslation.clm file. If you do,
before it is restored, the CIMPLICITY Language Mapper will not be able to find the translations.
The next time you open the CIMPLICITY Language Mapper window, a new AlarmTranslation.clm
will be automatically created and your translation configuration will be lost.

Step 1.2. Make New Point Alarm Messages Available for Translation
Point alarm messages that were created after the last project configuration update will be
automatically entered into the AlarmTranslation.clm file when the next project configuration update
is performed.
1. Create a new point or select an existing point that does not have an alarm.
2. Open the Point Properties dialog box.
3. Select the Alarm tab.
4. Enter an alarm message and configure the alarm.

5. Close the Point Properties dialog box.
6. Make sure project configuration is updated.
7. Open the CIMPLICITY Language Mapper window.
The default AlarmTranslation.clm file is loaded.
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The message you entered in the Alarm message field in the Point Properties dialog box displays in

the Key list.

Step 1.3. Make a New Alarm String Available for Translation
Alarm strings that were created after the last project configuration update will be automatically
entered into the AlarmTranslation.clm file when the next project configuration update is performed.
1. Create a new alarm string set (page 42).

2. Perform a project configuration update.
3. Open the CIMPLICITY Language Mapper window.
The default AlarmTranslation.clm file is loaded.
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The string values you entered in the String values fields in the Alarm String Index dialog box

displays in the Key list.

Step 2. Make CimEdit Text Available for Translation
Step 2. Make CimEdit Text Available for Translation
You add text to CimEdit translation files differently from how text is added to Alarm translation
files.
Alarm messages are automatically entered into an automatically created translation file.
First, CimEdit text needs to be selected; second a translation file has to be created or opened through
the Ambient Properties tab in the Properties - Screen dialog box for the text to be entered into the
file.
This step shows the logical sequence for selecting the text, then adding it to a translation file.
Step 2.1
(page
68)

Select text strings on CimEdit Screens.

Step 2.2
(page
80)

Automatically enter CimEdit text strings into a translation file.

Step 2.1. Select Text Strings on CimEdit Screens
Step 2.1. Select Text Strings on CimEdit Screens
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Important: When you design your CimEdit screen make sure that you allow enough space to
accommodate all selected languages for each text string.
For example, a message that will display is TANK LEVEL IS TOO HIGH.
Space required for different languages varies, as follows:
Language

Text String

Screen Original

TANK LEVEL IS TOO HIGH

French

LE NIVEAU DE RÉSERVOIR EST TROP ÉLEVÉ

Chinese

#######

Japanese

############

TANK_S

TANK_S LEVEL IS TOO HIGH

Text string translation options are as follows.
Option
2.1.1 (page
69)

Plain text

Option
2.1.2 (page
72)

Text buttons

Option
2.1.3 (page
74)

Animated text

Option
2.1.4 (page
75)

Expressions

Option
2.1.5 (page
77)

Execution condition messages

Option
2.1.6 (page
78)

Advanced procedure messages

Option
2.1.7 (page
79)

Popup menu items

Option 2.1.1. Plain Text Available for Translation
1. Place or select a text object that is on a CimEdit screen.
2. Open the text's Properties - Object dialog box.
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3. Select the Text tab.
The following options make the text on the button available for translation.

rect 67, 103, 91, 126 (page 71)
rect 67, 63, 91, 84 (page 70)
rect 67, 83, 91, 103 (page 71)
rect 67, 18, 91, 39 (page 70)
A
(page
70)

String

B
(page
70)

Font

C
(page
71)

Translate

D
(page
71)

Multiline

A

String

Text that will display on the CimView screen and can be translated into selected languages.
B

Font

Opens the Font dialog box to select the font, style and size for this string in the CimEdit/
CimView screen.
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Important: Select a font that will accommodate the characters for the translated languages.
For example, Arial Unicode MS is a very complete Unicode font.
C

Translate

Checked makes this string available for translation.
Default
D

Checked

Multiline

Multiline is checked by default when you create a new text entry.
Options are:
Clear Multiline
Enter text in the String field.
Check Multiline
Do the following.

1

Click the Text Box button to the right of the String field.

2

Enter the text in the Text Box.

4. Click Apply or OK.
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Note: If you want to emit this text selection (or selections) to a CimEdit translation file
before you make other text selections, go to Step 2.2. Otherwise, continue with the Step 2.1
options.

The text string is available to be emitted to the translation file (page 82).

Option 2.1.2. Text Buttons Available for Translation
1. Place or select a text button object that is on a CimEdit screen.
2. Open the text's Properties - Object dialog box.
3. Select Text Button.
The following options make the text on the button available for translation.

rect 150, 65, 173, 81 (page 73)
rect 231, 45, 254, 67 (page 73)
rect 149, 45, 172, 61 (page 73)
rect 64, 43, 87, 65 (page 73)
rect 63, 19, 86, 41 (page 73)
A
(page
73)

String

B
(page
73)

Font

C
(page
73)

Auto size
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D
(page
73)

Translate

E
(page
73)

Multiline

A

String

String that will be available for translation
B

Font

Opens the Font dialog box and select the font, style and size for this string in the CimEdit/
CimView screen.

Note: Select a font that will accommodate the characters for the translated languages. For
example, Arial Unicode MS is a very complete Unicode font.
C

Auto size

It is recommended that you leave Auto size clear.
When checked, the button automatically resizes to fit the text length.
This can create a jagged affect if different languages are used on the CimView screen.
Give the button an exact length that will be able to fit the characters for any of the selected
languages.
D

Translate

Checked makes the text string available for translation.
Default
E

Checked

Multiline
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Multiline is checked by default when you create a new text entry.
Options are:
Clear Multiline
Enter text in the String field.
Check Multiline
Do the following.

1

Click the Text Box button to the right of the String field.

2

Enter the text in the Text Box.

The text entered as the button label is available to be emitted to the selected translation file (page
82).

Option 2.1.3. Animated Text Available for Translation
1. Create or select a text object; the object will display animated text during runtime.
2. Open the Properties - Object dialog box.
3. Open the Expression List Attribute Animation dialog box.
The following options make animated text available for translation.
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Option
Text

Description
Translate
String

Font

Selections are
• Font
• Type
• Size
Note: If you make the text available for translation
make sure that the selected font accommodates
the languages in which the string will display. Arial
UNICODE MS can display all languages.

Note: If you want to omit this text selection (or selections) to a CimEdit translation file
before you make other text selections, go to Step 2.2. Otherwise, continue with the Step 2.1
options.

The text that is checked for translation is available to be emitted to the selected translation file. The
text for each expression will display on a single line in the translation file (page 82).

Option 2.1.4. Expressions Available for Translation
Option 2.1.4. Expressions Available for Translation
Option 2.1.4.1
(page 76)

Expression literals

Option 2.1.4.2
(page 76)

Enumeration point values
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Option 2.1.4.1. Expression Literals
1. Place or select a text or text button object that is on a CimEdit screen.
2. Open the text's Properties - Object dialog box.
3. Select one the following depending on the selected object.
Option

Tab

Text

Text

Text button

Text button

4. Enter an expression that contains string literals in the Expression field.
Example
IF (TANKLEVEL GT 55000) Then "CLOSE Valve In. CALL MANAGER." Else "If
alarm state, call manager."

5. Check Translate result value.
Note: The default is clear.

The text strings are available to be emitted to the selected translation file. Each string, surrounded by
double-quotes, will be placed on a single line in the translation file (page 82).
Option 2.1.4.2. Enumeration Point Values
When you emit text (page 80) for a CimEdit screen all values that have been configured for point
enumerationare automatically entered in the selected translation file.
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Example
An enumeration set named FLOW is configured to be available for selected pipe points.
Text values are:

• PIPE: OPEN
• PIPE: OPEN 3/4
• PIPE: MAINTAIN
• PIPE: CLOSE TO 1/4
• PIPE: CLOSE
When text is emitted to a selected translation file (page 82) the FLOW text values are emitted to
that file.

Option 2.1.5. Execution Condition Messages
Open an Execution Condition dialog box for a:
• Text/text button object
• Slider action
The following options make an execution condition text message available for translation.
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A

Message

String that will be available for translation.

B

Translate message

Checked makes the text string available for translation.

The text entered as the execution condition message is available to be emitted to the selected
translation file (page 82).

Option 2.1.6. Advanced Procedure Messages Available for Translation
1. Select the screen or any object that is on a CimEdit screen.
2. Open the screen or object's Properties dialog box.
3. Select Procedures.
4. Open the Procedure Information dialog box for an existing or new procedure.
5. Select the Advanced tab.
6. Check the accompanying Translate… checkbox for text message entries that should be
available for translation, as follows.
Note: The default is checked.

Field

Check

A

Success

Translate success message

B

Failure

Translate failure message
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Field

Check

C

Message

Translate message

D

Execution condition

The text strings that are entered in checked message fields is available to be emitted to the translation
file. Each message will display on a single line in the translation file (page 82).

Option 2.1.7. Popup Menu Items Available for Translation
These items are available for translation:
• Standard Popup menu items
• Customized Popup menu items
Standard Popup Menu Items
CimEdit automatically sends standard Popup menu items to the translation file when text is emitted.
Items include:
• Full Screen
• Help
• Menu
• Properties
• Point View
• Point Control Panel
• Quick Trends
Customized Popup Menu Items
1. Select the screen or any object that is on a CimEdit screen.
2. Open the screen or object's Properties dialog box.
3. Select Menu.
The following options make the text on the Popup menu available for translation:
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A

String that will be available for translation.

B

Checked makes the text string available
for translation.

The text string that is entered in the Menu text field is available to be emitted to the translation file
(page 82).

Step 2.2. Automatically Enter CimEdit Text Strings into a Map File
Step 2.2. Automatically Enter CimEdit Text Strings into a Translation File
Step 2.2.1
(page
80)

Emit text into a new file.

Step 2.2.2
(page
83)

Emit text into an existing file.

Step 2.2.1. Emit Text into a New File
Follow this procedure if you are starting a Language Mapping file for your CimEdit screens or want
to create a file exclusively for the screen you are working on.
1. Right-click the CimEdit screen to open the Properties- Screen dialog box.
2. Select the Ambient Properties tab.
3. Do the following:
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rect 249, 120, 267, 141 (page 81)
rect 293, 98, 319, 119 (page 81)
A

Map File

Enter the path and name of a new file that you want to have created.
Tip: The Browser button to the right of the Map File field will help you specify the name
and exact location.
a. Click the Browser button to the right of the Map File field.
A Pick a CIMPLICITY Language Map file browser opens.
b. Find the folder in which the file should be created.
c. Enter the filename in the File name field.
d. Click Open.

B

Emit Text

Click Emit Text.
Result:
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a. CIMPLICITY Language Mapper creates the specified translation <filename>.clm in the

selected location.
b. CIMPLICITY Language Mapper exports the selected CimEdit text into the selected

translation file.
1
(page
69)

Plain text
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2
(page
72)

Text buttons

3
(page
74)

Animated text

4
(page
75)

Expressions

5
(page
77)

Execution condition messages

6
(page
78)

Advanced procedure messages

7
(page
79)

Popup menu items

Tip: If you have several screens with unique static text performance may be improved
if you use several translation files among your screens instead of just one.

Step 2.2.2. Emit Text into an Existing File
Use this procedure if you want to continue working in an existing translation file in order to share it
with two or more of your CimEdit screens.
This enables sharing of common strings and makes translation for all screens the easiest to maintain.
1. Right-click the CimEdit screen to open the Properties- Screen dialog box.
2. Select Ambient Properties.
3. Do one of the following:

• Type in path and translation filename
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A

Enter the path and name of an existing file in the Map File field.

B

Click Emit Text.

• Find and select a translation file

a. Click the Browser button to the right of the Map File field.
A Pick a CIMPLICITY Language Map file browser opens.
b. Select the file you want to use.
c. Click Open.

The select path and name display in the Map File field.
d. Click Emit Text.
• Emit text without entering a path

a. Click Emit Text without entering a path and name in the Map File field.
Pick a CIMPLICITY Language Map file when the browser opens.
b. Select the file you want to use.
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The select path and name display in the Map File field.
c. Click Emit Text.
The text strings on the CimEdit screen that are checked for translation are created as keys in the
selected translation file.
If the key is already in the file, it is not overwritten. This is particularly important because the
existing key may already have associated translated strings.

A

New keys from text strings in current CimEdit screen that are not already in the translation file.

B

Keys from text strings from a previous CimEdit screen, already translated.

Note:
• You can select the default AlarmTranslation.clm. However, if you anticipate that there will be
several strings, or unique strings it may be more efficient to use a different translation file for
your CimEdit/CimView screens. If you create an AMV Control on a CImEdit/CimView screen,
you can copy strings, such as headings, buttons, from other CimEdit screens. You can also copy
keys and translations from one translation file to another.
• If the source screen for a linked object has a translation file configured it will use that file at
runtime, instead of the file defined in the destination screen. If both screens use the same file,
this is not an issue.
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Step 3. Translate Keys into other Languages or other
English Strings
Step 3. Translate Keys into other Languages or other English Strings
Step 3.1
(page
86)

Open the CIMPLICITY Language Mapper window.

Step 3.2
(page
87)

Select a translation file.

Step 3.3
(page
90)

Select a font.

Step 3.4
(page
91)

Select languages or other English strings.

Step 3.5
(page
93)

Translate keys that should display in selected languages.

Important: Alarm messages are loaded only when the Alarm Manager Resident Process
(AMRP) starts. Therefore any configuration changes, e.g. a new translation, made after the AMRP
start up will not show up in the Alarm Viewer. You will have to stop the AMRP and restart it for
changes to take affect.

Step 3.1. Open the CIMPLICITY Language Mapper Window
Do one of the following:
• Open the CIMPLICITY Language Mapper Window through the Workbench (page 64).
This method automatically opens the default AlarmTranslation.clm file.
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• Click Edit File on the Ambient Properties tab in CimEdit's Properties - Screen dialog box.
This method will open a selected *.clm file.

Step 3.2. Select a Translation File
Do any of the following:
• Use the default translation file.
• Create a new file.
• Open an existing translation file.
• Save the open file as another file.
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Use the default translation file
When you open the CIMPLICITY Language Mapper window, the default translation file,
alarmtranslation.clm, is loaded.

The file is available for editing translation keys and specifications.
Create a new file
Do one of the following.
• Click the New button
on the CIMPLICITY Language Mapper window toolbar.
• Click File>New on the CIMPLICITY Language Mapper window menu

bar.
Result: A new untitled file opens ready for translation configuration.
Important: If you are configuring a host redundant system, make sure the file is located in the
same place on both computers or use a static path for the filename.
If you do not do this and the directory structures are not the same on both computers, the translation
file will not be found by CimView.
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Open an existing translation file
1. Do one of the follwing.
• Click the Open button
on the CIMPLICITY Language Mapper window toolbar.
• Click File>Open on the CIMPLICITY Language Mapper window menu bar.
An Open dialog box opens.
2. Select the *.clm file that you want to open.
3. Click Open.

The selected file displays in the CIMPLICITY Language Mapper window.
Save the open file as another file
1. Open the file you want to save as another file.
2. Click File>Save as on the CIMPLICITY Language Mapper window menu bar.
A Save as dialog box opens.
3. Enter a file name in the folder where you want the file to be located.

4. Click the Save button.
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The CIMPLICITY Language Mapper window displays the new saved as

file.

Step 3.3. Select a Font
1. Click Edit>Select Font on the CIMPLICITY Language Mapper window menu bar.

The Font dialog box opens.
2. Select a font that will accommodate all of the languages you plan to use.
Important: If you select a font that cannot be used in a language you select, the words will
not display correctly.
Any UNICODE font, e.g. Arial UNICODE MS, can be used for all languages.
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Arial UNICODE MS font selected

A

English keys.

B

Romance languages display correctly.

C

Multi-byte Asian languages display correctly.

Times New Roman font selected

A

English keys.

B

Romance languages display correctly.

C

Multi-byte Asian languages do not display.

Step 3.4. Select Languages or other English Strings
1. Click Translations>Language Editor... on the CIMPLICITY Language Mapper window menu
bar.
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The Language Editor window opens.

2. Click Add.
The Add Language dialog box opens.
3. Make entries as follows.

A

Language

Enter a label that identifies the selected locale.

B

Local ID

Select the language/dialect that the label identifies in the drop-down list.

4. Click OK.
Your selection displays in the Language Editor list.
5. Repeat the procedure until all of the required languages are listed.
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6. Click Done.
The Language Editor window closes. The selected locales head columns in the CIMPLICITY
Language Mapper window and are available for translation.

Step 3.5. Translate Keys that should Display in Selected Languages
1. Do one of the following:
• Double-click a key.
• Click Translations > Translation Editor... on the CIMPLICITY Language Mapper menu

bar.
The Translation Editor window opens for the selected key.
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Selected languages (page 91) are available for translation.
2. Double-click a language.
A Translated Text Editor dialog box opens for the selected language.
3. Enter the string that you want to display when the text should display in the selected language.
Note:
• The text may display on a CimEdit/CimView screen or in the Alarm Viewer.
• The Text Editor accepts multi-line entries.

4. Click OK.
5. Repeat the procedure for all the languages you want to include in the translation.
The translated strings display in the Translation Editor window.

6. Close the Translation Editor window.
7. Continue translating all of the strings that should by displayed in multiple languages.
The strings display in the language columns in the CIMPLICITY Language Mapper window.
At runtime, when the translation file is used, the string entered for the selected runtime language
displays.
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Step 4. Work with Keys in a Translation File
Step 4. Work with Keys in a Translation File
Option
4.1 (page
95)

Add a new key manually.

Option
4.2 (page
96)

Copy and paste keys.

Option
4.3 (page
98)

Delete keys.

Option 4.1. Add a New Key Manually to a Translation File
1. Click Translations > Add New Key... on the CIMPLICITY Language Mapper window menu
bar.

The New Key dialog box opens.
2. Enter a key that you will want to translate.

Note:
• This key can be used for alarms and on CimEdit/CimView screens.
• The key can be multi-line.
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3. Click OK.
The key is added to the file that is open in the CIMPLICITY Language Mapper window.

Option 4.2. Copy and Paste Keys in a Translation File
Option 4.2. Copy and Paste Keys in a Translation File
Option
4.2.1 (page
96)

Copy and paste a key from another translation file.

Option
4.2.2 (page
97)

Copy and paste a key in the same translation file

Important: You can paste copied keys to a mapper file opened in a CIMPLICTY Language
Mapper window. However, pasting keys into a different program, e.g. Notepad, is not supported.

Option 4.2.1. Copy and Paste a Key from another Translation File
1. Open the key's source file.
2. Select one or more keys.
Note: Hold down Shift for adjacent keys and Ctrl for scattered

keys.
3. Do one of the following.
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• Click the Copy button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Copy on the CIMPLICITY Language Mapper window menu bar.
• Press Ctrl+C on the keyboard.
4. Open the key's target file.

5. Do one of the following:
• Click the Paste button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Paste on the CIMPLICITY Language Mapper window menu bar.
• Press Ctrl+V on the keyboard.
The key with any associated translations is pasted into the target file.

Option 4.2.2. Copy and Paste a Key in the Same Translation File
1. Select a key that you want to copy and paste.

2. Do one of the following:
• Click the Copy button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Copy on the CIMPLICITY Language Mapper window menu bar.
• Press Ctrl+C on the keyboard.
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3. Do one of the following:
• Click the Paste button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Paste on the CIMPLICITY Language Mapper window menu bar.
• Press Ctrl+V on the keyboard.
The key with associated translations is pasted into the list with an _n tag to differentiate it from the
copied key. You can copy and paste as many times as you want. The _n value corresponds to the
key's position in the copy/paste sequence.

Option 4.3. Delete a Key in a Translation File
1. Open the key's source file.
2. Select one or more keys to delete (use the Ctrl or Shift keys to select more than one line).

3. Do one of the following:
Cut the selected lines
a. Either:
• Click the Cut button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Cut on the CIMPLICITY Language Mapper window menu bar.
A message displays asking you to confirm if you want to delete the file.
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b. Click Yes.

1

The selections are cut from the file.

2

If you change your mind you can paste them back.

Method 2: Delete the selected lines
a. Either:
• Click the Delete button
on the CIMPLICITY Language Mapper window toolbar.
• Click Edit>Delete on the CIMPLICITY Language Mapper window menu bar.
A message displays asking you to confirm if you want to delete the file.

b. Click Yes.
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1

The selections are deleted from the file.

2

You cannot paste them back.

4. Save the translation file.
The selected keys are deleted.

Step 5. Print a Translation File Configuration
Step 5. Print a Translation File Configuration
Step 5.1
(page
100)

Preview the printed file.

Step 5.2
(page
102)

Print the translation file configuration.

Step 5.1. Preview the Printed File
1. Click File>Print Preview on the CIMPLICITY Language Mapper window menu bar.
A preview of the printed document opens in a Print Preview window.
Note: The preview will display either one or two pages, depending on the display the last
time the Print Preview window was closed.
2. The Print Preview window is as follows.
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A

Title bar

Displays the translation file that is being previewed.

B

Toolbar

Print the document.

Print
Next Page

Enabled when there is a next page to display.

Previous Page

Enabled when there is a previous page to display.

One Page/Two
Page

One Page displays during a two-page display; two page displays during a one-page
display.

Zoom In

Magnifies the preview to make the text legible; has a two-click magnification.

Zoom Out

Returns the preview to display the entire page in the window.

Close

Closes the Print Preview window.

C

Two-page display in Print Preview window.

D

Print preview zoomed in; The key displays with the translated strings listed underneath.

3. Close the window when you have finished using it.
Note: If you need to change the printer setup, e.g. your setup is set to landscape orientation
and you want portrait, close the Print Preview window and click File>Print Setup on the
CIMPLICITY Language Mapper window menu bar.
The Print Setup dialog box will open for setup changes.
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Step 5.2. Print the Translation File Configuration
1. Click File>Print on the CIMPLICITY Language Mapper window menu bar.
The Print dialog box opens.
2. Optional: Make any changes to the print setup.
3. Print the document.
4. Close the Print dialog box.

Step 6. Configure Translation Options for Runtime
Step 6. Configure Translation Options for Runtime
Step 6.1
(page
102)

Configure translation options for CimView users.

Step 6.2
(page
106)

Configure for Alarm Viewer control use.

Step 6.1. Configure Translation Options for CimView Users
Step 6.1. Configure Translation Options for CimView Users
The CIMPLICITY Language Mapper provides you with an Object Model. You can use the objects,
properties and methods to create scripts that determine translation options.
A simple way to enable CimView users to change languages or English text strings during runtime is
to create a button for each language you want to substitute.
Step 6.1.1
(page
102)

Configure buttons to change languages or English strings.

Step 6.1.2
(page
104)

Test your translations in CimView.

Step 6.1.1. Configure Buttons to Change Languages or English Strings

Alarms and Messages | 6 - CIMPLICITY Language Mapper | 103

1. Open a CimEdit screen that has been configured for translation.
2. Place a button on the screen.

3. Open the button's Properties - Object dialog box.
4. Label the button (page 72) to notify a user what language or English string the CimView
text will change to.
Note: Check Translate if you want the button label to be emitted to the translation file.

5. Create a MouseUp event:
a. Select the Events tab.
b. Select a MouseUp event.
c. Click the Popup button to the right of the Action field to open an Edit Script window.
d. Create a new script as the action for the mouse up event as follows.
Sub OnMouseUp(x As Long, y As Long, flags As Long)
CimGetScreen.Application.Language = "String Description"
End Sub
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Where
The "String Description" is the selected language, entered exactly as it is identified in
the CIMPLICITY Language Mapper window.
If the entry is not exactly the same, the default language will display instead of the selected
language.

e. Compile the script and close the Edit Script window.
6. Close the text button's Properties dialog box.
7. Continue to create buttons until you have created as many as the screen should have.
Tip: If you are configuring a screen with buttons to change languages, add a button that
enables the operator to re-select the default language after another language is selected.
Example
If English is the default language, add an English button. You do not need to create a column in
the translation file. If there is no entry, the default language displays.
8. Optional: Emit the text labels (page 80) on the text buttons and translate them in the
translation file selected for the screen.

Step 6.1.2. Test your Screen Translations in CimView
Click the Runtime button

on the CimEdit toolbar.

Alarms and Messages | 6 - CIMPLICITY Language Mapper | 105

Results
• The CimView screen displays in the default language.

• Entries in the CIMPLICITY Language Mapper display for a language display when its button is
clicked.
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• Alternative text in the CIMPLICITY Language Mapper for the default or any language,
displays when its button is clicked.

• Popup menu items display in the selected language when the Popup is opened, if they have been
translated in the CIMPLICITY Language Mapper.

Step 6.2. Configure an Alarm Viewer Control for Translation
Step 6.2. Configure an Alarm Viewer Control for Translation
The CIMPLICITY Language Mapper provides you with an Object Model. You can use the objects,
properties and methods to create scripts that determine translation options.
For example, a simple way to enable Alarm Viewer Control users to change languages or English
text strings during runtime is to create a button for each language you want to substitute.
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Step 6.2.1
(page
107)

Configure an Alarm Viewer control for translation.

Step 6.2.2
(page
108)

Test your Alarm Viewer Control translations in CimView.

Step 6.2.1. Configure an Alarm Viewer Control
1. Configure an Alarm Viewer Control on a CimEdit screen.
Configuration guidelines include:
• Verifying that you make fields, such as Message fields wide enough to accommodate the
languages to display in the Alarm Viewer control.
• Selecting a font that will accommodate the selected languages.
A UNICODE font can be used for any language.
2. Do one of the following to place buttons on the screen that will enable users to select another
language or text string:
If you configured buttons you need for another CimEdit screen
Copy the buttons to this screen or place them as linked objects.
If you need to create new buttons
Follow the procedure described in the previous step (page 102) .

3. Do one of the following to make sure the button labels and other text strings that should be
translated are translated:
If you are sharing a translation file that already has the translations
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You do not have to do anything.
If you are using a translation file that does not have the keys and translations
a. Emit (page 80) the text to the file.
b. Enter the translations (page 93).
You are now ready to test your screen during runtime.

Step 6.2.2. Test you Alarm Viewer Control Translations in CimView
on the CimEdit toolbar.
1. Click the Runtime button
The Alarm Viewer control opens in the default language.

2. Click language buttons to view the text changes, based on text that is translated in CimEdit's
selected translation file.
Click a foreign language button.
The text that is translated in the CIMPLICITY Language Mapper replaces the text that currently
displays on the screen.
Examples
Japanese translation
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French translation

Chapter 7. Historical Alarm Viewer Control
About the Historical Alarm Viewer Control
The Historical Alarm Viewer enables a user to view either Database Logger or Historian historical
data.
During a session, a user can:
• Review logged alarm data through CimView in an easy-to-read table format and
• Print one or more pages of the display at any time during a session.
The user will view logged data that passes specifications including filters, time frames and several
condition types.
You, an applications engineer, can simply place the control on a CimEdit screen and follow the next
steps to customize it.
Important: Viewers displaying a Historical Alarm Viewer that is pulling logged point and/or
alarm data from the SQL Server must have the same SQL driver version installed that is being used
on the CIMPLICITY Server. If the SQL driver is a different version the data will not display.

Historical Alarm Viewer Control Configuration
Historical Alarm Viewer Control Configuration
Step Number

Description

Step 1 (page
111)

Place an Historical Alarm Viewer (HAV) control on a CimEdit screen.

Step 2 (page
114)

Open the CIMPLICITY Historical Alarm Viewer Properties dialog box.

Step 3 (page
114)

Enter general specifications for the HAV control.

Step 4 (page
117)

Configure connection options for the CIMPLICITY Historical Alarm Viewer.

Step 5 (page
120)

Configure the SQL display.
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Step Number

Description

Step 6 (page
130)

Select column justification.

Step 7 (page
131)

Configure row styles.

Step 8 (page
137)

Specify runtime configuration capability.

CIMPLICITY Configuration Object Model and DCOM
When off-node projects are selected on the Connection tab, requests are made to determine which
tables the remote project has available by using the CIMPLICITY configuration Object Model
(CimServer).
CimServer uses DCOM based communications architecture. Therefore, it may be necessary to

ensure that DCOM is properly configured on the project’s node to allow access to the Object Model.
DCOM configuration and Windows security are complex technical topics and beyond the scope of
this document. For an introduction to DCOM security configuration, see Configuring the GagePort
Mitutoyo OPC server DCOM (About DCOM Security) in the CIMPLICITY documentation. For
more advanced DCOM configuration issues, please refer to Microsoft documentation.

Step 1. Place an Historical Alarm Viewer Control on a CimEdit Screen
Step 1. Place an Historical Alarm Viewer Control on a CimEdit Screen
Tasks to place an Historical Alarm Viewer Control on a CimEdit screen include:
Step 1.1
(page
111)

Insert an Historical Alarm Viewer Control on a CimEdit Screen

Step 1.2
(page
113)

Resize a New Alarm Viewer OCX Control.

Important: Put CimEdit in 100% zoom mode before you begin configuring or editing the
Historical Alarm Viewer control.

Step 1.1. Insert an HAV Control on a CimEdit Screen
Use the following buttons to insert an Historical Alarm Viewer control on a CimEdit screen:
• Historical Alarm Viewer button
• OLE button
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OLE Button
Historical Alarm Viewer Button
Click Historical Alarm Viewer in the Drawing>Objects group on the CimEdit Ribbon bar.

A Historical Alarm Viewer control is placed on the CimEdit screen. The top left corner is located at
the top left corner of the screen.
OLE Button
1. Click OLE in the Drawing>Objects group on the CimEdit Ribbon bar.

2. An ActiveX Placement cursor displays on the CimEdit screen.

3. Place the ActiveX Placement cursor where you want the top left corner of the control to be
located.
4. An Insert Object dialog box opens.

5. Double-click the CIMPLICITY Trend Control.
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A new Historical Alarm Viewer control is placed on your CimEdit

screen.

Step 1.2. Resize the Historical Alarm Viewer Control
You can perform a quick resize or a precise resize to resize the Historical Alarm Viewer Control.
Quick Resize Procedures
Grab one of the object's handles and move it to enlarge or reduce the HAV Control.
Precise Resize Procedure
1. Select the Historic Alarm Viewer control.
2. Do one of the following.
• Right-click the Historical Alarm Viewer Control; select Properties on the Popup menu.
• Click the Properties in the Home>Properties group on the CimEdit menu bar.
The Properties - Object dialog box opens.
3. Select Geometry.
4. Enter the following:
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Field

Enter

Top

Number of points starting from the bottom of the screen where the HAV Control top is located.

Width

Width of the object in points.

Left

Number of points starting from the left of the screen where the left side of the HAV Control is located.

Height

Height of the object in points.

The Historical Alarm Viewer Control enlarges/ reduces and moves to the size you specify.
Note: Hold the right-button down and drag the object to where you want it positioned on the
CimEdit/CimView screen.

Step 2. Open the CIMPLICITY Historical Alarm Viewer Properties
Dialog Box
1. Select the Historical Alarm Viewer control.
2. Do one of the following:
• Click the right-mouse button, and then select CIMPLICITY Historical Alarm Viewer
Object > Properties on the Popup menu.
• Click Edit > CIMPLICITY Historical Alarm Viewer Object > Properties on the
CimEdit menu bar.
• Press Alt+E+O+R on the keyboard.
The CIMPLICITY Historical Alarm Viewer Properties dialog box opens when you use any

method.

Step 3. Enter General Specifications for the HAV
Enter and select the following on the General tab in the CIMPLICITY Historical Alarm Viewer
Properties dialog box.
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rect 0, 49, 366, 93 (page 115)
rect 1, 91, 157, 122 (page 115)
rect 1, 120, 157, 145 (page 115)
rect 0, 143, 156, 168 (page 116)
1
(page
115)

Caption.

2
(page
115)

Use ambient properties.

3
(page
115)

Show toolbar.

4
(page
116)

Show Date/Time Pickers.

5
(page
116)

Font guideline.

1

Caption

The caption is a title that will identify the control during runtime.
Note: If the caption includes an ampersand, Windows will not display the ampersand. Use a
double ampersand to get a single ampersand to display. && will display as & in the runtime title.
2

Use Ambient Properties

Check Use Ambient Properties to use the CimEdit ambient properties for the Historical Alarm
Viewer.
3

Show Toolbar

Check Show Toolbar to display the following toolbar during runtime.
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A

Sort a selected column in ascending order.

B

Sort a selected column in descending order.

C

Add a filter to the view based on a selected cell.

D

Remove the additional filters.

Note: Filters applied during runtime are in addition to any filters configured on the SQL tab
in the CIMPLICITY Historical Alarm Viewer Properties dialog box. The UF button removes the
runtime filters only.
4

Show Date/Time Pickers

Check Show Date/Time Pickers to display a Start Date-Time and End Date-Time.
A user can select the starting and ending time of the logged data that the CIMPLICITY Historical
Alarm Viewer will display.
If the user clicks the down arrow to the right of each field a calendar will open to aid in making the

selection.
Note: You can specify the amount of time the Historical Alarm Viewer will display at one time.
This specification is on the SQL tab in the CIMPLICITY Historical Alarm Viewer Properties dialog
box.
The runtime Historical Alarm Viewer control will display the options that you selected and
configured.
5

Font Guideline

If an alarm message that needs to use non-Western characters (e.g. Cyrillic, Chinese) displays ????
instead of the message, the following procedure may correct the issue.
1. Right-click the Historical Alarm Viewer control.
2. Select Properties on the Popup menu.
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The Properties - Object dialog box opens.
3. Select Control Properties.
4. Click the Open button to the right of the Font field.
The Font dialog box opens.
5. Select a font that includes the characters for the required language.
6. Select the language in the script drop-down list.
7. Close the Font dialog box.
8. Close the Properties - Object dialog box.
Note: If this procedure does not resolve the issue, other factors might be affecting font display
on your system. Consult Microsoft documentation also.
This procedure applies to values/text from SQL Server. Cyrillic and other non-western characters are
not available for data from Historian.

Step 4. Configure Connection Options for the CIMPLICITY Historical
Alarm Viewer
The Connection tab in the Historical Alarm Viewer Properties dialog box provides several
connection selections. The selections you make on this tab determine what fields you can select to
display during runtime.
Enter and select the following on the Connection tab in the CIMPLICITY Historical Alarm Viewer
Properties dialog box.
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1
(page
118)

CIMPLICITY Project to connect to.

2
(page
118)

Connection String.

3
(page
118)

Table to View.

4
(page
120)

Refresh Rate

1

CIMPLICITY Project to connect to

Options include:
<none>

A Connection String (page 118) field displays in the dialog box for you to specify the connection.

<default
historian>

Display data logged to Historian.

<local>

Selects the local project in which the HAV is configured. The HAV displays all of the data from that project's
Historian server, not just the data logged from the selected project.

Project
name

Enables you to select any project running in the network, including any projects running on the local
computer. The HAV displays all of the data from the selected project's Historian server, not just the data
logged from the selected project.”

2

Connection String

A Connection String field displays when <none> is selected in the CIMPLICITY Project to
connect to field.
Click the button
to the right of the Connection String field to open a Data Link Properties dialog
box and configure the connection.
Important: When you select this option the password will display in the field; any user who has
access to the Historical Alarm Viewer control configuration will know what the password is.
Choosing other options sets the data link properties, but hides the information.
3

Table to View

Options depend on
• Which of the following or if both are enabled.
◦ Database Logger
◦ Historian
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• The value you selected in the CIMPLICITY Project to connect to field.
Options include the following.
Enabled
Database
Logger only

Options
<none>

<default
historian>

<local>

Selections
Based on connection string.

Note: Table to View options are available for a default Historian (page 119)
connection even if Historian is not enabled. However, The Historical Alarm Viewer will not
display data until the Historian is enabled.
ALARM_LOG
DATA_LOG
EM_LOG
EVENT_LOG

<Project
name>

ALARM_LOG
DATA_LOG
EM_LOG
EVENT_LOG

Historian
only

<none>

Based on connection string.

<default
historian>

IhAlarms
ihArchives
ihCalculationDependencies
ihCollectors
ihComments
ihMessages
ihQuerySettings
ihRawData
ihTags
ihTrend

<local>

Historian Alarms
Historian Data
Note: ALARM_LOG is also listed. If you select it a message will report that is cannot
be found. You can select it; however, the Historical Alarm Viewer will not display data until
the Database Logger is enable.
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Enabled

Options
<Project
name>

Selections
Historian Alarms
Historian Data
Note: ALARM_LOG is also listed. If you select it a message will report that is cannot
be found. You can select it; however, the Historical Alarm Viewer will not display data until
the Database Logger is enable.

Database
Logger and
Historian
4

All of the above options are available when both the Database Logger and Historian are enabled in the
Project Properties dialog box.

Refresh Rate

How frequently the screen should refresh.
The rate is in seconds.
Example
Enter

The screen:

0

Never refreshes.

5

Refreshes every 5 seconds

10

Refreshes every 10 seconds.

Step 5. Configure the SQL Display
Step 5. Configure the SQL Display
Once you have selected the connection the Historical Alarm Viewer will make, you can more
specifically select what data will be displayed.
1. Select the SQL tab.
2. Enter specifications that determine what data will be displayed and highlighted.
Steps to configure the SQL display include:
Step 5.1
(page
121)

Make general specifications.

Step 5.2
(page
122)

Select the fields that will display in the HAV.
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Step 5.3
(page
124)

Select data filters.

Step 5.4
(page
129)

Specify the sort order.

The Status box at the bottom of the tab displays your selections. During runtime these selections will
be implemented.

Step 5.1. Make General Specifications
General specifications on the Historical Alarm Viewer Properties dialog box SQL tab apply to all

connection selections.
A

Record Limit

Maximum number of records in the Record Limit field.
If the log contains more records than the maximum number of records, the HAV deals with the first
records up to the limit.
The filter and the sort specified through the SQL tab influence the records that are initially used.
Default
B

5000

Enable Most Recent

Do one of the following.
• Clear Enable Most Recent
The Time Amount and Time Units fields are disabled.
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The logged data that displays starts when the Historical Alarm Viewer Control is opened.
• Check Enable Most Recent
The Time Amount and Time Units fields are enabled.
Enter the time span for the Historical Alarm Viewer display as follows.

C

Time Amount

Number of selected units, e.g. 5 (seconds).

Time Units

Choose:
◦ Seconds
◦ Minutes
◦ Hours
◦ Days

Copy/paste text in the status box

Note: You can copy the data in the Status box.
Do one of the following to select the text.
• Click the right-mouse button over the text; select Select all on the Popup menu.
• Click the right-mouse button over selected text; select Copy on the Popup menu.
You can paste the selection the same way you paste a text selection in the Windows environment.

Step 5.2. Select the Fields that will Display in the HAV
Tip: Check Show Toolbar (page 115) on the General tab so a runtime user can influence the
record selection by adding a filter and changing the record sort order.
Click Select Fields on the SQL tab in the Historical Alarm Viewer Properties dialog box.
The Select Fields to view dialog box opens.
Do one of the following.
Select all fields in the table.
(page
122)
Select some fields in the table.
(page
123)

1. Select all Fields in the table
You can quickly select to display all of the columns in the Historical Alarm Viewer, as follows.
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Feature

Description

1

Select all fields in the
table.

(Default) Check to select all of the fields at one time.

2

Available Fields

The list of available fields is disabled; their static position in the Historical Alarm
Viewer cannot be changed.

3

SQL Clause

The SELECT* clause includes all fields.

2. Select some fields in the table
Note: The fields that are available (page 143) are based on selections on the Connection
tab's CIMPLICITY Project to connect to field and Table to View drop down list
You can select the columns that will display in the Historical Alarm Viewer, as follows.

Feature
1

Select all fields
in the table.

Description
Clear to select individual fields.
Tip: If you want to change the static position of the fields in the Historical Alarm
Viewer, clear the checkbox and select the fields individually.
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Feature

Description

2

Available Fields

Check the fields that should display in the Historical Alarm Viewer.

3

Up/Down
buttons

To change the position of a field in the Historical alarm viewer.
a. Select the field.
b. Click one of the buttons to do the following.

4

SQL Clause

(Read-only) The SELECT statement displays the selected fields in the order they will
display in the Historical Alarm Viewer.

Step 5.3. Select the Data Filters
Click More Filters on the SQL tab in the Historical Alarm Viewer Properties dialog box.
The Edit Filters dialog box opens.
The fields that display in the Fields dialog box are based on your Connection tab CIMPLICITY
Project to connect to and Table to View selections.
The Edit Filters dialog box provides the tools to define all filters, as follows.

rect 0, 54, 29, 83 (page 125)
rect -1, 157, 38, 196 (page 128)
rect -2, 280, 45, 317 (page 129)
A
(page
125)

Add conditions.

B
(page
128)

Construct the SQL clause.
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C
(page
129)

Review the SQL clause.

Add conditions.
A

Add conditions.

1. Select a field in the Files box.
Note: If you are going to construct statements such as AND, OR, select the fields for those
statements in the order they will be used.
2. Click Add Condition.
A Select Values dialog box opens with fields that relate to your selection.
3. Enter the value(s) against which data will be evaluated and filtered.
Criteria types are as follows.
• Time criteria
• Alarm state criteria
• Other alarm criteria
Time Criteria
A Select Values dialog box provides the following options for fields that require date and time
specifications.
Data that meets the date and time specifications passes the filter.
Check

Displays

One of the following:
• Less Than
• Greater Than

Displays a single date and time field for the date that will be referenced.

Important: Do not use Equals with a time stamp.
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Check

Displays

• Between

Two date and time fields for the date/time range that will be referenced.

• Null

No time fields are required.

Note: Click the down arrow to the right of a date field to display a calendar.

Alarm State Criteria
Alarm State criteria are available for the Database Logger ALARM_LOG table.
Checked values pass the filter.
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Other alarm criteria
Other alarm criteria include:
Data is evaluated alphanumerically. Data that meet the specifications passes the filter.
Check

Displays

One of the following:
• Equals
• Less Than
• Greater Than

Displays a criterion field for the value that will be referenced.

.
• Between

Two criteria fields for the value range that will be referenced.
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Check
• Null

Displays
No criteria fields are required.

The selected field is entered in the Select records where box.
Construct the SQL clause.
B

Construct the SQL clause.

By default, each field is added to the Select records where box as an AND criteria. The alarm will
have to fulfill that criteria and others on the list.
You can create statements to change how the list will be filtered.
1. Select a field in the Select records box.
2. Click any of the following to construct the SQL clause.
Button Name

Button

Modify
Remove
And
Or
NOT
Parentheses

Note: You can copy the data in the Status box.
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Review the SQL clause.
C

Review the SQL clause

The SQL Clause that you create displays in the read-only SQL Clause box.
When you close the Edit Filters dialog box, the clause also displays in the read-only box on the SQL
tab.

Step 5.4. Specify the Sort Order
Click Sort on the SQL tab in the Historical Alarm Viewer Properties dialog box.
The Select sort criterion dialog box opens.
The fields that display in the Sort by dialog box are based on your Connection tab CIMPLICITY
Project to connect to and Table to View selections.
Select the runtime sorting priorities, as follows.

Sort
Criterion

Feature

Description

A

Sort by

Check the fields that will be included in the criteria for sorting.

B

Ascending/
Descending

Check one to sort the fields: Ascending or Descending.

C

Up/Down

Moves a selected field up or down in the list. The sort begins with the first selected field in
the list; the next sort is the second selected field; sorts continue until the last selected field
is sorted.

D

SQL
Clause

(Read-only) The clause that defines the sorting priority displays.
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Step 6. Select Column Justification
The default Historical Alarm Viewer column justification is right, the standard justification for
numbers. You can change the default or re-select the default.
1. Select the Columns tab.

2. Choose among the following justification options:
Option

Description
General Justification
Left Justification
Right Justification

General Justification

A

Text is left justified

B

Numbers are right justified.

Left Justification

Numbers are right; text is left
Numbers and text are left.
Numbers and text are right.
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Right Justification

Step 7. Configure Row Styles
Step. 7 Configure Row Styles
The default display for rows is as follows.
If Use Ambient Properties on the General tab:

Rows Display using:

Not checked

System colors

Checked

Using the Ambient colors

If you want rows that meet certain conditions to display differently, you can select the Row Styles
tab.
Configuration steps are as follows:
Step 7.1
(page
132)

Add/remove rows styles.

Step 7.2
(page
133)

Configure Row Style 1 and Row Style 2.

Step 7.3
(page
135)

Configure addition row styles.
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Step 7.1. Add/Remove Row Styles
• Add a row style
• Remove a row style
Add a Row Style
1. Click the Add Style button.
An additional Row Style set is added to the list.
2. Continue to add as many styles as you think you need to highlight different runtime conditions.
As soon as a row style is added, its colors (page 133) can be selected and conditions (page
135) defined for runtime display.

Remove a Row Style
1. Select the Row Style <n> line for the row style you want to remove.
The button becomes a Remove Style button.
2. Click Remove Style.
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The style is removed.

Step 7.2. Configure Row Style Foreground and Background Colors
Select the foreground color for a Row Style.
(page
133)
Select the background color for a Row Style.
(page
134)

1. Select the Foreground Color for a Row Style
a. Select Foreground Color under a Row Style
A color square displays to the right of the Row Style box.
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b. Right-click the Square.
An Advanced Color Palette opens.
c. Select the foreground (font) color.

d. Click OK.
The color that displays in the Select Foreground Color is the font color for that row style.

2. Select the Background Color for a Row Style
Select Background Color and repeat the process above to specify the background color for the
selected Row Style.
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Step 7.3. Select Conditions for Row Styles
• Row style condition configuration.
• Guidelines for row styles.
• Row style condition example.
Row Style Condition Configuration
You can highlight selected conditions in the Historical Alarm Viewer by assigning them colors, as
follows.
1. Select Conditions under a Row Style.
An Add Condition button displays.
2. Click Add Condition.

A Select Fields browser opens.
3. Select a condition.
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4. Click OK.
The condition displays in the Row Style tree.
5. Do the following:

A

Select the condition. An Enter Value field displays on the Row Styles tab.

B

Enter a value in the Enter Value field

6. Repeat this procedure for Row Style 2 if you want to display a second customized row style.
During runtime rows that meet the specified conditions displays the row style for that condition.
Guidelines for row styles
• Available conditions depend on your CIMPLICITY Project to connect to and Table to View
selections on the Historical Alarm Viewer Properties' Connection tab.
• You can add more than one condition to a row style. The list of conditions will be included in an
AND clause. Runtime values will have to meet all criteria to display the row style.
• When you select a condition, a Remove Condition button displays; click Remove Condition to
remove the selected condition from the list.
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• If a value meets all the conditions for more than one row style, the last row style with conditions
that are met is applied to the row.
Row Style Condition Example
• Row Style 1 and Row Style 2 each have 1 condition
Style

Condition

Foreground

Background

Value

Row Style 1

value

White

Red

17500

Row Style 2

tagname

White

Blue

LEVELT101

• The alarm HEAT101 meets the condition for both row styles.
• The row for HEAT101 displays the Row Style 2

style.

Step 8. Specify Runtime Configuration Capability
The Runtime tab contains viewer options that you can enable for runtime.
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rect -1, 54, 116, 76 (page 138)
rect 0, 75, 117, 97 (page 139)
rect 1, 101, 143, 123 (page 140)
rect -2, 124, 140, 146 (page 141)
rect -3, 144, 139, 166 (page 142)
A
(page
138)

Enable Export

B
(page
139)

Enable Field Selection

C
(page
140)

Enable Filter Selection

D
(page
141)

Enable Sort Selection

E
(page
142)

Enable Printing

Enable Export
A

Enable Export

Runtime users can save the Historical Alarm Viewer screen as a .txt or .csv file.
1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.
2. Select Export on the Popup menu.
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A Save As dialog box opens.
3. Save the Historical Alarm Viewer report as a .csv or .txt file.
Note: The file is saved by default as a .txt file. If you want to save it as a .csv file, enter the
full name with the extension in the File name field.

The report is saved in the format you specify and can be opened in a .txt or .csv application.

Enable Field Selection
B

Enable Field Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.
2. Select Select Fields on the Popup menu.
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A Select fields to view dialog box opens. Fields can be added, removed, moved to the left or right on
the screen.

Enable Filter Selection
C

Enable Filter Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.
2. Select Select Filters on the Popup menu.

An Edit Filters dialog box opens.
The SQL clause can be modified to change the criteria for which alarms display in the Historical
Alarm Viewer.
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Note: Review a required SQL query if the Historian ihRawData table is selected.

Enable Sort Selection
D

Enable Sort Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.
2. Select Select Sorting on the Popup menu.

A Select sort criterion dialog box opens.
The current priorities for sorting the list can be changed.
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Enable Printing
E

Enable Printing

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.
2. Select Print on the Popup menu.

A Page Setup dialog box opens.
3. Select print criteria that reflect your Historical Alarm Viewer size and printer specifications.

4. Click OK.
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A Print Preview window opens.

5. Click the Print button on the Preview window toolbar when you are ready to print one or more
pages.
A Print dialog box opens.
6. Click Print to print a selected page range.

Technical Reference: Historical Alarm Viewer
Technical Reference: Historical Alarm Viewer
The Historical Alarm Viewer provides several options for displaying data during runtime.
Fields that are available are based on your CIMPLICITY Project to connect to and Table to View
selections on the Historical Alarm Viewer Properties' Connection tab.
1
(page
143)

Default Historian tables and field options

2
(page
154)

<Local> or <Project Name> tables and field options

1. Default Historian Tables and Field Options
1. Default Historian Tables and Field Options
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Table views that are available when you select Default Historian in the CIMPLICITY Project to
connect to on the Historical Alarm Viewer Properties dialog box Connection tab, are as follows.
Each table view provides related fields.
1.1
(page
144)

Default Historian\ihAlarms fields

1.2
(page
145)

Default Historian\ihArchives fields

1.3
(page
146)

Default Historian\ihCalculationDependencies fields

1.4
(page
146)

Default Historian\ihCollectors fields

1.5
(page
148)

Default Historian\ihComments fields

1.6
(page
148)

Default Historian\ihMessages fields

1.7
(page
149)

Default Historian\ihQuery fields

1.8
(page
149)

Default Historian\ihRawData fields

1.9
(page
150)

Default Historian\ihTags fields

1.10
(page
152)

Default Historian\ihTrend fields

1.1. Default Historian\ihAlarms Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihAlarms are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
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Criteria Type
Time

Fields
StartTime
EndTime
AckTime
Timestamp

Other

AlarmID
ItemID
Source
DataSource
Tagname
AlarmType
EventCategory
Condition
SubCondition
Message
Acked
Severity
Actor
Quality
RowCount

1.2. Default Historian\ihArchives Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihArchives are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
StartTime
EndTime
LastBackup
LastModified
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Criteria Type
Other

Fields
ArchiveName
ArchiveStatus
FileName
IsCurrent
IsReadOnly
FileSizeCurrentDisk
FileSizeCurrent
FileSizeTarget
LastBackupUser
LastModifiedUser
TimeZone
DaylightSavingTime
RowCount

1.3. Default Historian\ihCalculationDependencies Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihCalculationDependencies are selected on the Connection tab in the Historical
Alarm Viewer Properties dialog box.
Criteria Type
Other

Fields
Tagname
DependentTagname
RowCount

1.4. Default Historian\ihCollectors Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihCollectors are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
LastModified
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Criteria Type
Other

Fields
CollectorName
CollectorDescription
Comment
ComputerName
Status
CollectorType
MinimumDiskFreeBufferSize
MaximumMemoryBufferSize
ShouldAdjustTime
ShouldQueueWrites
CanBrowseSource
CanSourceTimestamp
StatusOutputAddress
RateOutputAddress
HeartbeatOutputAddress
ColllectorGeneral1
CollectorGeneral2
CollectorGeneral3
CollectorGeneral4
CollectorGeneral5
LastModifiedUser
SourceTimeInLocalTime
CollectionDelay
DefaultTagPrefix
DefaultCollectionInterval
DefaultCollectionType
DefaultTimeStampType
DefaultLoadBalancing
DefaultCollectorCompression
DefaultCollectorCompressionDeadband
DefaultCollectorCompressionTimeout
DefaultCollectorAbsoluteDeadbanding
DefaultCollectorAbsoluteDeadband
DisableOnTheFlyTagChanges
DefaultSpikeLogic
DefaultSpikeMultiplier
DefaultSpikeInterval
RedundancyEnabled
PrincipalCollector
IsActiveRedundantCollector
FailoverOnCollectorStatus
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1.5. Default Historian\ihComments Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihComments are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
Timestamp
StoredOnTimeStamp
CommentTimeStamp

Other

Tagname
SuppliedUsername
Username
Comment
DataTypeHint
SamplingMode
Direction
NumberofSamples
IntervalMilliseconds
CalculationMode
FilterTab
FilterMode
FilterComparisonMode
FilterValue
TimeZone
DaylightSavingTime
RowCount

1.6. Default Historian\ihMessages Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihMessages are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
TimeStamp
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Criteria Type
Other

Fields
Topic
Username
MessageNumber
MessageString
TimeZone
DaylightSavingTime
RowCount

1.7. Default Historian\ihQuerySettings Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihQuerySettings are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
StartTime
EndTime

Other

SamplingMode
Direction
NumberOfSamples
IntervalMilliseconds
CalculationMode
FilterTag
FilterMode
FilterComparisonMode
FilterValue
TimeZone
DaylightSavingTime
RowCount

1.8. Default Historian/ihRawData Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihRawData are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
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Criteria Type

Fields

Time

TimeStamp

Other

Tagname
Value
Quality
OPCQualityValid
OPCQuality
SamplingMode
Direction
NumberOfSamples
IntervalMilliseconds
CalculationMode
FilterTag
FilterMode
FilterComparisonMode
FilterValue
TimeZone
DaylightSavingTime
RowCount

Important: If you choose the ihRawData table, modify the Query (Data filters) to the
following.
SELECT * FROM "ihRawData" WHERE "timestamp">='<Date><Time>' and
("SamplingMode"='''interpolated''') ORDER BY "timestamp" DESC

Example
SELECT * FROM "ihRawData" WHERE "timestamp">='2008-05-17 20:01:09' and
("SamplingMode"='''interpolated''') ORDER BY "timestamp" DESC

1.9. Default Historian\ihTags Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihTags are selected on the Connection tab in the Historical Alarm Viewer Properties
dialog box.
Criteria Type
Time

Fields
LastModified
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Criteria Type
Other

Fields
Tagname
Description
EngUnits
Comment
DataType
FixedStringLength
CollectorName
SourceAddress
CollectionType
CollectionInterval
CollectionOffset
LoadBalancing
SpikeLogic
SpikeLogicOverride
TimeStampType
HiEngineeringUnits
LoEngineeringUnits
InputScaling
HiScale
LoScale
CollectorCompression CollectorDeadbandPercentRange
ArchiveCompression
ArchiveDeadbandPercentRange
CollectorGeneral1
CollectorGeneral2
CollectorGeneral3
CollectorGeneral4
CollectorGeneral5
ReadSecurityGroup
WriteSecurityGroup
AdministratorSecurityGroup
Calculation
LastModifiedUser
CollectorType
StoreMilliseconds
UTCBias
AverageCollectionTime
CollectionDisabled
CollectorCompressionTimeout
ArchiveCompressionTimeout
TimeZone
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1.10. Default Historian/ihTrend Fields
The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihTrend are selected on the Connection tab in the Historical Alarm Viewer Properties
dialog box.
Criteria Type
Time

Fields
TimeStamp
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Criteria Type
Other

Fields
SamplingMode
Direction
NumberOfSamples
IntervalMilliseconds
CalculationMode
FilterTag
FilterMode
FilterComparisonMode
FilterValue
TimeZone
DaylightSavingTime
RowCount
TagID.Value
TagID.Quality
TagID.Tagname
TagID.Description
TagID.EngUnits
TagID.Comment
TagID.DataType
TagID.FixedStringLength
TagID.CollectorName
TagID.SourceAddress
TagID.CollectionType
TagID.CollectionInterval
TagID.CollectionOffset
TagID.LoadBalancing
TagID.SpikeLogic
TagID.SpikeLogicOverride
TagID.TimeStampType
TagID.HiEngineeringUnits
TagID.LoEngineeringUnits
TagID.InputScaling
TagID.HiScale
TagID.LoScale
TagID.CollectorCompression
TagID.CollectorDeadbandPercentRange
TagID.ArchiveCompression
TagID.ArchiveDeadbandPercentRange
TagID.CollectorGeneral1
TagID.CollectorGeneral2
TagID.CollectorGeneral3
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2. <Local> or <Project Name> Tables and Field Options
2. <Local> or <Project Name> Tables and Field Options
Table views that are available when you select <local> or a project name in the CIMPLICITY
Project to connect to on the Historical Alarm Viewer Properties dialog box Connection tab, are as
follows.
Each table view provides related fields.
2.1
(page
154)

< Local> or <Project Name>\ALARM_LOG fields

2.2
(page
155)

< Local> or <Project Name>\DATA_LOG fields

2.3
(page
155)

< Local> or <Project Name>\EM_LOG fields

2.4
(page
156)

< Local> or <Project Name>\EVENT_LOG fields

2.5
(page
156)

< Local> or <Project Name>\Historian alarms fields

2.6
(page
157)

< Local> or <Project Name>\Historian data fields

2.1.< Local> or <Project Name>\ALARM_LOG Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and ALARM_LOG are selected on the Connection tab in the Historical Alarm
Viewer Properties dialog box.
Criteria Type
Time

Fields
timestamp
timestamp_utc
generation_time
generation_time_utc
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Criteria Type
Alarm State

Fields
prev_state
log_action
final_state

Other

sequence_number
alarm_id
alarm_class
resource
logged_by
reference
prev_state
log_action
alarm_message

2.2.< Local> or <Project Name>\DATA_LOG Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and DATA_LOG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type

Fields

Time

timestamp

Other

point_id
_VAL

2.3.< Local> or <Project Name>\EM_LOG Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and EM_LOG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
timestamp
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Criteria Type
Other

Fields
sequence_number
time
event_type
event_source
action_type
action_target

2.4.< Local> or <Project Name>\EVENT_LOG Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and EVENT_LOG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
Criteria Type
Time

Fields
timestamp
generation_time

Other

sequence_number
alarm_id
alarm_class
resource
logged_by
reference
alarm_message

2.5. <Local> or <Project Name>\Historian Alarms Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and Historian Alarms are selected on the Connection tab in the Historical
Alarm Viewer Properties dialog box.
Criteria Type
Time

Fields
StartTime
EndTime
ActTime
Timestamp
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Criteria Type
Other

Fields
AlarmID
ItemID
Source
DataSource
Tagname
AlarmType
EventCategory
Condition
SubCondition
Message
Acked
Severity
Actor
Quality
RowCount

2.6. <Local> or <Project Name>\Historian Data Fields
The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and Historian Data are selected on the Connection tab in the Historical Alarm
Viewer Properties dialog box.
Criteria Type
Time

Fields
TimeStamp
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Criteria Type
Other

Fields
Tagname
Value
Quality
OPCQualityValid
OPCQuality
SamplingMode
Direction
NumberOfSamples
IntervalMilliseconds
CalculationMode
FilterTag
FilterMode
FilterComparisonMode
FilterValue
TimeZone
DaylightSavingTime
RowCount

Chapter 8. OPC Alarm and Event Server and
Client
About the OPC Alarm and Event Server and Client
• OPC Alarm and Event Server and Client Overview
• OPC Alarm and Event Server and Client Steps

OPC Alarm and Event Server and Client Overview
CIMPLICITY provides you with an OPC Alarm and Event (A & E) Server and Client.
Note: The CIMPLICITY OPC Alarm and Event Server and Client are most commonly used to
send data to and receive data from non-CIMPLICITY OPC Alarm and Event Clients and Servers.
The server and client interaction occurs basically as follows.

1

OPC Alarm and Event Client (clients) starts and starts the OPC Alarm and Event Server (OPC servers), if it is not
already running.

2

Server requests data from the Alarm Managers in all connected source projects.
Note: Source projects are selected in the server configuration and need to be running in order to be
connected.

3

Alarm Managers send data to the server.

4

Server sends alarm data to its clients.

5

Clients display the data in the Alarm Viewer and notify the server if alarms are acknowledged..

6

Server transmits the information to the source projects.
3-6 continues with data being passed back and forth through the OPC Alarm and Event Server.

OPC Alarm and Event Server and Client Steps
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Step 1
(page
161)

Configure the OPC Alarm and Event Server.

Step 2
(page
167)

Configure the OPC Alarm and Event Client.

Step 3
(page
183)

Use the OPC Alarm and Event Client and Server at runtime.

Tip: CIMPLICITY also provides the powerful CIMPLICITY Enterprise functionality to send
and receive alarm and point data between CIMPLICITY projects.

Alarm Categories for an OPC Alarm and Event Server
These are the categories of CIMPLICITY alarm messages that passed as OPC alarm messages:
Category
Level

Used for
Non-Boolean point alarms
Text messages come from the alarm strings definition used by the alarm.

Discrete

Boolean point alarms
Text messages come from the alarm strings definition used by the alarm.

System

All non-point alarms
Non-point alarms have a configurable severity. This severity is used by the OPC server as the subcondition System severity.
Note: Existing non-point alarms have a default severity of 100.

Configure the OPC Alarm and Event Server and Client
Configure the OPC Alarm and Event Server and Client
Step 1
(page
161)

Configure the OPC Alarm and Event Server.

Step 2
(page
167)

Configure the OPC Alarm and Event Client.
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Step 3
(page
183)

Use the OPC Alarm and Event Client and Server at runtime.

Step 1. Configure the OPC Alarm and Event Server
Step 1. Configure the OPC Alarm and Event Server
Following are steps for configuring the OPC Alarm and Event Server.
Step 1.1
(page
161)

Open the OPC Alarm and Event Server Window.

Step 1.2
(page
162)

Configure projects.

Step 1.3
(page
164)

Apply the changes to the OPC Alarm and Event Server.

Step 1.4
(page
165)

Configure the OPC Alarm and Event Server sampling rate.

Step 1.5
(page
166)

Select trace options.

Step 1.6
(page
166)

Close the OPC Alarm and Event Server.

Step 1.1. Open the OPC Alarm and Event Server Window
1. Click Start on the Windows task bar.
2. Select (All) Programs>HMI SCADA - CIMPLICITY version>A&E OPC Server.

The OPC Alarm and Event Server window opens.
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Step 1.2. Configure Projects
Step 1.2. Configure Projects
Step 1.2.1
(page
162)

Open the Security dialog.

Step 1.2.2
(page
163)

Add a project.

Step 1.2.1. Open the Security Dialog
1. Click Settings on the OPC Alarm and Event Server window menu bar.
2. Select Configure Projects...

The Security Dialog opens.
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Buttons do the following:
Button

Click to

OK

Close the Security Dialog.

Cancel

Close the Security Dialog and cancel your changes.

Add

Add a new project to the OPC Alarm and Event Server.

Details

Edit the configuration for an connected project.

Step 1.2.2. Add a Project
1. Click Add in the Security Dialog.
A blank Project Properties dialog box opens.
2. Fill in the fields, as follows.

Field
Project name

Description
Project that will be connected to the OPC Alarm and Event Server.
Note: Running projects are included in the drop-down list.
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Field

Description

User name

CIMPLICITY project user selected to access data on the OPC Alarm
and Event Server.

Password

Password assigned to the user in the CIMPLICITY project.

Confirm password

Repeat of entered password.

3. Click OK.
The OPC Alarm and Event Server will collect data from the configured project that displays in

the list in the Security Dialog.
4. Continue to add projects until all the projects that should be connected to this server are
connected.

Step 1.3. Apply the Changes to the OPC Alarm and Event Server
1. Click OK in the Security Dialog when you have completed adding projects to the OPC Alarm
and Event Server.

• The Security Dialog closes.
• The OPC Alarm and Event Server window opens.
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2. Click OK.
The message closes.
Important: This list is for Server projects only. Do not add the client project to the Security
dialog.

Step 1.4. Configure the OPC Alarm and Event Server Sampling Rate
1. Click Settings on the OPC Alarm and Event Server menu bar.
2. Select Options...

The OPC Server Options dialog box opens.
3. Configure the fields as follows.

Field
Statistics sample period

Description
Number of milliseconds the server waits between samples
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Field
Namespace delimiter

Description
The character inserted in the fully qualified alarm name to
define a space between elements. Alarms that an OPC A & E
server collects must be configured on an OPC Client in order
for the values to display in the client's Alarm Viewer. The fully
qualified name is Source Project/Factory Resource/Reference
ID/Alarm ID

Display server window

Do either of the following: Select the Display the Server check
box when it is started by the client, or clear the Hide the Server
check box when it is started by the client.

Step 1.5. Select Trace Options
1. Select Trace on the OPC Alarm and Event Server window menu bar.
The Trace menu displays.
2. Select options as follows.

• Select one: None, Connect, Server, Subscription, Event, All
• Set Trace File...
• Enable COM Call Tracing

Step 1.6. Close the OPC Alarm and Event Server
1. Click File on the OPC Alarm and Event Server menu.
2. Select Exit.

When you restart the Server the security configuration will be applied.
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Note: The connection to the OPC Alarm and Event Server is controlled using COM security.

Step 2. Configure the OPC Alarm and Event Client
Step 2. Configure the OPC Alarm and Event Client
Alarms and events from OPC servers are created dynamically based on configuration for the
following alarms.
Alarm

Dynamically creates

$OPC_MODEL_ALARM

Point alarms

$OPC_MODEL_EVENT

Events

You can:
• Modify the alarms to change the default behavior.
• View alarms that are collected by any connected OPC Alarm and Event Server in the
CIMPLICITY project's Alarm Viewer.
• Configure individual qualified source alarms on the client computer.
• Log alarms to the Alarm log and events to the Event log.
Step 2.1
(page
167)

Open an OPC A&E client dialog box.

Step 2.2
(page
169)

Create a new connection to an OPC Alarm and Event Server.

Step 2.3
(page
176)

(Optional) Modify source alarms logging and deletion requirements for the client display.

Step 2.4
(page
179)

(Optional) Configure source alarms on the client computer.

Step 2.1. Open an OPC A&E Client Dialog Box
Step 2.1. Open an OPC A&E Client Dialog Box
Option
2.1.1 (page
168)

Open a new OPC A&E Client dialog box.
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Option
2.1.2 (page
169)

Open an existing OPC A&E Client dialog box.

Option 2.1.1. Open a New OPC A&E Client Dialog Box
CIMPLICITY provides several methods to open a new OPC A&E Client dialog box.
1. Select Project > Alarms > Alarm OPC Client in the Workbench left pane.
2. Do the following.

A

Click File>New on the Workbench menu bar.

B

Click the New Object button on the Workbench toolbar.

C

In the Workbench left pane, double click Alarm OPC Client.

D
In the Workbench right pane:
a. Right-click any OPC Client.
b. Select New on the Popup menu.
E

Press Ctrl+N on the keyboard.

A New OPC A&E Client dialog box opens when you use any method.
3. Enter a name in the New OPC A&E Client dialog box.

The name will be used as the reference id for alarms gathered by the client.
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4. Click OK.
The OPC A&E Client dialog box opens.
Option 2.1.2. Open an Existing OPC A&E Dialog Box
CIMPLICITY provides several methods to open an existing OPC A&E dialog box.
1. Select Project > Alarms > Alarm OPC Client in the Workbench left pane.
2. Select an OPC A&E client configuration in the Workbench right pane.
3. Do the following.

A

Click Edit>Properties on the Workbench menu bar.

B

Click the Properties button on the Workbench toolbar.

C

In the Workbench left pane:
a. Right-click Alarm OPC Client.
b. Select Properties on the Popup menu.

D

In the Workbench right pane, double click an OPC A&E client configuration.

E

Press Alt+Enter on the keyboard.

The selected OPC A&E Client dialog box opens when you use any method.

Step 2.2. Select the Client Alarm Viewer Display Criteria
Step 2.2. Select the Client Alarm Viewer Display Criteria
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Step 2.2.1
(page
170)

Create a new connection to an OPC Alarm and Event Server.

Step 2.2.2
(page
171)

Filter alarms that display in the A & E OPC client Alarm Viewer.

Step 2.2.3
(page
172)

Change attribute display in the Alarm Viewer message field.

Step 2.2.1. Create a New Connection to an OPC Alarm and Event Server
1. Fill in the fields in the OPC A&E Client dialog box as follows.
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Option
Server

Description
The OPC Alarm and Event Server that this client connects to. The server can be selected by doubleclicking one of the configured OPC Alarm and Event Servers that display in the Server list in the
bottom half of the OPC A&E Client dialog box.
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Option
Node

Description
The computer name on which the server is located.
Note:
• If the OPC Alarm and Event Server is on the local computer, the Node field can be blank.
• One client can connect to one OPC Server. If you have multiple OPC Servers, create multiple
OPC clients.

Resource
ID

Factory resource the OPC Alarm and Event Server will use to collect alarm data.

Filter

Opens the OPC Filter window (page 171) to select alarm filter criteria.

Message

Attribute entries configure the alarm message that displays for the source alarms.

Fields

Opens the OPC Fields browser (page 172) to list the attributes that can be selected for the
Message field.

Refresh

Refreshes the display.

2. Click OK.
The OPC A&E Client dialog closes.
Alarms from projects that are configured for the OPC Alarm and Event Server will display in the
client's Alarm Viewer.
When there is no filter all of the alarms generated on the source and client computers display in the
Alarm Viewer.

A

Alarms from a source project.

B

Alarms from a client project

C

Alarms from a source project.

Step 2.2.2. Filter Alarms that Display in the A & E OPC Client Alarm Viewer

1. Click the Filter button

in the OPC A&E Client dialog box.
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The OPC Filter window opens.
2. Select the following.

Window
area
Areas and
Sources

Description
Are created dynamically as the alarms are generated. If the alarms have not been generated then
they will not show in the list of areas and sources. If there are no selections, all alarms display in
the Alarm Viewer. You can select sources or areas for which you want to receive alarms.
A
S

Categories

Check which categories to receive. If there are no selections all categories will display.

Event Type

Types of alarms and events the should display: Simple, Condition, Tracking.

Severity
Range

Lowest and highest limits in the severity range (page 42) in which displayed alarms fall.

Your selections determine which alarms will display in the Alarm Viewer control.
Step 2.2.3. Change the Display in the Alarm Viewer Message Field
You can enhance or change the information that displays in the source projects message field.
1. Make sure that dynamic configuration is turned on in the client project, if the project is running.
2. Do any of the following:
• Add an attribute.
• Add text.
• Add text and attributes.
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• Leave the Message field blank.
Important: You can make multiple entries in the Message field. If you do leave spaces
between each selection, the spaces will display during runtime. However, the maximum alarm
message length is 73 characters, including the point ID (and spaces). If the message is longer,
the message will be truncated after 73 characters.

Add an attribute
The following attributes are available for the OPC Alarm and Event Client use.
• Category
• Condition
• Message
• Subcondition
When you enter an attribute in the Message field, make sure the attribute is enclosed in <>, e.g.
<Category>
Tip: Click the Fields button

to open the OPC Fields browser and select an attribute.

Values for the selected attributes will display in the message field during

runtime.
1

Fields and spaces configured for the OPC Alarm and Event Server alarm messages.

2

OPC Alarm and Event Server alarm fields and spaces display in the runtime Message column.

3

Alarm messages display for Client alarms during runtime.
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Add text
You can enter any text in the Message field.
The entered text will display in the alarm's Message field during

runtime.
1

Actual text that will display as the OPC Alarm and Event Server alarm message.

2

Actual text that displays as the OPC Alarm and Event Server alarm message during runtime
Note: The number of spaces between the text and sub-condition value correspond to the number of spaces
entered in the Message field during configuration.

3

Alarm messages display for Client alarms during runtime.

Add text and attributes
You can enter text and one or more attributes in the Message field.
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The entered text and values for the attributes display in the alarm's Message field during

runtime.
1

Actual text and sub-condition whose value will display as the OPC Alarm and Event Server alarm message.

2

Actual text and sub-condition value that display as the OPC Alarm and Event Server alarm message during runtime
Note: The number of spaces between the text and the sub-condition value correspond to the number of
spaces entered in the Message field during configuration.

3

Alarm messages display for Client alarms during runtime.

Leave the field blank
Entry in the Message field is optional. It can be left blank.
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The original message entered for the alarm

displays.
1

The Client has no configuration to override the original message for Server alarms.

2

Alarm messages configured in the Server projects display for the Server alarms during runtime

3

Alarm messages display for Client alarms during runtime.

Step 2.3. Modify Source Alarms Default Logging and Deletion Requirements for the Client
Display
Alarms and events from OPC servers are created dynamically based on the following alarms in the
client computer Alarms folder.
Alarm

Dynamically creates

$OPC_MODEL_ALARM

Point alarms

$OPC_MODEL_EVENT

Events
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You can modify these alarms to change the default behavior for the source alarms.
1. Double-click either $OPC_MODEL_ALARM or $OPC_MODEL_EVENT in the Alarms folder on the
client computer.
The Alarm Definition dialog box for the selected alarm opens.
2. Select the Alarm Definition tab.
3. Optional: Check one or more of the Alarm Logging options.

Alarm

Option

Description

Default Value

$OPC_MODEL_ALARM

Alarm
Logging

Alarms are logged to the Alarm log for checked
options.

All check boxes are
clear.

$OPC_MODEL_EVENT

Alarm
Logging

Event alarms are logged to the Event log for
checked options.

All check boxes are
clear.

Note: Do not change the Alarm class and Alarm type.
4. Select the Alarm Options tab.
5. Optional: Change default options to your system requirements.
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Letter
A

Alarm

Option

$OPC_MODEL_ALARM

Deletion requirements

B

Default Value

Acknowledge

Checked

Reset

Checked

Automatic actions
Printer repeat

<None>

Auto acknowledge

<None>

Auto reset

<None>

C

Manual reset allowed

Clear

D

Maximum stacked

0

A

B

$OPC_MODEL_EVENT

Deletion requirements
Acknowledge

Checked

Reset

Clear

Automatic actions
Printer repeat

<None>

Auto acknowledge

<Immediate>

Auto reset

<None>

C

Manual reset allowed

Clear

D

Maximum stacked

0

Important:
• If you change any of these requirements, e.g. check Manual reset allowed, you can delete
the Alarm from the client Alarm Viewer display. However, this action is not sent back
through the OPC server to the source project.
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• Change the default $OPC_MODEL_EVENT Auto acknowledge to <None> if you want
users to view event alarms in the client Alarm Viewer.

Step 2.4. Configure Source Alarms on the Client Computer
Step 2.4. Configure Source Alarms on the Client Computer
Step 2.4.1
(page
179)

Create source alarms on the client computer.

Step 2.4.2
(page
180)

Define source alarms on the client computer.

Step 2.4.1. Create Source Alarms on the Client Computer
You can also configure source alarms on the client computer if you know the following:
• Project names
• Factory resource IDs
• Alarm reference IDs
Note: A point alarm's reference ID is the point ID.
• Alarm IDs
This gives you more control over the alarm display.
1. Double-click Alarms in the left pane of the client project Workbench.

A New Alarm dialog box opens.
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2. Enter a fully qualified name for a source project alarm that will be viewed in the client's Alarm
Viewer.
Project/Factory Resource ID/Reference ID/Alarm ID.

Important: The fully qualified alarm ID:
• Must be a maximum of 255 characters or less.
• Cannot contain the characters: $, | or start with @.
Example
SNORTH/AANDE/SN5/SN5

Note: If a reference ID has not been specifically specified for the point it is the same as the
point ID.

The alarm can now be configured similar to a local alarm.
Step 2.4.2. Define Source Alarms on the Client Computer
1. Select the Alarm Definition tab in the Alarm Definition dialog box.
Options descriptions are:
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Field

Description

Description

Used to describe the alarm in the client project, e.g. in the Workbench right pane.

Alarm
class

Colors for states in the class that are recognized by the OPC A & E configuration display in the
Alarm Viewer.
Note: The class name does not have to be the same as the class used on the OPC A & E
server.

Alarm type

$CIMBASIC is the required entry.

Help file

(Optional) Name of a text file that users can display when they click the Help button in the Alarm
Viewer. You can enter a filename of up to 67 characters.

Severity

A number the identifies the importance of the alarm; the higher the number, the more severe the
state. This enables you to prioritize alarms.

Alarm
message

%s (lower case) is the required entry.

Alarm
Logging

Alarms are recorded in the client project's Alarm log, based on the checked conditions.

2. Select the Alarm Routing tab.
3. Make sure the alarms are routed to the role for the A & E OPC server user.
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4. Optional: Configure alarm options.
5. Click OK to close the Alarm Definition dialog box.
The qualified alarm displays the source alarm data that is recognized by the OPC Alarm and Event
configuration.
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1

Alarm IDs from Server projects display the same type of qualified name whether or not they have been defined in
the Client project.

2

The class assigned to the alarm ID in the client project is one of the following:
Alarm type
Auto qualified Server alarms
Qualified Server alarms
Client alarms
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3

The sub-condition that displays in the Sub-condition column reflects the alarm limits assigned in the alarm's source
project. The color assigned to the alarm ID (page 184) is based on the sub-condition for the assigned class and
the alarm state.
Alarm type
Auto qualified Server alarms
Qualified Server alarms
Client alarms

Step 3. Use the OPC Alarm and Event Client and Server at Runtime
Step 3. Use the OPC Alarm and Event Client and Server at Runtime
Step 3.1
(page
183)

Start the source and client projects.

Step 3.2
(page
184)

Use the OPC Alarm and Event Client Alarm Viewer.

Step 3.3
(page
185)

Review runtime statistics in the OPC Alarm and Event server window.

Step 3.4
(page
186)

Disconnect clients.

Step 3.1. Start the Source and Client Projects
1. Start the source project or projects.

2. Start the client project.
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The OPC Alarm and Event Server window opens on the server computer, if it is not already running.

Step 3.2. Use the OPC Alarm and Event Client Alarm Viewer
Open an Alarm Viewer control or the stand alone Alarm Viewer on the client computer.
The display reflects your configuration and the alarm source.
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1
(page
179)

Configured source: Alarm ID, Message, Class, Subcondition.

2
(page
176)

Source alarm: Alarm ID, Message, Class, Subcondition.

3
(page
176)

Source event: Alarm ID, Message, Class, Subcondition.

4

Client alarm: Alarm ID, Message, Class, Subcondition.

Step 3.3. Review Runtime Statistics in the OPC Alarm and Event Server Window
The OPC Alarm and Event Server window (page 161) displays statistics to inform you of client/
source projects alarm activity.
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Statistic

Describes Number of:

Sample Period (ms)

Milliseconds the server takes to collect data. At the end of the period, the data is displayed
in the Client Alarm Viewers.

Num Event Server
Objects

Internal events and alarms currently supported by the server.

Num Subscriptions

Clients that are running and being sent data from the server.

Num Browser Objects

Clients browsing for information.
Note: CIMPLICITY OPC Alarm and Event Server supports clients with browsing
functionality.

Num Events Generated

Changes of states; changes include alarms being activated and alarms acknowledged.

Num Client Notifications

Number of server to client notifications.

Num Events Last
Sample Period

Events the server collected during the specified sample period.
Example
The server collected 19 events during the last 1000 milliseconds, the length specified for the
server's sample period.

Step 3.4. Disconnect Clients
1. Click File on the OPC Alarm and Event Server window menu bar.
2. Select Request Clients to Disconnect.

All clients connected to the OPC Alarm and Event Server are disconnected for the sample period.
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At the end of the sampling period they are reconnected.

OPC Alarm and Event Server Technical Notes
• Redundant environments.
• DCOM configuration.
• OPC Alarm & Event server shortcut icon.

Redundant Environments
The OPC Alarm and Event Server should be run on a third computer in a redundant environment.
The OPC server will then fail over correctly
Note: If you try to configure an OPC Alarm and Event Server on the primary and secondary
computers, you will create a feedback loop that will fail.

DCOM Configuration
When you want the OPC Alarm and Event Clients to communicate with an off-node OPC Alarm and
Event Server, configure the same DCOM configuration for the OPC Alarm and Event Server and
OPCEnum as you do for the CIMPLICITY OPC Server.
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OPC Alarm & Event Server Shortcut Icon
You can place a shortcut ic...to open the OPC Alarm & Event server.
When the OPC Alarm & Event server opens it:
• Reads project configuration at startup and populates the server configuration database.
• Sets its status to OPCAE_STATUS_NOCONFIG until all configuration information is
processed.
• Sets the status to OPCAE_STATUS_RUNNING when it is ready.
• Updates its configuration as projects are added and removed and in addition processes dynamic
configuration notifications from the projects to keep its own configuration database up-to-date.
Important: A&E OPC Clients should not use the A&E OPC Server while the status is
OPCAE_STATUS_NOCONFIG.
Make sure the server status is OPCAE_STATUS_RUNNING before attempting to set a filter.

